Bug 370724 - Window manager restarts
Summary: Window manager restarts
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.7.4
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-10-14 04:16 UTC by Hector Gonzalez
Modified: 2016-10-14 05:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hector Gonzalez 2016-10-14 04:16:13 UTC
Application: kwin_x11 (5.7.4)

Qt Version: 5.6.1
Frameworks Version: 5.26.0
Operating System: Linux 4.7.5-2 x86_64
Distribution: Debian GNU/Linux testing (stretch)

-- Information about the crash:
- What I was doing when the application crashed: I was openining a preference window from a plasma widget when the window manager restarted

- Unusual behavior I noticed: the window manager stopped

- Custom settings of the application: None

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f85bc203940 (LWP 2670))]

Thread 7 (Thread 0x7f85a7fff700 (LWP 2900)):
#0  0x000000386f4e1253 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x000000312a0d6d3f in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x000000312a0d87e4 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x000000312a0d8cfa in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x000000312a08319a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x0000003129ea8e53 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x0000003d064c8a55 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x0000003129eadd78 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x000000386fc07464 in start_thread (arg=0x7f85a7fff700) at pthread_create.c:333
#9  0x000000386f4e897f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 6 (Thread 0x7f85a77fe700 (LWP 2720)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x000000313bf7c574 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#2  0x000000313bf7c5b9 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#3  0x000000386fc07464 in start_thread (arg=0x7f85a77fe700) at pthread_create.c:333
#4  0x000000386f4e897f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 5 (Thread 0x7f85b0fcc700 (LWP 2716)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f85b2134493 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#2  0x00007f85b2133bd7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#3  0x000000386fc07464 in start_thread (arg=0x7f85b0fcc700) at pthread_create.c:333
#4  0x000000386f4e897f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 4 (Thread 0x7f85b37fe700 (LWP 2713)):
#0  0x000000386f4e1253 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x000000312a0d6d3f in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x000000312a0d87e4 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x000000312a0d8cfa in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x000000312a08319a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x0000003129ea8e53 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x0000003d064c8a55 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x0000003129eadd78 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x000000386fc07464 in start_thread (arg=0x7f85b37fe700) at pthread_create.c:333
#9  0x000000386f4e897f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 3 (Thread 0x7f85ba045700 (LWP 2701)):
#0  0x000000386f4e1253 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x000000312a0d6d3f in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x000000312a0d87e4 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x000000312a0d8cfa in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x000000312a08319a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x0000003129ea8e53 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x000000312ba15525 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x0000003129eadd78 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x000000386fc07464 in start_thread (arg=0x7f85ba045700) at pthread_create.c:333
#9  0x000000386f4e897f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 2 (Thread 0x7f85bb70a700 (LWP 2694)):
#0  0x000000386f4df50d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x000000387340c150 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x000000387340dee9 in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f85bbf71a79 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x0000003129eadd78 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x000000386fc07464 in start_thread (arg=0x7f85bb70a700) at pthread_create.c:333
#6  0x000000386f4e897f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 1 (Thread 0x7f85bc203940 (LWP 2670)):
[KCrash Handler]
#6  0x0000003d064b3e50 in QQmlBinding::write(QQmlPropertyData const&, QV4::Value const&, bool, QFlags<QQmlPropertyPrivate::WriteFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x0000003d064b4ba7 in QQmlBinding::update(QFlags<QQmlPropertyPrivate::WriteFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x0000003d064be705 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x0000003d0644852e in QQmlComponentPrivate::complete(QQmlEnginePrivate*, QQmlComponentPrivate::ConstructionState*) () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#10 0x0000003d064485f7 in QQmlComponentPrivate::completeCreate() () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#11 0x0000003d06448460 in QQmlComponent::create(QQmlContext*) () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#12 0x00007f85b80a1fd7 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/org.kde.kdecoration2/kwin5_aurorae.so
#13 0x0000003d09dcfd19 in ?? () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#14 0x0000003d09cb6339 in KWin::Client::createDecoration(QRect const&) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#15 0x0000003d09cb6cfd in KWin::Client::updateDecoration(bool, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#16 0x0000003d09d13656 in KWin::Client::manage(unsigned int, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#17 0x0000003d09c9979f in KWin::Workspace::createClient(unsigned int, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#18 0x0000003d09d00a97 in KWin::Workspace::workspaceEvent(xcb_generic_event_t*) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#19 0x000000312a0822df in QAbstractEventDispatcher::filterNativeEvent(QByteArray const&, void*, long*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007f85bbf73455 in QXcbConnection::handleXcbEvent(xcb_generic_event_t*) () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#21 0x00007f85bbf743eb in QXcbConnection::processXcbEvents() () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#22 0x000000312a0b3729 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#23 0x0000003cfed5cbec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#24 0x0000003cfed6208f in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#25 0x000000312a085450 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x000000312a0873cc in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x000000312a0d8be2 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007f85bbfe60ad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#29 0x000000312a08319a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#30 0x000000312a08b99c in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#31 0x0000003d08609216 in kdemain () from /usr/lib/x86_64-linux-gnu/libkdeinit5_kwin_x11.so
#32 0x000000386f4202b1 in __libc_start_main (main=0x4006a0, argc=3, argv=0x7ffc6e55daf8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc6e55dae8) at ../csu/libc-start.c:291
#33 0x00000000004006d9 in _start ()

Possible duplicates by query: bug 370624, bug 370614, bug 370512, bug 370432, bug 370174.

Reported using DrKonqi
Comment 1 Martin Flöser 2016-10-14 05:31:44 UTC
As a workaround use breeze window decoration.

*** This bug has been marked as a duplicate of bug 361236 ***