Bug 370177 - No longer stores any configuration after removal of profile support
Summary: No longer stores any configuration after removal of profile support
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: Git
Platform: Other Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 373825 373826 377912 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-06 05:12 UTC by Christoph Feck
Modified: 2017-03-29 16:09 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 17.04


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Feck 2016-10-06 05:12:07 UTC
To reproduce:
- start konqueror
- maximize its window
- exit konqueror
- start konqueror again

Actual result:
- konqueror starts with tiny window size

Expected result:
- konqueror starts maximized

Not only window size, but all other configuration is lost. I only tried Ctrl+M to hide the menu bar. On next start, the menu bar is visible again.

This makes konqueror unusable.
Comment 1 Kevin Kofler 2017-01-10 18:30:52 UTC
*** Bug 373826 has been marked as a duplicate of this bug. ***
Comment 2 avlas 2017-01-20 20:04:07 UTC
I filled two bugs for the two issues you mentioned (I was not aware of this bug at that time). As said in them, the issues can be workarounded:

https://bugs.kde.org/show_bug.cgi?id=373826 -> For the case someone is interested, I currently work around the issue with a specific kwin rule to force inital size of Konqueror's window.

https://bugs.kde.org/show_bug.cgi?id=373825 -> For now, I could work around the issue by manually editing the file konqueror.rc located in .local/share/kxmlgui5/konqueror/
Comment 3 avlas 2017-01-20 20:05:38 UTC
(In reply to avlas from comment #2)
> I filled two bugs for the two issues you mentioned (I was not aware of this
> bug at that time). As said in them, the issues can be workarounded:
> 
> https://bugs.kde.org/show_bug.cgi?id=373826 -> For the case someone is
> interested, I currently work around the issue with a specific kwin rule to
> force inital size of Konqueror's window.
> 
> https://bugs.kde.org/show_bug.cgi?id=373825 -> For now, I could work around
> the issue by manually editing the file konqueror.rc located in
> .local/share/kxmlgui5/konqueror/

Let me say, that these workarounds are far from optimal, but they do the job until the issues get fixed (if they eventually do)
Comment 4 Kevin Kofler 2017-01-22 16:14:27 UTC
*** Bug 373825 has been marked as a duplicate of this bug. ***
Comment 5 Wolfgang Bauer 2017-03-29 15:59:09 UTC
Should be fixed in 17.04 (RC):
https://cgit.kde.org/konqueror.git/commit/?h=Applications/17.04&id=c726679e24cda7bd232044ea8e7b069483989905

I just gave that patch a quick try on top of 17.04 Beta: The window size is remembered now, and Konqueror starts maximized if it was when it's closed. Also the shown toolbars are remembered, and whether the menu bar is shown or hidden.

I think this can be closed now...
Comment 6 Wolfgang Bauer 2017-03-29 15:59:38 UTC
*** Bug 377912 has been marked as a duplicate of this bug. ***
Comment 7 avlas 2017-03-29 16:09:14 UTC
Thanks Albert for the nice and simple fix!