Bug 369136 - Krunner please add better plugin help/documentation button.
Summary: Krunner please add better plugin help/documentation button.
Status: RESOLVED FIXED
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Neon Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Alexander Lohnau
URL:
Keywords:
: 187146 187963 188341 386510 427351 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-21 03:02 UTC by Tony
Modified: 2021-12-26 10:57 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony 2016-09-21 03:02:48 UTC
Some of the krunner plugins don't have a "help" or "configuration" button showing how to use/configure them. 
Ex: the "Dictionary" plugin lets you "define" the keyword need it to run it, the web shortcuts can be change on system settings BUT  the spell checker, although it can be configure in system settings, does not show how to use the krunner plugin or the unit converter which can't be configure on system settings and does not have a "help" button either.

The lack of this may lead users (like me) to believe they do not work, are broken or something alike due to the lack of this information.

Reproducible: Always
Comment 1 Alexander Lohnau 2020-06-14 15:35:45 UTC
I am working on that. There will be (hopefully) an extra usage button where the config/info buttons are.

Maybe inline help will be integrated too.
Comment 2 Alexander Lohnau 2020-06-14 21:47:54 UTC
*** Bug 187963 has been marked as a duplicate of this bug. ***
Comment 3 Alexander Lohnau 2020-07-08 11:30:05 UTC
*** Bug 187146 has been marked as a duplicate of this bug. ***
Comment 4 Alexander Lohnau 2020-07-08 13:05:22 UTC
*** Bug 188341 has been marked as a duplicate of this bug. ***
Comment 5 Alexander Lohnau 2020-07-08 13:12:43 UTC
*** Bug 386510 has been marked as a duplicate of this bug. ***
Comment 6 David Faure 2020-08-13 21:19:22 UTC
Git commit edc45feb457a51b496edb571306298d30ad4c552 by David Faure, on behalf of Alexander Lohnau.
Committed on 13/08/2020 at 21:19.
Pushed by dfaure into branch 'master'.

Allow extra button to be added to KPluginSelector
Related: bug 315829

M  +39   -2    src/kpluginselector.cpp
M  +9    -0    src/kpluginselector.h
M  +2    -0    src/kpluginselector_p.h

https://invent.kde.org/frameworks/kcmutils/commit/edc45feb457a51b496edb571306298d30ad4c552
Comment 7 Alexander Lohnau 2020-10-05 06:30:22 UTC
*** Bug 427351 has been marked as a duplicate of this bug. ***
Comment 9 Alexander Lohnau 2021-12-26 10:57:46 UTC
Git commit c8c72bf66a403b408fa9d6559ed5887e358bd490 by Alexander Lohnau.
Committed on 25/12/2021 at 16:53.
Pushed by alex into branch 'master'.

Add helprunner to show usage information for KRunner plugins
Related: bug 433636

M  +2    -1    lookandfeel/contents/runcommand/RunCommand.qml
M  +1    -0    runners/CMakeLists.txt
A  +2    -0    runners/helprunner/CMakeLists.txt
A  +81   -0    runners/helprunner/helprunner.cpp     [License: LGPL(v2.1+)]
A  +27   -0    runners/helprunner/helprunner.h     [License: LGPL(v2.1+)]
A  +17   -0    runners/helprunner/helprunner.json

https://invent.kde.org/plasma/plasma-workspace/commit/c8c72bf66a403b408fa9d6559ed5887e358bd490