Bug 366331 - Kwin segmentation fault within a few minutes after login
Summary: Kwin segmentation fault within a few minutes after login
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.7.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-08-01 17:41 UTC by Philipp
Modified: 2016-08-01 18:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp 2016-08-01 17:41:58 UTC
Application: kwin_x11 (5.7.2)
 (Compiled from sources)
Qt Version: 5.7.0
Frameworks Version: 5.24.0
Operating System: Linux 4.6.3-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:
Just opening any arbitrary new window will trigger the segmentation fault. There's no real pattern to it, for example opening a certain application that crashes it in every case. Trying to reproduce the error with "reboot/login/open the same thing that crashed last time" leads to no success.

So, the basic pattern is: after booting the machine and logging in, normally within the first 2-5 minutes Kwin will die when a new window is created. The new window will be drawn and is responsive after Kwin is restarted automatically, but this particular window is drawn without any decorations. All the other currently open windows are not affected and get redrawn correctly.

* Turning the compositor off, as proposed in several other bug reports, doesn't change anything. Same error rate.
* Upgrading from Qt 5.6.1 to 5.7.0 didn't fix the bug.
* Occurence of crash increased after upgrading from KDE 5.6 to 5.7

This is a possible duplicate of several other bugs. Ironically, the KDE Crash Reporting Assistant doesn't let me chose a related bug from the list it found. A bug in the bug reporter, well ...

The crash can be reproduced sometimes.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f14cd206840 (LWP 903))]

Thread 5 (Thread 0x7f14cb78e700 (LWP 918)):
#0  0x00007f14e119b3ed in poll () from /lib64/libc.so.6
#1  0x00007f14e03148f2 in _xcb_conn_wait () from /usr/lib64/libxcb.so.1
#2  0x00007f14e03166df in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f14cc66edb9 in QXcbEventReader::run() () from /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f14dee00c9d in QThreadPrivate::start(void*) () from /usr/lib64/libQt5Core.so.5
#5  0x00007f14e145e434 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f14e11a450d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f14c94eb700 (LWP 925)):
#0  0x00007f14e119b3ed in poll () from /lib64/libc.so.6
#1  0x00007f14df00f77a in qt_safe_poll(pollfd*, unsigned long, timespec const*) () from /usr/lib64/libQt5Core.so.5
#2  0x00007f14df011556 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#3  0x00007f14defbe84a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007f14dedfb29b in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#5  0x00007f14e19b24b5 in ?? () from /usr/lib64/libQt5DBus.so.5
#6  0x00007f14dee00c9d in QThreadPrivate::start(void*) () from /usr/lib64/libQt5Core.so.5
#7  0x00007f14e145e434 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f14e11a450d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f14c333d700 (LWP 950)):
#0  0x00007f14e119b3ed in poll () from /lib64/libc.so.6
#1  0x00007f14df00f77a in qt_safe_poll(pollfd*, unsigned long, timespec const*) () from /usr/lib64/libQt5Core.so.5
#2  0x00007f14df011556 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#3  0x00007f14defbe84a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007f14dedfb29b in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#5  0x00007f14d98ed2e5 in QQmlThreadPrivate::run() () from /usr/lib64/libQt5Qml.so.5
#6  0x00007f14dee00c9d in QThreadPrivate::start(void*) () from /usr/lib64/libQt5Core.so.5
#7  0x00007f14e145e434 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f14e11a450d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f14adf40700 (LWP 1084)):
#0  0x00007f14e119b3ed in poll () from /lib64/libc.so.6
#1  0x00007f14df00f77a in qt_safe_poll(pollfd*, unsigned long, timespec const*) () from /usr/lib64/libQt5Core.so.5
#2  0x00007f14df011556 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#3  0x00007f14defbe84a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007f14dedfb29b in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#5  0x00007f14d98ed2e5 in QQmlThreadPrivate::run() () from /usr/lib64/libQt5Qml.so.5
#6  0x00007f14dee00c9d in QThreadPrivate::start(void*) () from /usr/lib64/libQt5Core.so.5
#7  0x00007f14e145e434 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f14e11a450d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f14cd206840 (LWP 903)):
[KCrash Handler]
#6  0x00007f14d98d5779 in QQmlBinding::write(QQmlPropertyData const&, QV4::Value const&, bool, QFlags<QQmlPropertyPrivate::WriteFlag>) () from /usr/lib64/libQt5Qml.so.5
#7  0x00007f14d98d6bda in QQmlBinding::update(QFlags<QQmlPropertyPrivate::WriteFlag>) () from /usr/lib64/libQt5Qml.so.5
#8  0x00007f14d98e2849 in QQmlObjectCreator::finalize(QQmlInstantiationInterrupt&) () from /usr/lib64/libQt5Qml.so.5
#9  0x00007f14d985ff72 in QQmlComponentPrivate::complete(QQmlEnginePrivate*, QQmlComponentPrivate::ConstructionState*) () from /usr/lib64/libQt5Qml.so.5
#10 0x00007f14d9860029 in QQmlComponentPrivate::completeCreate() () from /usr/lib64/libQt5Qml.so.5
#11 0x00007f14d9860183 in QQmlComponent::create(QQmlContext*) () from /usr/lib64/libQt5Qml.so.5
#12 0x00007f14c357b53b in Aurorae::Decoration::init() () from /usr/lib64/qt5/plugins/org.kde.kdecoration2/kwin5_aurorae.so
#13 0x00007f14e0dc5d78 in KWin::Decoration::DecorationBridge::createDecoration(KWin::AbstractClient*) () from /usr/lib64/libkwin.so.5
#14 0x00007f14e0ca2d59 in KWin::Client::createDecoration(QRect const&) () from /usr/lib64/libkwin.so.5
#15 0x00007f14e0ca378b in KWin::Client::updateDecoration(bool, bool) () from /usr/lib64/libkwin.so.5
#16 0x00007f14e0d03610 in KWin::Client::manage(unsigned int, bool) () from /usr/lib64/libkwin.so.5
#17 0x00007f14e0c83385 in KWin::Workspace::createClient(unsigned int, bool) () from /usr/lib64/libkwin.so.5
#18 0x00007f14e0cf0c51 in KWin::Workspace::workspaceEvent(xcb_generic_event_t*) () from /usr/lib64/libkwin.so.5
#19 0x00007f14defbd99c in QAbstractEventDispatcher::filterNativeEvent(QByteArray const&, void*, long*) () from /usr/lib64/libQt5Core.so.5
#20 0x00007f14cc66cd84 in QXcbConnection::handleXcbEvent(xcb_generic_event_t*) () from /usr/lib64/libQt5XcbQpa.so.5
#21 0x00007f14cc66f170 in QXcbConnection::processXcbEvents() () from /usr/lib64/libQt5XcbQpa.so.5
#22 0x00007f14defecd5a in QObject::event(QEvent*) () from /usr/lib64/libQt5Core.so.5
#23 0x00007f14df89e0b4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#24 0x00007f14df8a5c80 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#25 0x00007f14defc0440 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
#26 0x00007f14defc32f1 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQt5Core.so.5
#27 0x00007f14df0113a2 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#28 0x00007f14cc6e4d5d in QUnixEventDispatcherQPA::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5XcbQpa.so.5
#29 0x00007f14defbe84a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#30 0x00007f14defc73bc in QCoreApplication::exec() () from /usr/lib64/libQt5Core.so.5
#31 0x00007f14e167c26b in kdemain () from /usr/lib64/libkdeinit5_kwin_x11.so
#32 0x00007f14e10db630 in __libc_start_main () from /lib64/libc.so.6
#33 0x00000000004007f9 in _start ()

Possible duplicates by query: bug 366240, bug 366198, bug 366126, bug 366097, bug 366096.

Reported using DrKonqi
Comment 1 Rex Dieter 2016-08-01 17:59:55 UTC

*** This bug has been marked as a duplicate of bug 361236 ***
Comment 2 Rex Dieter 2016-08-01 18:00:58 UTC
workaround:  until the aforementioned bug is fixed, use a different window decoration