Bug 366151 - Gmail shutting down
Summary: Gmail shutting down
Status: RESOLVED DUPLICATE of bug 319776
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Mint (Ubuntu based) Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-07-27 02:32 UTC by J Coombs
Modified: 2017-01-07 12:49 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J Coombs 2016-07-27 02:32:41 UTC
Application: akonadi_imap_resource (4.14)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.16.0-38-generic x86_64
Distribution: Linux Mint 17.2 Rafaela

-- Information about the crash:
- What I was doing when the application crashed:
Using Vivaldi Browser and watching Flash video on Forefox browser. Alert popped up. Was not using mail at he time.

-- Backtrace:
Application: Google Mail (bigdaddymobaddie) of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f38cd5fc7c0 (LWP 2711))]

Thread 2 (Thread 0x7f38b3fff700 (LWP 4172)):
#0  0x00007f38c8f90fdd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f38c7f16fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f38c7f170ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f38ccc2f7be in QEventDispatcherGlib::processEvents (this=0x7f38a800f490, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007f38ccc010af in QEventLoop::processEvents (this=this@entry=0x7f38b3ffee20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f38ccc013a5 in QEventLoop::exec (this=this@entry=0x7f38b3ffee20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f38ccafdc5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#7  0x00007f38ccb0032f in QThreadPrivate::start (arg=0xc4ec50) at thread/qthread_unix.cpp:349
#8  0x00007f38c85fb184 in start_thread (arg=0x7f38b3fff700) at pthread_create.c:312
#9  0x00007f38c8f9e37d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f38cd5fc7c0 (LWP 2711)):
[KCrash Handler]
#6  0x0000000000000001 in ?? ()
#7  0x00007f38ccc15999 in QObject::disconnect (sender=0xc44fd0, signal=0xc41819 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", signal@entry=0x47b588 "2stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=receiver@entry=0xc17b70, method=0xc469b9 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)", method@entry=0x47b540 "1onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2883
#8  0x000000000044fbb5 in SessionPool::killSession (this=this@entry=0xc17b70, session=0xc44fd0, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:182
#9  0x000000000044ff55 in SessionPool::disconnect (this=0xc17b70, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:115
#10 0x000000000043108b in ImapResourceBase::doSetOnline (this=0xb9b3d0, online=<optimized out>) at ../../../resources/imap/imapresourcebase.cpp:575
#11 0x00007f38ccffc3d1 in Akonadi::AgentBase::setOnlineInternal(bool) () from /usr/lib/libakonadi-kde.so.4
#12 0x00007f38ccffc622 in Akonadi::AgentBase::setTemporaryOffline(int) () from /usr/lib/libakonadi-kde.so.4
#13 0x000000000042e8fe in ImapResourceBase::onConnectDone (this=0xb9b3d0, errorCode=-1090044704, errorString=...) at ../../../resources/imap/imapresourcebase.cpp:314
#14 0x00000000004644ff in ImapResourceBase::qt_static_metacall (_o=0xc44fd0, _c=3204922592, _id=1, _a=0x0) at moc_imapresourcebase.cpp:123
#15 0x00007f38ccc1687a in QMetaObject::activate (sender=sender@entry=0xc17b70, m=m@entry=0x482160 <SessionPool::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7ffcbf074090) at kernel/qobject.cpp:3539
#16 0x00000000004649a4 in SessionPool::connectDone (this=this@entry=0xc17b70, _t1=_t1@entry=8, _t2=...) at moc_sessionpool.cpp:160
#17 0x0000000000450bf4 in SessionPool::cancelSessionCreation (this=this@entry=0xc17b70, session=<optimized out>, errorCode=errorCode@entry=8, errorMessage=...) at ../../../resources/imap/sessionpool.cpp:247
#18 0x0000000000451008 in SessionPool::onLoginDone (this=0xc17b70, job=0xc4ce30) at ../../../resources/imap/sessionpool.cpp:372
#19 0x0000000000464a0c in SessionPool::qt_static_metacall (_o=0xc44fd0, _c=3204922592, _id=1, _a=0x0) at moc_sessionpool.cpp:94
#20 0x00007f38ccc1687a in QMetaObject::activate (sender=sender@entry=0xc4ce30, m=m@entry=0x7f38c9eb0600 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7ffcbf0743c0) at kernel/qobject.cpp:3539
#21 0x00007f38c9b20912 in KJob::result (this=this@entry=0xc4ce30, _t1=_t1@entry=0xc4ce30) at ./kjob.moc:207
#22 0x00007f38c9b20950 in KJob::emitResult (this=0xc4ce30) at ../../kdecore/jobs/kjob.cpp:318
#23 0x00007f38ca8806b7 in KIMAP::LoginJob::connectionLost() () from /usr/lib/libkimap.so.4
#24 0x00007f38ca88b19a in KIMAP::SessionPrivate::clearJobQueue() () from /usr/lib/libkimap.so.4
#25 0x00007f38ccc1ac1e in QObject::event (this=0xc45580, e=<optimized out>) at kernel/qobject.cpp:1194
#26 0x00007f38cbf9be2c in QApplicationPrivate::notify_helper (this=this@entry=0xa3d040, receiver=receiver@entry=0xc45580, e=e@entry=0x7f38a80072f0) at kernel/qapplication.cpp:4567
#27 0x00007f38cbfa24a0 in QApplication::notify (this=this@entry=0x7ffcbf074b40, receiver=receiver@entry=0xc45580, e=e@entry=0x7f38a80072f0) at kernel/qapplication.cpp:4353
#28 0x00007f38ca0e0cca in KApplication::notify (this=0x7ffcbf074b40, receiver=0xc45580, event=0x7f38a80072f0) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007f38ccc024dd in QCoreApplication::notifyInternal (this=0x7ffcbf074b40, receiver=receiver@entry=0xc45580, event=event@entry=0x7f38a80072f0) at kernel/qcoreapplication.cpp:953
#30 0x00007f38ccc05b3d in sendEvent (event=0x7f38a80072f0, receiver=0xc45580) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xa0b220) at kernel/qcoreapplication.cpp:1577
#32 0x00007f38ccc05fe3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#33 0x00007f38ccc2ff83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#34 postEventSourceDispatch (s=0xa3c310) at kernel/qeventdispatcher_glib.cpp:287
#35 0x00007f38c7f16e04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007f38c7f17048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007f38c7f170ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#38 0x00007f38ccc2f7a1 in QEventDispatcherGlib::processEvents (this=0xa0c700, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#39 0x00007f38cc03dbe6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007f38ccc010af in QEventLoop::processEvents (this=this@entry=0x7ffcbf074ab0, flags=...) at kernel/qeventloop.cpp:149
#41 0x00007f38ccc013a5 in QEventLoop::exec (this=this@entry=0x7ffcbf074ab0, flags=...) at kernel/qeventloop.cpp:204
#42 0x00007f38ccc06b79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#43 0x00007f38cd0e3783 in Akonadi::ResourceBase::init(Akonadi::ResourceBase*) () from /usr/lib/libakonadi-kde.so.4
#44 0x0000000000418993 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:193
#45 0x00007f38c8ec5f45 in __libc_start_main (main=0x4182e0 <main(int, char**)>, argc=3, argv=0x7ffcbf074c58, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffcbf074c48) at libc-start.c:287
#46 0x0000000000418854 in _start ()

Possible duplicates by query: bug 361213.

Reported using DrKonqi
Comment 1 Daniel Vrátil 2017-01-07 12:49:03 UTC

*** This bug has been marked as a duplicate of bug 319776 ***