Bug 365716 - Digital clock display is missing digits when resuming from suspend with NVIDIA GPU
Summary: Digital clock display is missing digits when resuming from suspend with NVIDI...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Digital Clock (show other bugs)
Version: 5.20.0
Platform: FreeBSD Ports FreeBSD
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
: 442814 458348 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-07-15 15:58 UTC by Markus Strobl
Modified: 2022-09-25 13:12 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.26


Attachments
Time should be 10:59 AM (666.68 KB, image/png)
2016-07-15 16:04 UTC, Markus Strobl
Details
KDE Plasma 5.7.2 panel - digital clock - missing digits (39.68 KB, image/png)
2016-07-20 20:19 UTC, Bob Wya
Details
Missing decade digit, Plasma 5.18 LTS (111.93 KB, image/png)
2020-06-09 06:39 UTC, David
Details
Only single digit, Plasma 5.18 LTS (103.93 KB, image/png)
2020-06-09 06:40 UTC, David
Details
screenshot of the digital clock in the panel with missing digits (8.99 KB, image/png)
2020-12-19 09:49 UTC, Matthias Apitz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Strobl 2016-07-15 15:58:36 UTC
Seems to be triggered by resume-from-suspend. Random digits are missing from the clock. Sometimes from the time, sometimes from date. Only way to get them back that I've found is to logout and back in.

Spectacle is not able to take a screenshot of the panel, so I'll attach a phone pic instead.

Reproducible: Always
Comment 1 Markus Strobl 2016-07-15 16:04:05 UTC
Created attachment 100114 [details]
Time should be 10:59 AM

Time should be 10:59 AM
Comment 2 Bob Wya 2016-07-16 14:01:20 UTC
I can reproduce this issue...

I'll do some more testing... I've tried increasing the width in:
org.kde.plasma.digitalclock/ ... /DigitalClock.qml
96: Layout.minimumWidth: Math.max(labelsFlow.width+2, dateLabel.paintedWidth)
just to see what effect this has... :-)
Comment 3 Bob Wya 2016-07-20 20:19:40 UTC
Created attachment 100218 [details]
KDE Plasma 5.7.2 panel - digital clock - missing digits
Comment 4 Kai Uwe Broulik 2016-08-31 14:16:37 UTC
Looks like a driver/Qt bug to me, though, re-assigning to plasmashell Digital Clock
Comment 5 Barafu Albino Cheetah 2017-05-06 09:49:34 UTC
The bug is still here and is very annoying. You can't have office PC without the clock in the tray. A suggestion for a workaround would be highly appreciated. 
In my case, digital clock is missing hours, and displays something like "  :45". Happens sometimes after reboot and the only cure is to reboot. 
I use 4k display and I somehow think it may be connected.
Comment 6 Christoph Feck 2017-05-16 01:29:06 UTC
Are you using the nvidia drivers? There are known issues with OpenGL buffers getting lost after a suspend/resume cycle with those.
Comment 7 Barafu Albino Cheetah 2017-05-16 14:15:10 UTC
I am using Nvidia drivers. However, if you are talking about system suspend/resume - I never use those. Too many problems with them, really.
Comment 8 Bob Wya 2017-12-05 17:55:20 UTC
Still present in Plasma 5.11.4 with Qt 5.9.3.

Still occurring after some (not all) suspend-resume cycles on my laptop.

Nvidia proprietary driver 387.34 with a Geforce GTX 970M.
Comment 9 Sebastian W 2019-02-18 14:16:26 UTC
I can confirm this issue. On my system it is triggered when switching users.
Comment 10 David 2020-06-09 06:32:20 UTC
Same issue on Kubuntu 20.04. It is sensible to font settings and actual date text. I don't know how to upload screenshots, but perhaps I can add links to them at least.

There were problems after the upgrade from 19.10, then I changed font settings and since then it worked without issues until today.

https://photos.app.goo.gl/rGcQ7LC2S2V4voYN8 - only first digit visible

Then I tried to enable BOLD text and now I have this:
https://photos.app.goo.gl/2yyziopQAqLEMBt47 - missing decade digit.
Comment 11 David 2020-06-09 06:39:29 UTC
Created attachment 129151 [details]
Missing decade digit, Plasma 5.18 LTS
Comment 12 David 2020-06-09 06:40:56 UTC
Created attachment 129152 [details]
Only single digit, Plasma 5.18 LTS
Comment 13 Nate Graham 2020-10-18 14:28:26 UTC
For anyone still experiencing this in Plasma 5.18 or 5.20, can you please update your NVIDIA drivers to the very latest versions and see if it's still happening?
Comment 14 Bug Janitor Service 2020-11-02 04:33:30 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 15 Bug Janitor Service 2020-11-17 04:33:49 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!
Comment 16 David 2020-11-17 07:21:14 UTC
I can confirm that now it is OK on my machine.
Ubuntu 20.04.1 LTS
Nvidia Driver version: 450.80.02
Comment 17 Matthias Apitz 2020-12-19 09:44:50 UTC
This is with plasma 5.20 on FreeBSD (ports from head): The digital panel clock (version 3.0) looses digits of the time. It is not related to suspend/resume (because I can't use them with FreeBSD) and also not related to NVIDIA driver (my Acer C720 laptop uses Intel). 

From time to time some of the digits of the clock in the panel are going away. I will attach a screenshot or look here: http://www.unixarea.de/clock.png 
To make them appear again I change the characters for the digits from normal to bold (or vice versa) and then after some time they're away again.
Comment 18 Matthias Apitz 2020-12-19 09:49:59 UTC
Created attachment 134199 [details]
screenshot of the digital clock in the panel with missing digits
Comment 19 Nate Graham 2021-09-22 18:35:28 UTC
*** Bug 442814 has been marked as a duplicate of this bug. ***
Comment 20 ratijas 2022-06-15 16:05:00 UTC
I *suppose* this is a bug with Text.Fit mode that the Date & Time applet uses. I just happened to play with user switcher applet, trying to make its layout work for both vertical and horizontal orientations, and I discovered that a text label may randomly shift waaay down for no good reason. It might or might not be related, but matter of the fact: Text::fontSizeMode is buggy, and there may be more surprises to come.
Comment 21 Nate Graham 2022-08-30 19:43:25 UTC
*** Bug 458348 has been marked as a duplicate of this bug. ***
Comment 22 Nate Graham 2022-09-23 01:58:18 UTC
We recently fixed an issue in Plasma 5.26 with various plasmoids being visually corrupted on wake-from-sleep when using an NVIDIA GPU.

Those of you who are experiencing similar issues but without having woken form sleep, or not using an NVIDIA GPU, can you please file new bug reports so we can make sure those separate issues are tracked correctly and don't get mistakenly rolled up here? Thanks!
Comment 23 ratijas 2022-09-25 13:12:38 UTC
I can confirm that things got generally better after laptop waking up from sleep, at least on X11. On Wayland thoughyesterday I got an extremely glitchy picture with artifacts covering the whole screen, but that might have been related to multi-screen setup (I connected it to a "new" TV via HDMI before waking up).