Bug 365029 - Add dbus interface to set/query the current desktop wallpaper
Summary: Add dbus interface to set/query the current desktop wallpaper
Status: RESOLVED DUPLICATE of bug 217950
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Image Wallpaper (show other bugs)
Version: master
Platform: Kubuntu Packages Linux
: NOR wishlist
Target Milestone: 1.0
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-03 07:03 UTC by edA-qa mort-ora-y
Modified: 2016-07-03 12:05 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description edA-qa mort-ora-y 2016-07-03 07:03:09 UTC
There is presently no way to programmatically set the wallpaper in KDE. This prevents things like `variety` from dynamically modifying it, and image views like `gwenview`  from having a "Set as wallpaper` option 
  - https://bugs.kde.org/show_bug.cgi?id=170124
  - http://peterlevi.com/variety/2014/05/variety-and-kde/

The previous dcop system used to have a method to set the wallpaper, but the dbus interface for `org.kde.PlasmaShell` does not. Methods to set, and possibly get, the current wallpaper (or filename) would be quite helpful.

Reproducible: Always
Comment 1 Rog131 2016-07-03 11:07:18 UTC
Dublicate of the Bug 217950 - Ability to set desktop wallpaper via a dbus command : https://bugs.kde.org/show_bug.cgi?id=217950
Comment 2 Rog131 2016-07-03 11:09:29 UTC
(In reply to edA-qa mort-ora-y from comment #0)
> There is presently no way to programmatically set the wallpaper in KDE. This
> prevents things like `variety` from dynamically modifying it, and image
> views like `gwenview`  from having a "Set as wallpaper` option 
>   - https://bugs.kde.org/show_bug.cgi?id=170124
>   - http://peterlevi.com/variety/2014/05/variety-and-kde/
> 
> The previous dcop system used to have a method to set the wallpaper, but the
> dbus interface for `org.kde.PlasmaShell` does not. Methods to set, and
> possibly get, the current wallpaper (or filename) would be quite helpful.
> 
> Reproducible: Always

Plasma 4: https://code.google.com/archive/p/ksetwallpaper/
Plasma 5: An example - https://www.kubuntuforums.net/showthread.php?66762-Right-click-wallpaper-changer&p=387392&viewfull=1#post387392
Comment 3 Kai Uwe Broulik 2016-07-03 12:05:40 UTC

*** This bug has been marked as a duplicate of bug 217950 ***