Bug 364751 - Konkeror crash when open url on kmail
Summary: Konkeror crash when open url on kmail
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-06-25 14:20 UTC by Martial Guex
Modified: 2018-12-02 03:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martial Guex 2016-06-25 14:20:05 UTC
Application: konqueror (4.14.20)
KDE Platform Version: 4.14.21
Qt Version: 4.8.7
Operating System: Linux 4.6.0-1-amd64 x86_64
Distribution: Debian GNU/Linux 7-updates (n/a)

-- Information about the crash:
- What I was doing when the application crashed:
Open url (https://groups.yahoo.com/neo/groups/N2PK-VNA/files/2N3904_Amp_4_Revision_3.pdf) on mail  inside kmail

-- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f965690f900 (LWP 19461))]

Thread 4 (Thread 0x7f962e6bd700 (LWP 19477)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:225
#1  0x00007f9655494384 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2  0x00007f9655486fe7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#3  0x00007f9655493e3c in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f96518db464 in start_thread (arg=0x7f962e6bd700) at pthread_create.c:334
#5  0x00007f96540ede5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f96434d6700 (LWP 19463)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:225
#1  0x00007f9655494384 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2  0x00007f9655486fe7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#3  0x00007f9655493e3c in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f96518db464 in start_thread (arg=0x7f96434d6700) at pthread_create.c:334
#5  0x00007f96540ede5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f9643cd7700 (LWP 19462)):
#0  0x00007ffdf8ebbc3f in clock_gettime ()
#1  0x00007f96540faa26 in __GI___clock_gettime (clock_id=1, tp=0x7f9643cd69f0) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f96554ee635 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#3  0x00007f96555d5085 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f96555d394c in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f96555d3a15 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f9650fe892d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f9650fe92cb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f9650fe94ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f96555d4216 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007f96555a217f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#11 0x00007f96555a24e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#12 0x00007f9655491549 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#13 0x00007f964aecf64e in ?? () from /usr/lib/libkio.so.5
#14 0x00007f9655493e3c in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#15 0x00007f96518db464 in start_thread (arg=0x7f9643cd7700) at pthread_create.c:334
#16 0x00007f96540ede5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f965690f900 (LWP 19461)):
[KCrash Handler]
#6  0x00007f9654941339 in QWidgetPrivate::showChildren(bool) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#7  0x00007f965494144f in QWidgetPrivate::show_helper() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#8  0x00007f965494346a in QWidget::setVisible(bool) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#9  0x00007f9654941387 in QWidgetPrivate::showChildren(bool) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#10 0x00007f965494144f in QWidgetPrivate::show_helper() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#11 0x00007f965494346a in QWidget::setVisible(bool) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#12 0x00007f964be5e85c in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_konqueror.so
#13 0x00000000004089cc in ?? ()
#14 0x0000000000409aaf in ?? ()
#15 0x000000000040a19e in ?? ()
#16 0x000000000040555d in ?? ()
#17 0x00007f96540255f0 in __libc_start_main (main=0x404980, argc=2, argv=0x7ffdf8e9bf88, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffdf8e9bf78) at libc-start.c:291
#18 0x00000000004063f9 in _start ()

Possible duplicates by query: bug 349736.

Reported using DrKonqi
Comment 1 Andrew Crouthamel 2018-11-01 13:56:51 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 2 Bug Janitor Service 2018-11-16 11:42:45 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2018-12-02 03:48:39 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!