Bug 364098 - In split pane view konsole should respect focus follows mouse but doesn't
Summary: In split pane view konsole should respect focus follows mouse but doesn't
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 2.13
Platform: unspecified Linux
: NOR wishlist with 61 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords: usability
: 412523 412644 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-08 11:52 UTC by davidblunkett
Modified: 2020-09-16 02:18 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 20.12


Attachments
attachment-21775-0.html (1.70 KB, text/html)
2017-05-08 08:49 UTC, davidblunkett
Details
patch to add terminal focus following mouse in konsole (4.25 KB, patch)
2020-08-17 20:25 UTC, Luc Dufresne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description davidblunkett 2016-06-08 11:52:08 UTC
In split pane view konsole should honour the focus policy for windows for its panes otherwise it is inconsistent in its behaviour between terminals in separate panes and split panes.  If the policy is "focus follows mouse" it should switch pane focus between panes depending on where the mouse is.  At present it requires the pane to be click regardless of focus policy.  

It does respect this when mouse scrolling but not without. 

Reproducible: Always

Steps to Reproduce:
1. konsole with split screen and KDE focus policy "focus follows mouse"
2. move mouse over pane - focus should follow but does not unless the mouse is clicked or scrolled.


Actual Results:  
Clicks required to focus on pane

Expected Results:  
Focus should follow mouse
Comment 1 davidblunkett 2017-03-18 21:10:33 UTC
Any chance this will be fixed?
Comment 2 Christoph Feck 2017-03-31 18:54:51 UTC
There is no "KDE focus policy", but only "KWin focus policy", in other words, it affects windows, not widgets.

I suggest to use multiple Konsole windows. No other application uses the KWin setting to focus widgets when moving the cursor, I do not see why Konsole should be different.
Comment 3 davidblunkett 2017-04-02 20:34:56 UTC
I see a good reason that this should be different - it makes the behaviour consistent with the window policy and, at present, from a user point of view using FFM the entry goes where the mouse is in every thing _except_ split view in konsole.

In some circumstances it is actually genuinely useful to have a split pane (as opposed to multiple windows) but the "click to focus" policy makes it excruciating to use under FFM.

I suspect it is entirely trivial to fix this.
Comment 4 Christoph Feck 2017-04-21 17:55:16 UTC
Which other applications that have multiple focusable areas in a single window use "focus follows mouse"?
Comment 5 davidblunkett 2017-04-25 07:26:44 UTC
I simply fail to see your objection to this.  Policy "click to focus" clearly flies in the face of user preferences.  Respecting the window manager setting is trivial to implement and you could even consider and option:

- click to focus
- window manager choice
- focus follows mouse

And in answer to your question - I cannot think of a single multipane application that doesn't behave this way, I think konsole is uniquely uncooperative.
Comment 6 Christoph Feck 2017-04-28 00:18:37 UTC
> I cannot think of a single multipane application that doesn't behave this way

Then please give references. I am objecting, because you did not give any.
Comment 7 davidblunkett 2017-05-08 08:49:06 UTC
Created attachment 105386 [details]
attachment-21775-0.html

I simply cannot think of another application that does not respect this:


gimp

libreoffice

xfig

matlab

octave

amarok

etc

etc

every tool in the box!


________________________________
From: Christoph Feck <bugzilla_noreply@kde.org>
Sent: Friday, April 28, 2017 12:18 AM
To: dav1dblunk3tt@hotmail.com
Subject: [konsole] [Bug 364098] In split pane view konsole should respect focus follows mouse but doesn't

https://bugs.kde.org/show_bug.cgi?id=364098

--- Comment #6 from Christoph Feck <cfeck@kde.org> ---
> I cannot think of a single multipane application that doesn't behave this way

Then please give references. I am objecting, because you did not give any.

--
You are receiving this mail because:
You reported the bug.
Comment 8 Christoph Feck 2019-10-24 12:04:40 UTC
*** Bug 412523 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2019-10-24 15:23:47 UTC
*** Bug 412644 has been marked as a duplicate of this bug. ***
Comment 10 Mobe 2020-02-09 14:56:39 UTC
Coming from Terminator and screen (both applications support the follow mouse policy) the first feature I missed in konsole was focus follows pointer. I'd love to have that in konsole as well. It's an essential feature to improve productivity.
Comment 11 Vladimir Brik 2020-04-16 17:33:30 UTC
KDE's yakuake console implements this for its multi-pane mode and it works very well
Comment 12 Luc Dufresne 2020-08-17 20:23:58 UTC
I was missing this feature. So I wrote a quick and dirty patch. (see attachment)

As in yakuake, I added a general preference : "Focus terminals when the mouse pointer is moved over them".

Seems to work as intended.
Comment 13 Luc Dufresne 2020-08-17 20:25:51 UTC
Created attachment 130951 [details]
patch to add terminal focus following mouse in konsole
Comment 14 Axel 2020-08-17 20:54:47 UTC
The patch works properly.

Luc, could you send the merge request? https://invent.kde.org/utilities/konsole
Comment 15 Bug Janitor Service 2020-08-18 18:47:55 UTC
A possibly relevant merge request was started @ https://invent.kde.org/utilities/konsole/-/merge_requests/197
Comment 16 Nate Graham 2020-09-16 02:18:18 UTC
Implemented with https://invent.kde.org/utilities/konsole/-/commit/befddfcd9209effad6bb95ed48a06fe6530c14b8 in Konsole 20.12!