Bug 363687 - Crash when trying to resize an LV with a mounted filessystem
Summary: Crash when trying to resize an LV with a mounted filessystem
Status: RESOLVED DUPLICATE of bug 353775
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-05-30 08:05 UTC by Paul Burden
Modified: 2016-05-31 12:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Burden 2016-05-30 08:05:42 UTC
Application: kvpm (0.9.9)
KDE Platform Version: 4.14.16
Qt Version: 4.8.7
Operating System: Linux 4.4.0-22-generic x86_64
Distribution: Ubuntu 16.04 LTS

-- Information about the crash:
- What I was doing when the application crashed: I was trying to reduce the size of a logical volume in a volume group. I had forgotten to unmount the file system. KVPM told me that I needed to unmount it then crashed.

-- Backtrace:
Application: kvpm (kvpm), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f83671bd900 (LWP 3018))]

Thread 2 (Thread 0x7f834ffff700 (LWP 3706)):
#0  0x00007f835fbd4a49 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f835fb8f8b9 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f835fb9024b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f835fb9042c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f83652f92ce in QEventDispatcherGlib::processEvents (this=0x7f8348004a40, flags=...) at kernel/qeventdispatcher_glib.cpp:452
#5  0x00007f83652c718f in QEventLoop::processEvents (this=this@entry=0x7f834fffec80, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f83652c74f5 in QEventLoop::exec (this=this@entry=0x7f834fffec80, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f83651b6549 in QThread::exec (this=this@entry=0xdb0740) at thread/qthread.cpp:538
#8  0x00007f83652a7223 in QInotifyFileSystemWatcherEngine::run (this=0xdb0740) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007f83651b8e3c in QThreadPrivate::start (arg=0xdb0740) at thread/qthread_unix.cpp:352
#10 0x00007f83610656fa in start_thread (arg=0x7f834ffff700) at pthread_create.c:333
#11 0x00007f83638ccb5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f83671bd900 (LWP 3018)):
[KCrash Handler]
#6  SizeSelectorBox::getMaximumSize (this=0x50) at /build/buildd/kvpm-0.9.9/kvpm/sizeselectorbox.cpp:284
#7  0x000000000049ad20 in LVReduceDialog::resetOkButton (this=0xf2ad00) at /build/buildd/kvpm-0.9.9/kvpm/lvreduce.cpp:181
#8  0x000000000049b4b8 in LVReduceDialog::LVReduceDialog (this=0xf2ad00, volume=<optimized out>, parent=<optimized out>) at /build/buildd/kvpm-0.9.9/kvpm/lvreduce.cpp:150
#9  0x00000000004726a2 in LVActions::callDialog (this=0xcd0100, action=<optimized out>) at /build/buildd/kvpm-0.9.9/kvpm/lvactions.cpp:916
#10 0x00007f83652dd010 in QMetaObject::activate (sender=0xcd0100, m=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3567
#11 0x00007f8366b527e2 in KActionCollection::actionTriggered(QAction*) () from /usr/lib/libkdeui.so.5
#12 0x00007f8366b53636 in ?? () from /usr/lib/libkdeui.so.5
#13 0x00007f83652dd010 in QMetaObject::activate (sender=sender@entry=0xcd3310, m=m@entry=0x7f8365101da0 <QAction::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7ffcdc968600) at kernel/qobject.cpp:3567
#14 0x00007f8364604d62 in QAction::triggered (this=this@entry=0xcd3310, _t1=false) at .moc/release-shared/moc_qaction.cpp:276
#15 0x00007f83646060b3 in QAction::activate (this=this@entry=0xcd3310, event=event@entry=QAction::Trigger) at kernel/qaction.cpp:1257
#16 0x00007f8364a679fd in QMenuPrivate::activateCausedStack (this=this@entry=0xf1e4c0, causedStack=..., action=action@entry=0xcd3310, action_e=action_e@entry=QAction::Trigger, self=self@entry=true) at widgets/qmenu.cpp:1037
#17 0x00007f8364a6bde9 in QMenuPrivate::activateAction (this=0xf1e4c0, action=0xcd3310, action_e=QAction::Trigger, self=<optimized out>) at widgets/qmenu.cpp:1129
#18 0x00007f8366d0e663 in KMenu::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libkdeui.so.5
#19 0x00007f83646618d0 in QWidget::event (this=this@entry=0xf16410, event=event@entry=0x7ffcdc968d20) at kernel/qwidget.cpp:8775
#20 0x00007f8364a6fffb in QMenu::event (this=0xf16410, e=0x7ffcdc968d20) at widgets/qmenu.cpp:2480
#21 0x00007f836460afdc in QApplicationPrivate::notify_helper (this=this@entry=0x88e510, receiver=receiver@entry=0xf16410, e=e@entry=0x7ffcdc968d20) at kernel/qapplication.cpp:4570
#22 0x00007f83646120d6 in QApplication::notify (this=<optimized out>, receiver=0xf16410, e=0x7ffcdc968d20) at kernel/qapplication.cpp:4113
#23 0x00007f8366c446aa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#24 0x00007f83652c890d in QCoreApplication::notifyInternal (this=0x7ffcdc96a580, receiver=receiver@entry=0xf16410, event=event@entry=0x7ffcdc968d20) at kernel/qcoreapplication.cpp:955
#25 0x00007f83646116dd in QCoreApplication::sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#26 QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0xf16410, event=event@entry=0x7ffcdc968d20, alienWidget=alienWidget@entry=0x0, nativeWidget=nativeWidget@entry=0xf16410, buttonDown=buttonDown@entry=0x7f8365136368 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3178
#27 0x00007f836468fd7c in QETWidget::translateMouseEvent (this=this@entry=0xf16410, event=event@entry=0x7ffcdc969050) at kernel/qapplication_x11.cpp:4572
#28 0x00007f836468ec83 in QApplication::x11ProcessEvent (this=0x7ffcdc96a580, event=event@entry=0x7ffcdc969050) at kernel/qapplication_x11.cpp:3626
#29 0x00007f83646b8542 in x11EventSourceDispatch (s=0x8820f0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#30 0x00007f835fb90127 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f835fb90380 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f835fb9042c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007f83652f92ce in QEventDispatcherGlib::processEvents (this=0x85bb90, flags=...) at kernel/qeventdispatcher_glib.cpp:452
#34 0x00007f83646b8616 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007f83652c718f in QEventLoop::processEvents (this=this@entry=0x7ffcdc969440, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007f83652c74f5 in QEventLoop::exec (this=this@entry=0x7ffcdc969440, flags=...) at kernel/qeventloop.cpp:204
#37 0x00007f8364a6eb57 in QMenu::exec (this=this@entry=0xf16410, p=..., action=action@entry=0x0) at widgets/qmenu.cpp:2124
#38 0x000000000050c1d4 in VolumeGroupTab::lvContextMenu (this=0xccfbc0, item=<optimized out>) at /build/buildd/kvpm-0.9.9/kvpm/volumegrouptab.cpp:293
#39 0x00007f83652dd010 in QMetaObject::activate (sender=sender@entry=0xceae20, m=m@entry=0x518e80 <VGTree::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffcdc9695b0) at kernel/qobject.cpp:3567
#40 0x000000000043b41d in VGTree::lvMenuRequested (this=this@entry=0xceae20, _t1=0xdc2ba0) at /build/buildd/kvpm-0.9.9/obj-x86_64-linux-gnu/kvpm/moc_vgtree.cpp:105
#41 0x00000000004fddbf in VGTree::popupContextMenu (this=this@entry=0xceae20, point=...) at /build/buildd/kvpm-0.9.9/kvpm/vgtree.cpp:397
#42 0x000000000043a8b0 in VGTree::qt_static_metacall (_o=0xceae20, _c=<optimized out>, _id=1, _a=0x7ffcdc969730) at /build/buildd/kvpm-0.9.9/obj-x86_64-linux-gnu/kvpm/moc_vgtree.cpp:55
#43 0x00007f83652dd010 in QMetaObject::activate (sender=sender@entry=0xceae20, m=m@entry=0x7f83651037e0 <QWidget::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffcdc969730) at kernel/qobject.cpp:3567
#44 0x00007f8364653662 in QWidget::customContextMenuRequested (this=this@entry=0xceae20, _t1=...) at .moc/release-shared/moc_qwidget.cpp:373
#45 0x00007f8364662648 in QWidget::event (this=this@entry=0xceae20, event=event@entry=0x7ffcdc969da0) at kernel/qwidget.cpp:8570
#46 0x00007f8364a2acee in QFrame::event (this=0xceae20, e=0x7ffcdc969da0) at widgets/qframe.cpp:557
#47 0x00007f8364b50663 in QAbstractItemView::viewportEvent (this=this@entry=0xceae20, event=event@entry=0x7ffcdc969da0) at itemviews/qabstractitemview.cpp:1644
#48 0x00007f8364b91f9c in QTreeView::viewportEvent (this=0xceae20, event=0x7ffcdc969da0) at itemviews/qtreeview.cpp:1252
#49 0x00007f83652c8a76 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=this@entry=0x88e510, receiver=receiver@entry=0xcec090, event=event@entry=0x7ffcdc969da0) at kernel/qcoreapplication.cpp:1065
#50 0x00007f836460afbc in QApplicationPrivate::notify_helper (this=this@entry=0x88e510, receiver=receiver@entry=0xcec090, e=e@entry=0x7ffcdc969da0) at kernel/qapplication.cpp:4566
#51 0x00007f8364612f0c in QApplication::notify (this=<optimized out>, receiver=0xcec090, e=0x7ffcdc969da0) at kernel/qapplication.cpp:4192
#52 0x00007f8366c446aa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#53 0x00007f83652c890d in QCoreApplication::notifyInternal (this=0x7ffcdc96a580, receiver=receiver@entry=0xcec090, event=event@entry=0x7ffcdc969da0) at kernel/qcoreapplication.cpp:955
#54 0x00007f836468f45c in QCoreApplication::sendSpontaneousEvent (event=0x7ffcdc969da0, receiver=0xcec090) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#55 QETWidget::translateMouseEvent (this=this@entry=0xccfbc0, event=event@entry=0x7ffcdc96a0d0) at kernel/qapplication_x11.cpp:4643
#56 0x00007f836468ec83 in QApplication::x11ProcessEvent (this=0x7ffcdc96a580, event=event@entry=0x7ffcdc96a0d0) at kernel/qapplication_x11.cpp:3626
#57 0x00007f83646b8542 in x11EventSourceDispatch (s=0x8820f0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#58 0x00007f835fb90127 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#59 0x00007f835fb90380 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#60 0x00007f835fb9042c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#61 0x00007f83652f92ae in QEventDispatcherGlib::processEvents (this=0x85bb90, flags=...) at kernel/qeventdispatcher_glib.cpp:450
#62 0x00007f83646b8616 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#63 0x00007f83652c718f in QEventLoop::processEvents (this=this@entry=0x7ffcdc96a4b0, flags=...) at kernel/qeventloop.cpp:149
#64 0x00007f83652c74f5 in QEventLoop::exec (this=this@entry=0x7ffcdc96a4b0, flags=...) at kernel/qeventloop.cpp:204
#65 0x00007f83652cd4b9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1227
#66 0x00007f836460922c in QApplication::exec () at kernel/qapplication.cpp:3828
#67 0x00000000004376a3 in main (argc=<optimized out>, argv=<optimized out>) at /build/buildd/kvpm-0.9.9/kvpm/main.cpp:77

Possible duplicates by query: bug 353775.

Reported using DrKonqi
Comment 1 Christoph Feck 2016-05-31 12:27:34 UTC

*** This bug has been marked as a duplicate of bug 353775 ***