Bug 353775 - crash when resizeing LV
Summary: crash when resizeing LV
Status: RESOLVED DOWNSTREAM
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
: 363687 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-10 20:56 UTC by Gerhard Lehnhoff
Modified: 2016-05-31 12:27 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Lehnhoff 2015-10-10 20:56:16 UTC
Application: kvpm (0.9.9)
KDE Platform Version: 4.14.11
Qt Version: 4.8.6
Operating System: Linux 4.2.0-11-generic x86_64
Distribution: Ubuntu Wily Werewolf (development branch)

-- Information about the crash:
crashed when lv has been reduced. lv contained a ext4 fs. lv has been reduced after crash.

The crash can be reproduced every time.

-- Backtrace:
Application: kvpm (kvpm), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f841626f900 (LWP 5336))]

Thread 2 (Thread 0x7f8403e09700 (LWP 5395)):
#0  0x00007f84129bb8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f840eef51ec in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f840eef52fc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f84143d620e in QEventDispatcherGlib::processEvents (this=0x7f83f4003090, flags=...) at kernel/qeventdispatcher_glib.cpp:452
#4  0x00007f84143a40d1 in QEventLoop::processEvents (this=this@entry=0x7f8403e08c80, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f84143a4445 in QEventLoop::exec (this=this@entry=0x7f8403e08c80, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f84142934f9 in QThread::exec (this=this@entry=0xf87130) at thread/qthread.cpp:538
#7  0x00007f8414384133 in QInotifyFileSystemWatcherEngine::run (this=0xf87130) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f8414295d1c in QThreadPrivate::start (arg=0xf87130) at thread/qthread_unix.cpp:349
#9  0x00007f84103a66aa in start_thread (arg=0x7f8403e09700) at pthread_create.c:333
#10 0x00007f84129c6eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f841626f900 (LWP 5336)):
[KCrash Handler]
#6  SizeSelectorBox::getMaximumSize (this=0x50) at /build/buildd/kvpm-0.9.9/kvpm/sizeselectorbox.cpp:284
#7  0x000000000049ad20 in LVReduceDialog::resetOkButton (this=0xeb7650) at /build/buildd/kvpm-0.9.9/kvpm/lvreduce.cpp:181
#8  0x000000000049b4b8 in LVReduceDialog::LVReduceDialog (this=0xeb7650, volume=<optimized out>, parent=<optimized out>) at /build/buildd/kvpm-0.9.9/kvpm/lvreduce.cpp:150
#9  0x00000000004726a2 in LVActions::callDialog (this=0xe3f010, action=<optimized out>) at /build/buildd/kvpm-0.9.9/kvpm/lvactions.cpp:916
#10 0x00007f84143b9f60 in QMetaObject::activate (sender=0xe3f010, m=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3567
#11 0x00007f8415bf1822 in KActionCollection::actionTriggered(QAction*) () from /usr/lib/libkdeui.so.5
#12 0x00007f8415bf2676 in ?? () from /usr/lib/libkdeui.so.5
#13 0x00007f84143b9f60 in QMetaObject::activate (sender=sender@entry=0xe479d0, m=m@entry=0x7f84141e2dc0 <QAction::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7ffcdf5a3cd0) at kernel/qobject.cpp:3567
#14 0x00007f84136e8a42 in QAction::triggered (this=this@entry=0xe479d0, _t1=false) at .moc/release-shared/moc_qaction.cpp:276
#15 0x00007f84136e9da3 in QAction::activate (this=0xe479d0, event=<optimized out>) at kernel/qaction.cpp:1257
#16 0x00007f8413ac7fe3 in QAbstractButtonPrivate::click (this=this@entry=0xe56f70) at widgets/qabstractbutton.cpp:530
#17 0x00007f8413ac8134 in QAbstractButton::mouseReleaseEvent (this=0xd2b0c0, e=0x7ffcdf5a4260) at widgets/qabstractbutton.cpp:1123
#18 0x00007f8413b8e24a in QToolButton::mouseReleaseEvent (this=<optimized out>, e=<optimized out>) at widgets/qtoolbutton.cpp:723
#19 0x00007f8413742e20 in QWidget::event (this=0xd2b0c0, event=0x7ffcdf5a4260) at kernel/qwidget.cpp:8775
#20 0x00007f84136eecdc in QApplicationPrivate::notify_helper (this=this@entry=0xb105f0, receiver=receiver@entry=0xd2b0c0, e=e@entry=0x7ffcdf5a4260) at kernel/qapplication.cpp:4570
#21 0x00007f84136f5dd6 in QApplication::notify (this=<optimized out>, receiver=0xd2b0c0, e=0x7ffcdf5a4260) at kernel/qapplication.cpp:4113
#22 0x00007f8415ce3a2a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#23 0x00007f84143a585d in QCoreApplication::notifyInternal (this=0x7ffcdf5a4a70, receiver=receiver@entry=0xd2b0c0, event=event@entry=0x7ffcdf5a4260) at kernel/qcoreapplication.cpp:955
#24 0x00007f84136f53dd in QCoreApplication::sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#25 QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0xd2b0c0, event=event@entry=0x7ffcdf5a4260, alienWidget=alienWidget@entry=0xd2b0c0, nativeWidget=nativeWidget@entry=0xe50f60, buttonDown=buttonDown@entry=0x7f8414217318 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3178
#26 0x00007f84137709bb in QETWidget::translateMouseEvent (this=this@entry=0xe50f60, event=event@entry=0x7ffcdf5a45c0) at kernel/qapplication_x11.cpp:4632
#27 0x00007f8413770223 in QApplication::x11ProcessEvent (this=0x7ffcdf5a4a70, event=event@entry=0x7ffcdf5a45c0) at kernel/qapplication_x11.cpp:3626
#28 0x00007f8413799b52 in x11EventSourceDispatch (s=0xb10970, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#29 0x00007f840eef4ff7 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f840eef5250 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f840eef52fc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f84143d61ee in QEventDispatcherGlib::processEvents (this=0xaf0ba0, flags=...) at kernel/qeventdispatcher_glib.cpp:450
#33 0x00007f8413799c26 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f84143a40d1 in QEventLoop::processEvents (this=this@entry=0x7ffcdf5a49a0, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f84143a4445 in QEventLoop::exec (this=this@entry=0x7ffcdf5a49a0, flags=...) at kernel/qeventloop.cpp:204
#36 0x00007f84143aa429 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1227
#37 0x00007f84136ecf2c in QApplication::exec () at kernel/qapplication.cpp:3828
#38 0x00000000004376a3 in main (argc=<optimized out>, argv=<optimized out>) at /build/buildd/kvpm-0.9.9/kvpm/main.cpp:77

Reported using DrKonqi
Comment 1 Christoph Feck 2015-10-10 22:17:25 UTC
Bugs for KVPM are not tracked at the KDE bug tracker. Please report this issue directly to KVPM developers via http://sourceforge.net/p/kvpm/bugs/
Comment 2 Christoph Feck 2016-05-31 12:27:34 UTC
*** Bug 363687 has been marked as a duplicate of this bug. ***