Bug 363603 - Freeze Konquerer
Summary: Freeze Konquerer
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-05-27 20:46 UTC by vspindler
Modified: 2018-12-02 03:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vspindler 2016-05-27 20:46:57 UTC
Application: konqueror (4.14.18)
KDE Platform Version: 4.14.18
Qt Version: 4.8.6
Operating System: Linux 4.1.21-14-default x86_64
Distribution: "openSUSE Leap 42.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

surfing on website , scrolling, Konquerror was freezing, maybe flsh plugin?

The crash can be reproduced every time.

-- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd551f24780 (LWP 1238))]

Thread 7 (Thread 0x7fd532f29700 (LWP 1248)):
#0  0x00007fd54f490d4d in nanosleep () at /lib64/libc.so.6
#1  0x00007fd54f490be4 in sleep () at /lib64/libc.so.6
#2  0x00007fd537f4ee40 in WTF::TCMalloc_PageHeap::scavengerThread() () at /usr/lib64/libQtWebKit.so.4
#3  0x00007fd537f4eee9 in  () at /usr/lib64/libQtWebKit.so.4
#4  0x00007fd5507d20a4 in start_thread () at /lib64/libpthread.so.0
#5  0x00007fd54f4befed in clone () at /lib64/libc.so.6

Thread 6 (Thread 0x7fd53b821700 (LWP 1249)):
#0  0x00007fd5507d8a7d in read () at /lib64/libpthread.so.0
#1  0x00007fd54c5d6b60 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fd54c595999 in g_main_context_check () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fd54c595df8 in  () at /usr/lib64/libglib-2.0.so.0
#4  0x00007fd54c595f7c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#5  0x00007fd550b99fde in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#6  0x00007fd550b6bd4f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#7  0x00007fd550b6c045 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#8  0x00007fd550a694df in QThread::exec() () at /usr/lib64/libQtCore.so.4
#9  0x00007fd550a6bbbf in  () at /usr/lib64/libQtCore.so.4
#10 0x00007fd5507d20a4 in start_thread () at /lib64/libpthread.so.0
#11 0x00007fd54f4befed in clone () at /lib64/libc.so.6

Thread 5 (Thread 0x7fd4f23f1700 (LWP 1250)):
#0  0x00007fd5507d63e8 in pthread_cond_timedwait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fd537f76fe6 in WTF::ThreadCondition::timedWait(WTF::Mutex&, double) () at /usr/lib64/libQtWebKit.so.4
#2  0x00007fd537cc1a3c in JSC::BlockAllocator::waitForRelativeTime(double) () at /usr/lib64/libQtWebKit.so.4
#3  0x00007fd537cc1aa8 in JSC::BlockAllocator::blockFreeingThreadMain() () at /usr/lib64/libQtWebKit.so.4
#4  0x00007fd537f76a06 in WTF::wtfThreadEntryPoint(void*) () at /usr/lib64/libQtWebKit.so.4
#5  0x00007fd5507d20a4 in start_thread () at /lib64/libpthread.so.0
#6  0x00007fd54f4befed in clone () at /lib64/libc.so.6

Thread 4 (Thread 0x7fd4dcc31700 (LWP 1311)):
#0  0x00007fd5507d603f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fd4dcc98d79 in  () at /usr/lib64/java-1_8_0-openjdk-plugin/lib/IcedTeaPlugin.so
#2  0x00007fd4dcc99819 in  () at /usr/lib64/java-1_8_0-openjdk-plugin/lib/IcedTeaPlugin.so
#3  0x00007fd5507d20a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007fd54f4befed in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7fd4dc430700 (LWP 1312)):
#0  0x00007fd5507d603f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fd4dcc98d79 in  () at /usr/lib64/java-1_8_0-openjdk-plugin/lib/IcedTeaPlugin.so
#2  0x00007fd4dcc99819 in  () at /usr/lib64/java-1_8_0-openjdk-plugin/lib/IcedTeaPlugin.so
#3  0x00007fd5507d20a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007fd54f4befed in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7fd4dbc2f700 (LWP 1313)):
#0  0x00007fd5507d603f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fd4dcc98d79 in  () at /usr/lib64/java-1_8_0-openjdk-plugin/lib/IcedTeaPlugin.so
#2  0x00007fd4dcc99819 in  () at /usr/lib64/java-1_8_0-openjdk-plugin/lib/IcedTeaPlugin.so
#3  0x00007fd5507d20a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007fd54f4befed in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7fd551f24780 (LWP 1238)):
[KCrash Handler]
#6  0x0000000000000000 in  ()
#7  0x00007fd550b73729 in QMetaObject::cast(QObject*) const () at /usr/lib64/libQtCore.so.4
#8  0x00007fd536b22924 in WebCore::FrameNetworkingContextQt::networkAccessManager() const () at /usr/lib64/libQtWebKit.so.4
#9  0x00007fd53741d2f5 in WebCore::thirdPartyCookiePolicyPermits(WebCore::NetworkingContext*, QUrl const&, QUrl const&) () at /usr/lib64/libQtWebKit.so.4
#10 0x00007fd53740d67b in WebCore::ResourceRequest::toNetworkRequest(WebCore::NetworkingContext*) const () at /usr/lib64/libQtWebKit.so.4
#11 0x00007fd537413655 in WebCore::QNetworkReplyHandler::redirect(WebCore::ResourceResponse&, QUrl const&) () at /usr/lib64/libQtWebKit.so.4
#12 0x00007fd5374144d2 in WebCore::QNetworkReplyHandler::sendResponseIfNeeded() () at /usr/lib64/libQtWebKit.so.4
#13 0x00007fd5374122bf in WebCore::QNetworkReplyHandlerCallQueue::flush() [clone .part.56] () at /usr/lib64/libQtWebKit.so.4
#14 0x00007fd537412c54 in WebCore::QNetworkReplyWrapper::receiveMetaData() () at /usr/lib64/libQtWebKit.so.4
#15 0x00007fd550b810fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /usr/lib64/libQtCore.so.4
#16 0x00007fd550b75228 in QMetaMethod::invoke(QObject*, Qt::ConnectionType, QGenericReturnArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument) const () at /usr/lib64/libQtCore.so.4
#17 0x00007fd550b77702 in QMetaObject::invokeMethod(QObject*, char const*, Qt::ConnectionType, QGenericReturnArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument) () at /usr/lib64/libQtCore.so.4
#18 0x00007fd5466447ec in  () at /usr/lib64/libkio.so.5
#19 0x00007fd546646470 in  () at /usr/lib64/libkio.so.5
#20 0x00007fd550b810fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /usr/lib64/libQtCore.so.4
#21 0x00007fd551006132 in KJob::result(KJob*) () at /usr/lib64/libkdecore.so.5
#22 0x00007fd551006170 in KJob::emitResult() () at /usr/lib64/libkdecore.so.5
#23 0x00007fd54668031a in KIO::SimpleJob::slotFinished() () at /usr/lib64/libkio.so.5
#24 0x00007fd54668148e in KIO::TransferJob::slotFinished() () at /usr/lib64/libkio.so.5
#25 0x00007fd550b810fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /usr/lib64/libQtCore.so.4
#26 0x00007fd54671be86 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () at /usr/lib64/libkio.so.5
#27 0x00007fd5467199ae in KIO::SlaveInterface::dispatch() () at /usr/lib64/libkio.so.5
#28 0x00007fd54670e6c6 in KIO::Slave::gotInput() () at /usr/lib64/libkio.so.5
#29 0x00007fd550b810fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /usr/lib64/libQtCore.so.4
#30 0x00007fd54664e4d1 in  () at /usr/lib64/libkio.so.5
#31 0x00007fd550b8549e in QObject::event(QEvent*) () at /usr/lib64/libQtCore.so.4
#32 0x00007fd54fce779c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQtGui.so.4
#33 0x00007fd54fcedcdd in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQtGui.so.4
#34 0x00007fd551916e9a in KApplication::notify(QObject*, QEvent*) () at /usr/lib64/libkdeui.so.5
#35 0x00007fd550b6d18d in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib64/libQtCore.so.4
#36 0x00007fd550b7045d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib64/libQtCore.so.4
#37 0x00007fd550b9a7fe in  () at /usr/lib64/libQtCore.so.4
#38 0x00007fd54c595c84 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#39 0x00007fd54c595ed8 in  () at /usr/lib64/libglib-2.0.so.0
#40 0x00007fd54c595f7c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#41 0x00007fd550b99fbe in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#42 0x00007fd54fd846a6 in  () at /usr/lib64/libQtGui.so.4
#43 0x00007fd550b6bd4f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#44 0x00007fd550b6c045 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#45 0x00007fd550b71499 in QCoreApplication::exec() () at /usr/lib64/libQtCore.so.4
#46 0x00007fd5478a5cbe in kdemain () at /usr/lib64/libkdeinit4_konqueror.so
#47 0x0000000000408815 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 320316.

Possible duplicates by query: bug 320316.

Reported using DrKonqi
Comment 1 Andrew Crouthamel 2018-11-01 13:52:20 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 2 Bug Janitor Service 2018-11-16 11:42:03 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2018-12-02 03:48:01 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!