Bug 320316 - Crashes When Logging into Webmail
Summary: Crashes When Logging into Webmail
Status: RESOLVED WORKSFORME
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdewebkit (show other bugs)
Version: 4.10.3
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: webkit-devel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-26 16:30 UTC by Russ Fineman
Modified: 2013-06-17 03:01 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot (148.31 KB, image/png)
2013-05-29 04:54 UTC, Dawit Alemayehu
Details
New crash information added by DrKonqi (11.32 KB, text/plain)
2013-06-17 03:01 UTC, Donald A. Syvanen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Russ Fineman 2013-05-26 16:30:55 UTC
Application: konqueror (4.10.3 "release 559")
KDE Platform Version: 4.10.3 "release 563"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.4-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Click link to Webmail and Konqueror crashed. 
Code
---------
https://mail.nwi.net/landing.php
/CODE
----------
This should take me to login page with Uer ID and Password. Link works in SeaMonkey, Chromium and FireFox.
Note trying to load missing debug files says :
KDEinit4 is missing (True -not in openSUSE repo's for KDE 4.10.3)

The crash can be reproduced every time.

-- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0eceb45780 (LWP 6097))]

Thread 9 (Thread 0x7f0eb1fc8700 (LWP 6098)):
#0  0x00007f0ecd405964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0ec312e2f0 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f0ec3bad7c0 <WTF::pageheap_memory>) at /usr/src/debug/webkit-qtwebkit-23/Source/WTF/wtf/FastMalloc.cpp:2571
#2  0x00007f0ec312e329 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at /usr/src/debug/webkit-qtwebkit-23/Source/WTF/wtf/FastMalloc.cpp:1767
#3  0x00007f0ecd401e0f in start_thread () from /lib64/libpthread.so.0
#4  0x00007f0ecc1787dd in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f0eb085b700 (LWP 6099)):
#0  0x00007f0ec90f9a71 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f0ec90bca8a in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f0ec90bcbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f0ecd7c22e6 in QEventDispatcherGlib::processEvents (this=0x7f0e640008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f0ecd792adf in QEventLoop::processEvents (this=this@entry=0x7f0eb085ae00, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f0ecd792d68 in QEventLoop::exec (this=0x7f0eb085ae00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f0ecd6950f0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007f0ecd6980cc in QThreadPrivate::start (arg=0x12cd920) at thread/qthread_unix.cpp:338
#8  0x00007f0ecd401e0f in start_thread () from /lib64/libpthread.so.0
#9  0x00007f0ecc1787dd in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f0e6b3bd700 (LWP 6102)):
#0  0x00007f0ecd405964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0ec2eac157 in JSC::BlockAllocator::blockFreeingThreadMain (this=0x7f0eb173b398) at /usr/src/debug/webkit-qtwebkit-23/Source/JavaScriptCore/heap/BlockAllocator.cpp:128
#2  0x00007f0ec315581e in WTF::wtfThreadEntryPoint (param=0x1474350) at /usr/src/debug/webkit-qtwebkit-23/Source/WTF/wtf/ThreadingPthreads.cpp:196
#3  0x00007f0ecd401e0f in start_thread () from /lib64/libpthread.so.0
#4  0x00007f0ecc1787dd in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f0e59ce1700 (LWP 6124)):
#0  0x00007f0ecc16b97d in read () from /lib64/libc.so.6
#1  0x00007f0ebcd2fe41 in ?? () from /usr/lib64/tls/libnvidia-tls.so.319.17
#2  0x00007f0ec90f8e0f in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f0ec90bc634 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f0ec90bca42 in ?? () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f0ec90bcf02 in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#6  0x00007f0e61b2eba6 in ?? () from /usr/lib64/libgio-2.0.so.0
#7  0x00007f0ec90e0345 in ?? () from /usr/lib64/libglib-2.0.so.0
#8  0x00007f0ecd401e0f in start_thread () from /lib64/libpthread.so.0
#9  0x00007f0ecc1787dd in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f0e53fff700 (LWP 6127)):
#0  0x00007f0ecd405964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0e582d1e93 in queue_processor(void*) () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007f0ecd401e0f in start_thread () from /lib64/libpthread.so.0
#3  0x00007f0ecc1787dd in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f0e537fe700 (LWP 6128)):
#0  0x00007f0ecd405964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0e582d1e93 in queue_processor(void*) () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007f0ecd401e0f in start_thread () from /lib64/libpthread.so.0
#3  0x00007f0ecc1787dd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f0e52ffd700 (LWP 6129)):
#0  0x00007f0ecd405964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0e582d1e93 in queue_processor(void*) () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007f0ecd401e0f in start_thread () from /lib64/libpthread.so.0
#3  0x00007f0ecc1787dd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f0e13cba700 (LWP 6185)):
#0  0x00007f0ecd403e25 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f0ec90f9a71 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f0ec90bc343 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f0ec90bc9cb in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f0ec90bcbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f0ecd7c22e6 in QEventDispatcherGlib::processEvents (this=0x7f0e30003070, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f0ecd792adf in QEventLoop::processEvents (this=this@entry=0x7f0e13cb9dd0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f0ecd792d68 in QEventLoop::exec (this=0x7f0e13cb9dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f0ecd6950f0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#9  0x00007f0ec64cd4ee in KIO::NameLookUpThread::run (this=0x1d1c1a0) at /usr/src/debug/kdelibs-4.10.3/kio/kio/hostinfo.cpp:226
#10 0x00007f0ecd6980cc in QThreadPrivate::start (arg=0x1d1c1a0) at thread/qthread_unix.cpp:338
#11 0x00007f0ecd401e0f in start_thread () from /lib64/libpthread.so.0
#12 0x00007f0ecc1787dd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f0eceb45780 (LWP 6097)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f0ecd79a1c9 in QMetaObject::cast (this=0x7f0ec3a1f440 <QWebFrame::staticMetaObject>, obj=0x168a790) at kernel/qmetaobject.cpp:274
#8  0x00007f0ec1d34d44 in WebCore::FrameNetworkingContextQt::networkAccessManager () from /usr/lib64/libQtWebKit.so.4
#9  0x00007f0ec267b31a in WebCore::thirdPartyCookiePolicyPermits () from /usr/lib64/libQtWebKit.so.4
#10 0x00007f0ec266b443 in WebCore::ResourceRequest::toNetworkRequest () from /usr/lib64/libQtWebKit.so.4
#11 0x00007f0ec267180d in WebCore::QNetworkReplyHandler::redirect () from /usr/lib64/libQtWebKit.so.4
#12 0x00007f0ec267255a in WebCore::QNetworkReplyHandler::sendResponseIfNeeded () from /usr/lib64/libQtWebKit.so.4
#13 0x00007f0ec266f211 in WebCore::QNetworkReplyHandlerCallQueue::flush () from /usr/lib64/libQtWebKit.so.4
#14 0x00007f0ec266fd3a in WebCore::QNetworkReplyWrapper::receiveMetaData () from /usr/lib64/libQtWebKit.so.4
#15 0x00007f0ecd7a929f in QMetaObject::activate (sender=0x12b5260, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3548
#16 0x00007f0ecd79bca7 in QMetaMethod::invoke (this=this@entry=0x7fff97672060, object=object@entry=0x12b5260, connectionType=Qt::DirectConnection, connectionType@entry=Qt::AutoConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#17 0x00007f0ecd79e07c in QMetaObject::invokeMethod (obj=0x12b5260, member=<optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#18 0x00007f0ec63ecbec in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., type=Qt::AutoConnection, member=0x7f0ec654fae2 "finished", obj=0x12b5260) at /usr/include/QtCore/qobjectdefs.h:418
#19 KDEPrivate::AccessManagerReply::emitFinished (this=this@entry=0x12b5260, state=state@entry=true, type=type@entry=Qt::AutoConnection) at /usr/src/debug/kdelibs-4.10.3/kio/kio/accessmanagerreply_p.cpp:484
#20 0x00007f0ec63edee5 in KDEPrivate::AccessManagerReply::slotResult (this=0x12b5260, kJob=0x1cf93e0) at /usr/src/debug/kdelibs-4.10.3/kio/kio/accessmanagerreply_p.cpp:427
#21 0x00007f0ecd7a929f in QMetaObject::activate (sender=0x1cf93e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff97672610) at kernel/qobject.cpp:3548
#22 0x00007f0ecdc22162 in KJob::result (this=this@entry=0x1cf93e0, _t1=_t1@entry=0x1cf93e0) at /usr/src/debug/kdelibs-4.10.3/build/kdecore/kjob.moc:208
#23 0x00007f0ecdc221a0 in KJob::emitResult (this=0x1cf93e0) at /usr/src/debug/kdelibs-4.10.3/kdecore/jobs/kjob.cpp:318
#24 0x00007f0ec6420d65 in KIO::SimpleJob::slotFinished (this=this@entry=0x1cf93e0) at /usr/src/debug/kdelibs-4.10.3/kio/kio/job.cpp:494
#25 0x00007f0ec6428272 in KIO::TransferJob::slotFinished (this=0x1cf93e0) at /usr/src/debug/kdelibs-4.10.3/kio/kio/job.cpp:1081
#26 0x00007f0ecd7a929f in QMetaObject::activate (sender=0x1498410, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3548
#27 0x00007f0ec64c3a31 in KIO::SlaveInterface::dispatch (this=0x1498410, _cmd=104, rawdata=...) at /usr/src/debug/kdelibs-4.10.3/kio/kio/slaveinterface.cpp:172
#28 0x00007f0ec64c0b1a in KIO::SlaveInterface::dispatch (this=0x1498410) at /usr/src/debug/kdelibs-4.10.3/kio/kio/slaveinterface.cpp:88
#29 0x00007f0ec64b507e in KIO::Slave::gotInput (this=0x1498410) at /usr/src/debug/kdelibs-4.10.3/kio/kio/slave.cpp:344
#30 0x00007f0ecd7a929f in QMetaObject::activate (sender=0x187f3b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3548
#31 0x00007f0ec63f5c72 in dequeue (this=<optimized out>) at /usr/src/debug/kdelibs-4.10.3/kio/kio/connection.cpp:82
#32 KIO::ConnectionPrivate::dequeue (this=0x189ede0) at /usr/src/debug/kdelibs-4.10.3/kio/kio/connection.cpp:71
#33 0x00007f0ecd7a877e in QObject::event (this=0x187f3b0, e=<optimized out>) at kernel/qobject.cpp:1203
#34 0x00007f0ecc92186c in QApplicationPrivate::notify_helper (this=this@entry=0x9862b0, receiver=receiver@entry=0x187f3b0, e=e@entry=0x183efb0) at kernel/qapplication.cpp:4562
#35 0x00007f0ecc925ceb in QApplication::notify (this=0x7fff97673960, receiver=0x187f3b0, e=0x183efb0) at kernel/qapplication.cpp:4423
#36 0x00007f0ece537146 in KApplication::notify (this=0x7fff97673960, receiver=0x187f3b0, event=0x183efb0) at /usr/src/debug/kdelibs-4.10.3/kdeui/kernel/kapplication.cpp:311
#37 0x00007f0ecd793d8e in QCoreApplication::notifyInternal (this=0x7fff97673960, receiver=receiver@entry=0x187f3b0, event=event@entry=0x183efb0) at kernel/qcoreapplication.cpp:946
#38 0x00007f0ecd7976f1 in sendEvent (event=0x183efb0, receiver=0x187f3b0) at kernel/qcoreapplication.h:231
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x7f32b0) at kernel/qcoreapplication.cpp:1570
#40 0x00007f0ecd7c2133 in sendPostedEvents () at kernel/qcoreapplication.h:236
#41 postEventSourceDispatch (s=0x987380) at kernel/qeventdispatcher_glib.cpp:279
#42 0x00007f0ec90bc7d5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#43 0x00007f0ec90bcb08 in ?? () from /usr/lib64/libglib-2.0.so.0
#44 0x00007f0ec90bcbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#45 0x00007f0ecd7c22c6 in QEventDispatcherGlib::processEvents (this=0x7f9790, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#46 0x00007f0ecc9c1c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x00007f0ecd792adf in QEventLoop::processEvents (this=this@entry=0x7fff97673660, flags=...) at kernel/qeventloop.cpp:149
#48 0x00007f0ecd792d68 in QEventLoop::exec (this=0x7fff97673660, flags=...) at kernel/qeventloop.cpp:204
#49 0x00007f0ecd797a08 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#50 0x00007f0eb8b634b2 in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kde-baseapps-4.10.3/konqueror/src/konqmain.cpp:227
#51 0x000000000040889a in _start ()

Reported using DrKonqi
Comment 1 Dawit Alemayehu 2013-05-26 17:28:14 UTC
There is no way for us to test this since it requires a login. Also the backtrace from the crash seems to  implicate QtWebKit as the source of this crash. However, out of curiosity can you tell us what version of qtwebkit package is installed on your system ? Do you have the latest 2.3 version ?
Comment 2 Russ Fineman 2013-05-27 00:45:25 UTC
(In reply to comment #1)
> There is no way for us to test this since it requires a login. Also the
> backtrace from the crash seems to  implicate QtWebKit as the source of this
> crash. However, out of curiosity can you tell us what version of qtwebkit
> package is installed on your system ? Do you have the latest 2.3 version ?

from openSUSE repo:
[CODE]
-----------------
rpl7:~> rpm -qi libQtWebKit4
Name        : libQtWebKit4
Version     : 4.8.4+2.3.1
Release     : 62.1
Architecture: x86_64
Install Date: Fri 03 May 2013 02:12:12 PM PDT
Group       : Development/Libraries/C and C++
Size        : 34467263
License     : LGPL-2.1+ and BSD-3-Clause
Signature   : DSA/SHA1, Thu 02 May 2013 12:29:25 PM PDT, Key ID 27c070176f88bb2f
Source RPM  : libQtWebKit4-4.8.4+2.3.1-62.1.src.rpm
Build Date  : Thu 02 May 2013 04:14:14 AM PDT
Build Host  : build34
Relocations : (not relocatable)
Vendor      : obs://build.opensuse.org/KDE
URL         : http://trac.webkit.org/wiki/QtWebKit
Summary     : Open source Web Browser engine based on Qt4
Description :
WebKit is an open source web browser engine. WebKit's HTML and JavaScript code
began as a branch of the KHTML and KJS libraries from KDE. As part of KDE
framework KHTML was based on Qt but during their porting efforts Apple's
engineers made WebKit toolkit independent. QtWebKit is a project aiming at
porting this fabulous engine back to Qt.
Distribution: KDE:Qt / openSUSE_12.3
[/CODE]
----------------
Not sure what latest version 2.3 is. There is also a debug program installed and  it does not actually require loggin, it crashs before I get to the loggin screen at my ISP's website.

I assume that the numbering of the package maybe openSUSE's. It came from the install dvd originally, may have been updated recently, no sure. My openSUSE 12.2 install works fine with KDE 4.10.3. Not sure of release of KDE, but I know Konqueror is Release 359 there also.
Comment 3 Russ Fineman 2013-05-27 00:47:05 UTC
Is it possible this is openSUSE problem?  I can Copy this there if necessary.
Thanks for your quick response.
Comment 4 Dawit Alemayehu 2013-05-29 04:53:53 UTC
(In reply to comment #3)
> Is it possible this is openSUSE problem?  I can Copy this there if necessary.
> Thanks for your quick response.

Well it seems to be, because I most definitely cannot reproduce the crash by just clicking on the link to visit the page. Instead, I get the login page from your ISP. See attached screenshots.
Comment 5 Dawit Alemayehu 2013-05-29 04:54:37 UTC
Created attachment 80146 [details]
screenshot
Comment 6 Russ Fineman 2013-05-29 16:54:56 UTC
Don't think its openSUSE or you. Its working today. I called the ISP last week and they said no problems, but they actually contract with someone to provide service. 

My bet is there supplier fixed something.  The old phone company game, it's not us!

Thanks for your help. I say we close this?

Russ
Comment 7 Dawit Alemayehu 2013-05-30 11:18:44 UTC
See comment #6.
Comment 8 Donald A. Syvanen 2013-06-17 03:01:55 UTC
Created attachment 80573 [details]
New crash information added by DrKonqi

konqueror (4.10.4) on KDE Platform 4.10.4 using Qt 4.8.4

- What I was doing when the application crashed:

I clicked the mouse to see an email, and Konqueror crashed.

-- Backtrace (Reduced):
#7  0x0000003dcdc518f4 in WebCore::FrameNetworkingContextQt::networkAccessManager() const () from /lib64/libQtWebKit.so.4
#8  0x0000003dce5aa67a in WebCore::thirdPartyCookiePolicyPermits(WebCore::NetworkingContext*, QUrl const&, QUrl const&) () from /lib64/libQtWebKit.so.4
#9  0x0000003dce59a7a3 in WebCore::ResourceRequest::toNetworkRequest(WebCore::NetworkingContext*) const () from /lib64/libQtWebKit.so.4
#10 0x0000003dce5a0b6d in WebCore::QNetworkReplyHandler::redirect(WebCore::ResourceResponse&, QUrl const&) () from /lib64/libQtWebKit.so.4
#11 0x0000003dce5a18ba in WebCore::QNetworkReplyHandler::sendResponseIfNeeded() () from /lib64/libQtWebKit.so.4