Bug 361887 - gwenview shows wrong colours
Summary: gwenview shows wrong colours
Status: RESOLVED NOT A BUG
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 4.13.1
Platform: Kubuntu Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-17 09:43 UTC by Jens
Modified: 2016-12-20 14:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens 2016-04-17 09:43:02 UTC
Hello,

I have a problem with gwenview showing wrong colours. I presume these are complementary colours shown: yellow shows magenta, green shows violet, blue shows green, and so on. 
A violet meadow with a green sky looks somehow "alienated" :-'

This happens to most of my JPG and some PNG images. I couldn't figure out why some images show the correct colours. 
Interestingly this error appears just in the view mode. The thumbnails show the correct colours. All other programs have no problems in showing the correct colours. (Maybe the thumbnails are created with another program/app/module/component.)

Sorry if there is a well known solution for this but I couldn't find anything.


Reproducible: Always

Steps to Reproduce:
Sorry, I have no idea how to reproduce this issue. I installed this program with Muon. That' all I can say.



System:
Linux  3.16.0-70-generic #90~14.04.1-Ubuntu SMP Wed Apr 6 22:56:34 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Christoph Feck 2016-04-20 01:18:50 UTC

*** This bug has been marked as a duplicate of bug 341943 ***
Comment 2 Jens 2016-04-20 06:43:16 UTC
???

What shall I do with this other bug report??? I have absolutely no idea what the sense of this should be. Shall I install something – if so what? Or is the suggestion to convert all my images?

Sorry, this didn't help at all.  [:complete confusion:]
Comment 3 Jan Kundrát 2016-12-20 12:10:16 UTC
You have probably installed a testing color profile for your screen. Ensure that your system's settings do not have these profiles installed.
Comment 4 Jens 2016-12-20 14:02:18 UTC
Hi Jan,

that has been a long time since I posted my request. Thank you for answering :)

But I did not install any colour profile on this system. All installed profiles are those from the installation CD or any of the system updates. I did add a colour profile for an elder monitor some months ago, but the monitor as well as the Kubuntu installation of the time of my post are broken by now. Nevertheless the problem remained with a new Kubuntu (14.04 LTS) and a new monitor.

In the meantime I tried all Nvidia versions and now also without an Nvidia installation – still without any changes (if someone should come to this proposal).

So after searching endlessly for a solution without any clue, I discarded the use of Gwenview and installed GPicView, XnView and even IrfanView which all are doing a fine job.

Anyway I'm still and technically interested in a solution for this issue. So if someone still could find an answer I would be very thankful.