Bug 341943 - Gwenview cannot apply image color profile
Summary: Gwenview cannot apply image color profile
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR major with 40 votes (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL: http://abload.de/img/5172nfsfp.png
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-16 12:41 UTC by Ettore Atalan
Modified: 2016-04-20 01:18 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ettore Atalan 2014-12-16 12:41:10 UTC
Gwenview (v4.14.0 pre) cannot apply the image color profile of a specific PNG file. Gwenview's image area is still empty after loading the file.

Terminal Output:

Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QDBusObjectPath)
Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QDBusObjectPath)
Bus::open: Can not get ibus-daemon's address. 
IBusInputContext::createInputContext: no connection to ibus-daemon 
gwenview(12387)/kdeui (kdelibs): Attempt to use QAction "edit_redo" with KXMLGUIFactory! 
gwenview(12387)/kdeui (kdelibs): Attempt to use QAction "edit_undo" with KXMLGUIFactory! 
QPropertyAnimation::updateState (opacity): Changing state of an animation without target
QPropertyAnimation::updateState (geometry): Changing state of an animation without target
QPropertyAnimation::updateState (opacity): Changing state of an animation without target
QPropertyAnimation::updateState (geometry): Changing state of an animation without target
gwenview(12387) Gwenview::ThumbnailProvider::checkThumbnail: Thumbnail for "file:///home/ata/Arbeitsfl%C3%A4che/5172.png" does not contain correct image size information 
gwenview(12387) Gwenview::ThumbnailProvider::checkThumbnail: Thumbnail for "file:///home/ata/Arbeitsfl%C3%A4che/5172.png" does not contain correct image size information 
gwenview(12387) Gwenview::RasterImageViewPrivate::updateDisplayTransform: This image has a color profile, but Gwenview can only apply color profile on RGB32 or ARGB32 images 


Reproducible: Always

Steps to Reproduce:
1. Download the PNG file from URL http://abload.de/img/5172nfsfp.png
2. Open this PNG file in Gwenview

Actual Results:  
No picture.

Expected Results:  
A picture.
Comment 1 Jan Kundrát 2015-05-28 21:27:39 UTC
With gwenview 14.12.3 and littlecms 2.6-r1 on Gentoo Linux, that image opens and renders, but the embedded ICC profile is ignored (green in "Accessibility" is too saturated, too much towards a dark green). That is fixed by https://git.reviewboard.kde.org/r/123928/ which shows that word a little bit more yellowish.
Comment 2 Jan Kundrát 2015-06-02 15:00:03 UTC
Git commit 1425825120ad19fc085fe62ca025023d46038aef by Jan Kundrát.
Committed on 29/05/2015 at 00:32.
Pushed by jkt into branch 'master'.

Apply display color profile to all images

...including those which do not have any embedded profile. Just treat
them as sRGB, which is probably a reasonable choice. This makes a huge
difference on wide-gamut displays.

LittleCMS doesn't support RGBA_Premultiplied because premultipled alpha
doesn't "make a lot of sense with a color management system since color
perception varies with intensity and the colorspace may not be linear
across the color channels" (see [1] for why, and for an experimental
patch which apparently didn't move anywhere and wasn't merged).

[1] http://sourceforge.net/p/lcms/mailman/message/30246542/

REVIEW: 123928
Related: bug 322149

M  +6    -1    lib/cms/cmsprofile.cpp
M  +1    -0    lib/cms/cmsprofile.h
M  +4    -2    lib/documentview/rasterimageview.cpp
M  +0    -2    lib/imagescaler.cpp

http://commits.kde.org/gwenview/1425825120ad19fc085fe62ca025023d46038aef
Comment 3 Christoph Feck 2016-04-20 01:18:50 UTC
*** Bug 361887 has been marked as a duplicate of this bug. ***