Bug 361534 - Kwin crashes while playing games 2D Using OpenGL?
Summary: Kwin crashes while playing games 2D Using OpenGL?
Status: RESOLVED DUPLICATE of bug 361154
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.6.2
Platform: Other Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-08 22:14 UTC by wolfyrion
Modified: 2016-04-09 15:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wolfyrion 2016-04-08 22:14:57 UTC
If I play games like super meat boy  or MAME Games (sdlmame) using openg after I finish playing the games all my plasma 5 ui is corrupted.
example how it looks
http://i.imgur.com/bxGsIkJ.png

The worst of all is that anything that I try to open it keeps flashing my whole screen and I have to restart or log out and login back again.

Reproducible: Always

Steps to Reproduce:
1. just play a game super meat boy from steam or sdlmame games with opengl support
2.
3.

Actual Results:  
After finishing playing the games my whole ui looks like this
http://i.imgur.com/bxGsIkJ.png

it seems that KWIN compositor is crashing

Expected Results:  
not corrupted graphics
Comment 1 Thomas Lübking 2016-04-08 22:40:11 UTC
Looks like bug #361477 resp. bug #361154
The weird pattern is that suspending the compositor (SHIFT+Alt+F12) prevents the problems, but resuming the compositor (what implies a new GL context) restores the problem.

Please attach the output of "qdbus org.kde.KWin /KWin supportInformation" (w/ running compositor, but the problem doesn't need to be present)
Comment 2 wolfyrion 2016-04-09 05:16:07 UTC
I have posted the 3 text output files in dropbox - folder corruption

https://www.dropbox.com/sh/jjnfxt3qsv7ncih/AABfLxFw93N-SSAEsM7hb0_Va?dl=0

Text files

no problem --> without the problem 
during the problem  --> while running a specific game in sdlmame disabling the compositor
with the problem --> exiting the game but having the texture corruption

https://www.dropbox.com/sh/jjnfxt3qsv7ncih/AABfLxFw93N-SSAEsM7hb0_Va?dl=0
Comment 3 Thomas Lübking 2016-04-09 06:55:25 UTC
"during the problem" has
> Compositing
> ===========
> Compositing is not active

Is that correct?
Sounds as if the decoration window still includes some shadow padding?

Can you please dump xwinfinfo and xprop of the damaged area?

Run:
    xwinfinfo > damage.info; xwinfinfo > damage.props

The cursor will turn into a "+" twice, just click somewhere into the damaged area next to the border.
The output will be redirected into two files damage.info & damage.props. Please attach them *here* - do in general not use paste.kde.org nor dropbox for relevant bug information, since that information might be lost for future bug readers. Thanks.
Comment 4 wolfyrion 2016-04-09 11:52:01 UTC
First it seems that Plasma 5 is disabling composing automatically each time I start a 3D Game. Why?? I dont have the option to disable in full screen.


xwininfo > damage.info; xwininfo > damage.props


DAMAGE INFO

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0x1a00011 "Desktop — Plasma"

  Absolute upper-left X:  0
  Absolute upper-left Y:  0
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 2560
  Height: 1440
  Depth: 32
  Visual: 0x7a
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x1a0000f (not installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +0+0  -1920+0  -1920-0  +0-0
  -geometry 2560x1440+0+0


DAMAGE PROPS


xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0x1a00011 "Desktop — Plasma"

  Absolute upper-left X:  0
  Absolute upper-left Y:  0
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 2560
  Height: 1440
  Depth: 32
  Visual: 0x7a
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x1a0000f (not installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +0+0  -1920+0  -1920-0  +0-0
  -geometry 2560x1440+0+0
Comment 5 wolfyrion 2016-04-09 12:03:13 UTC
Also I have install another  window manager like compiz and set it as a default Window Manager and it doesnt cause this problem so I assume is something with KWIN :o?
Comment 6 Thomas Lübking 2016-04-09 14:02:54 UTC
That's the desktop window - if the information regarding the compositor is correct, things turn really weird (could be some OutputOnly window - not sure whether xprop etc. capture them)

How do the artifacts behave if you move the window? Do the move with it, remain static or "clear" (ie. the re-exposed region gets fixed)?
Comment 7 wolfyrion 2016-04-09 14:56:33 UTC
it seems is a shadow something  that why I Cant capture that as a window and it captures the plasma 5 desktop.

Yes when I move the window the corrupted shadow thingy is moving as well.

As I said before this actually is happening with ALL the 3D Games or any other application is using opengl
KWIN automatically disables the compositor on launch of a 3D Application or game which that was not happening before. So is behaving like disabling/enabling compositor and causing these problems. 

This was not happening before, KWIN was not disabling the compositor thats why I didnt have any problems.
 I think these problems occurred during the last update.

So noone of you can reproduce that bug... I mean you dont have any Application/GAME that is using opengl to launch just to see that it disables the compositor?
Comment 8 Thomas Lübking 2016-04-09 15:58:21 UTC
I'm not even running KWin (or any KDE or any Qt) anymore...

----

The compositor is suspended because the game asks for that - you can override that by a rule.
It however hardly explains this behavior nor is overriding it a sane fix to the problem.

If the artifacts move along the window and are even visible while the compositor is suspended, the only explanation is an OutputOnly window which is likely supposed to contain the deco shadows and is for some strange reason not removed (plus I really thought we'd now have gotten rid of the stupid window-but-not-the-window shadows)

Also it's not clear whether this is really the cause (see bug #361154, "I can disable compositing for say the Steam client (in a kwin rule) and launching a Steam game - does not cause the compositing issues.")
And no: never seen. I've no steam/account, though.

*** This bug has been marked as a duplicate of bug 361154 ***