Bug 349904 - Colgado cargando en Onedrive
Summary: Colgado cargando en Onedrive
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-07-04 17:41 UTC by Andres
Modified: 2021-01-16 04:34 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andres 2015-07-04 17:41:46 UTC
Application: akonadi_imap_resource (4.14)
KDE Platform Version: 4.14.2 (Compiled from sources)
Qt Version: 4.8.6
Operating System: Linux 3.16.0-41-generic i686
Distribution: Ubuntu 14.04.2 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Estaba cargando archivos en OneDrive y la aplicación pedía certificados de seguridad que no me había pedido antes, por consecuencia de tanto preguntar, la aplicación se cerró

-- Backtrace:
Application: Google Mail (azentenolara) de tipo Servidor de correo IMAP (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb4b69740 (LWP 5877))]

Thread 4 (Thread 0xb1be7b40 (LWP 5882)):
#0  0xb55fe0bd in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb579cfd4 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb55550e0 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb55102b5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb5510528 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb738b95f in QEventDispatcherGlib::processEvents (this=0xb0675630, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0xb735a823 in QEventLoop::processEvents (this=this@entry=0xb1be7288, flags=...) at kernel/qeventloop.cpp:149
#7  0xb735ab49 in QEventLoop::exec (this=this@entry=0xb1be7288, flags=...) at kernel/qeventloop.cpp:204
#8  0xb724723d in QThread::exec (this=this@entry=0x90b65a0) at thread/qthread.cpp:537
#9  0xb724738b in QThread::run (this=0x90b65a0) at thread/qthread.cpp:604
#10 0xb7249b6f in QThreadPrivate::start (arg=0x90b65a0) at thread/qthread_unix.cpp:349
#11 0xb55fbf70 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb578fbee in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xaf5fdb40 (LWP 6834)):
#0  0xb5554d13 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb5555118 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb550f99e in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb55102df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb5510528 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb738b95f in QEventDispatcherGlib::processEvents (this=0xb0705ec8, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0xb735a823 in QEventLoop::processEvents (this=this@entry=0xaf5fd288, flags=...) at kernel/qeventloop.cpp:149
#7  0xb735ab49 in QEventLoop::exec (this=this@entry=0xaf5fd288, flags=...) at kernel/qeventloop.cpp:204
#8  0xb724723d in QThread::exec (this=this@entry=0x91cbf98) at thread/qthread.cpp:537
#9  0xb724738b in QThread::run (this=0x91cbf98) at thread/qthread.cpp:604
#10 0xb7249b6f in QThreadPrivate::start (arg=0x91cbf98) at thread/qthread_unix.cpp:349
#11 0xb55fbf70 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb578fbee in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb11ffb40 (LWP 6838)):
#0  0xb7795d50 in __kernel_vsyscall ()
#1  0xb579d872 in clock_gettime () from /lib/i386-linux-gnu/libc.so.6
#2  0xb72a48cc in do_gettime (frac=0xb11ff020, sec=0xb11ff018) at tools/qelapsedtimer_unix.cpp:127
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:144
#4  0xb738d2a2 in updateCurrentTime (this=0xb0802674) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=0xb0802674, tm=...) at kernel/qeventdispatcher_unix.cpp:460
#6  0xb738b82b in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb11ff11c) at kernel/qeventdispatcher_glib.cpp:143
#7  0xb738b8bd in timerSourcePrepare (source=0xb0802640, timeout=0xb11ff11c) at kernel/qeventdispatcher_glib.cpp:176
#8  0xb550f9b3 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb55102df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb5510528 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#11 0xb738b95f in QEventDispatcherGlib::processEvents (this=0xb0805240, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#12 0xb735a823 in QEventLoop::processEvents (this=this@entry=0xb11ff288, flags=...) at kernel/qeventloop.cpp:149
#13 0xb735ab49 in QEventLoop::exec (this=this@entry=0xb11ff288, flags=...) at kernel/qeventloop.cpp:204
#14 0xb724723d in QThread::exec (this=this@entry=0x91459e0) at thread/qthread.cpp:537
#15 0xb724738b in QThread::run (this=0x91459e0) at thread/qthread.cpp:604
#16 0xb7249b6f in QThreadPrivate::start (arg=0x91459e0) at thread/qthread_unix.cpp:349
#17 0xb55fbf70 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#18 0xb578fbee in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb4b69740 (LWP 5877)):
[KCrash Handler]
#7  0xb6218764 in operator char const* (this=<optimized out>) at /usr/include/qt4/QtCore/qbytearray.h:425
#8  KIMAP::Session::selectedMailBox (this=0x9118388) at ../../kimap/session.cpp:449
#9  0x0808b052 in RetrieveItemsTask::startRetrievalTasks (this=this@entry=0x90e55b8) at ../../../resources/imap/retrieveitemstask.cpp:150
#10 0x0808b2d8 in RetrieveItemsTask::doStart (this=0x90e55b8, session=0x9118388) at ../../../resources/imap/retrieveitemstask.cpp:98
#11 0x0807ea1b in ResourceTask::onSessionRequested (this=this@entry=0x90e55b8, requestId=296, session=0x9118388, errorCode=0) at ../../../resources/imap/resourcetask.cpp:119
#12 0x080aab55 in ResourceTask::qt_static_metacall (_o=_o@entry=0x90e55b8, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfea08cc) at moc_resourcetask.cpp:69
#13 0xb73710f7 in QMetaObject::activate (sender=sender@entry=0x90b8838, m=m@entry=0x80c7de0 <SessionPool::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0xbfea08cc) at kernel/qobject.cpp:3539
#14 0x080aac0f in SessionPool::sessionRequestDone (this=this@entry=0x90b8838, _t1=296, _t2=_t2@entry=0x9118388, _t3=_t3@entry=0, _t4=...) at moc_sessionpool.cpp:153
#15 0x080968bc in SessionPool::processPendingRequests (this=this@entry=0x90b8838) at ../../../resources/imap/sessionpool.cpp:257
#16 0x080aad5c in SessionPool::qt_static_metacall (_o=0x90b8838, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x90e8460) at moc_sessionpool.cpp:92
#17 0xb736d8aa in QMetaCallEvent::placeMetaCall (this=0x902ce70, object=0x90b8838) at kernel/qobject.cpp:524
#18 0xb73756fb in QObject::event (this=0x90b8838, e=0x902ce70) at kernel/qobject.cpp:1194
#19 0xb68677f4 in QApplicationPrivate::notify_helper (this=0x8f89248, receiver=0x90b8838, e=0x902ce70) at kernel/qapplication.cpp:4567
#20 0xb686e2d3 in QApplication::notify (this=0xbfea0f94, receiver=receiver@entry=0x90b8838, e=e@entry=0x902ce70) at kernel/qapplication.cpp:4353
#21 0xb5e5d1b4 in KApplication::notify (this=0xbfea0f94, receiver=0x90b8838, event=0x902ce70) at ../../kdeui/kernel/kapplication.cpp:311
#22 0xb735be4a in QCoreApplication::notifyInternal (this=0xbfea0f94, receiver=receiver@entry=0x90b8838, event=event@entry=0x902ce70) at kernel/qcoreapplication.cpp:953
#23 0xb735f70d in sendEvent (event=0x902ce70, receiver=0x90b8838) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x8f59fd8) at kernel/qcoreapplication.cpp:1577
#25 0xb735fc1c in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#26 0xb738c23e in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#27 postEventSourceDispatch (s=0x8f866a0) at kernel/qeventdispatcher_glib.cpp:287
#28 0xb55101e3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#29 0xb5510468 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0xb5510528 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0xb738b93b in QEventDispatcherGlib::processEvents (this=this@entry=0x8f5ab70, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#32 0xb691c60e in QGuiEventDispatcherGlib::processEvents (this=0x8f5ab70, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0xb735a823 in QEventLoop::processEvents (this=this@entry=0xbfea0f08, flags=...) at kernel/qeventloop.cpp:149
#34 0xb735ab49 in QEventLoop::exec (this=this@entry=0xbfea0f08, flags=...) at kernel/qeventloop.cpp:204
#35 0xb73608fe in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#36 0xb6865a24 in QApplication::exec () at kernel/qapplication.cpp:3828
#37 0xb7631e28 in Akonadi::ResourceBase::init (r=r@entry=0x909b108) at ../../akonadi/resourcebase.cpp:579
#38 0x0805b4ed in Akonadi::ResourceBase::init<ImapResource> (argc=argc@entry=3, argv=argv@entry=0xbfea1074) at /usr/include/akonadi/resourcebase.h:193
#39 0x0805ac5b in main (argc=3, argv=0xbfea1074) at ../../../resources/imap/main.cpp:22

Possible duplicates by query: bug 340794.

Reported using DrKonqi
Comment 1 ralfgesellensetter 2017-06-11 08:52:24 UTC
If my Spanish is good enough, I am facing exactly the same problem:

Observed:
1. Download a folder from MS OneDrive as ZIP archive.
2. Try to open ZIP file with ARK

Expected Result:
Ark opens archive.

Observed Result: ARK says: not a valid archive.
(Testet with 5 different archives).

Workaround: Uncompress using "unzip" in console or using "mc".

Possibly, character encoding is the issue, here, as well. Any idea?
Comment 2 ralfgesellensetter 2017-06-11 08:53:32 UTC
ark version: 4:15.12.3
Comment 3 Christoph Feck 2017-06-19 12:21:23 UTC
This ticket is completely unrelated to Ark. Also, your version is outdated. If you can reproduce with a recent ark version, please report a new ticket.
Comment 4 Justin Zobel 2020-12-17 05:29:51 UTC
Thank you for the crash report.

As it has been a while since this was reported, can you please test and confirm if this issue is still occurring or if this bug report can be marked as resolved.

I have set the bug status to "needsinfo" pending your response, please change back to "reported" or "resolved/worksforme" when you respond, thank you.
Comment 5 Bug Janitor Service 2021-01-01 04:35:14 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 6 Bug Janitor Service 2021-01-16 04:34:29 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!