Bug 359180 - Crash - due to RSS feeds?
Summary: Crash - due to RSS feeds?
Status: RESOLVED DUPLICATE of bug 378513
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-02-09 11:00 UTC by bux23
Modified: 2017-05-07 12:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bux23 2016-02-09 11:00:12 UTC
Application: kontact (5.0.2)

Qt Version: 5.5.1
Operating System: Linux 4.4.0-2-generic i686
Distribution: Ubuntu Xenial Xerus (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

I was browsing my RSS feeds.

- Unusual behavior I noticed:

The RSS feed overview list showed that there are articles, but the article lists were empty.

- Custom settings of the application:

I added two RSS feeds to the two default feeds "Kubuntu" and KDE":
- http://www.heise.de/news-extern/news.html
- http://derstandard.at/?page=rss&ressort=seite1

The crash can be reproduced sometimes.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xad898840 (LWP 21826))]

Thread 8 (Thread 0xabf6fb40 (LWP 21828)):
#0  0xb7753c31 in __kernel_vsyscall ()
#1  0xb298a23c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb5fe2d26 in __pthread_cond_wait (cond=0xb5d78d54, mutex=0xb5d78d3c) at forward.c:149
#3  0xb50dd4ea in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#4  0xb50dd53c in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#5  0xb298518a in start_thread (arg=0xabf6fb40) at pthread_create.c:333
#6  0xb5fd600e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 7 (Thread 0xaafbdb40 (LWP 21829)):
#0  0xb7753c31 in __kernel_vsyscall ()
#1  0xb5fcb40b in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb26d1ac0 in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb26c306c in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb26c31a4 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb64f9764 in QEventDispatcherGlib::processEvents (this=0xaa600468, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#6  0xb649e2d3 in QEventLoop::processEvents (this=0xaafbd194, flags=...) at kernel/qeventloop.cpp:128
#7  0xb649e72a in QEventLoop::exec (this=0xaafbd194, flags=...) at kernel/qeventloop.cpp:204
#8  0xb62c3edd in QThread::exec (this=0x8392648) at thread/qthread.cpp:503
#9  0xb62c3fb8 in QThread::run (this=0x8392648) at thread/qthread.cpp:570
#10 0xb62c93fb in QThreadPrivate::start (arg=0x8392648) at thread/qthread_unix.cpp:331
#11 0xb298518a in start_thread (arg=0xaafbdb40) at pthread_create.c:333
#12 0xb5fd600e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 6 (Thread 0xaa49eb40 (LWP 21830)):
#0  0xb7753c31 in __kernel_vsyscall ()
#1  0xb298a23c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb5fe2d26 in __pthread_cond_wait (cond=0xab6b2138, mutex=0xab6b2120) at forward.c:149
#3  0xb510c0bc in WTF::ThreadCondition::wait(WTF::Mutex&) () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#4  0xb4dcad36 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#5  0xb50f46b2 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#6  0xb510bac1 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#7  0xb298518a in start_thread (arg=0xaa49eb40) at pthread_create.c:333
#8  0xb5fd600e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 5 (Thread 0xa9affb40 (LWP 21831)):
#0  0xb7753c31 in __kernel_vsyscall ()
#1  0xb298a23c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb5fe2d26 in __pthread_cond_wait (cond=0xab6b6734, mutex=0xab6b671c) at forward.c:149
#3  0xb510c0bc in WTF::ThreadCondition::wait(WTF::Mutex&) () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#4  0xb4dcbe65 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#5  0xb50f46b2 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#6  0xb510bac1 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#7  0xb298518a in start_thread (arg=0xa9affb40) at pthread_create.c:333
#8  0xb5fd600e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 4 (Thread 0xa92feb40 (LWP 21832)):
#0  0xb7753c31 in __kernel_vsyscall ()
#1  0xb298a23c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb5fe2d26 in __pthread_cond_wait (cond=0xab6b6734, mutex=0xab6b671c) at forward.c:149
#3  0xb510c0bc in WTF::ThreadCondition::wait(WTF::Mutex&) () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#4  0xb4dcbe65 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#5  0xb50f46b2 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#6  0xb510bac1 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#7  0xb298518a in start_thread (arg=0xa92feb40) at pthread_create.c:333
#8  0xb5fd600e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 3 (Thread 0xa8afdb40 (LWP 21833)):
#0  0xb7753c31 in __kernel_vsyscall ()
#1  0xb298a23c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb5fe2d26 in __pthread_cond_wait (cond=0xab6b6734, mutex=0xab6b671c) at forward.c:149
#3  0xb510c0bc in WTF::ThreadCondition::wait(WTF::Mutex&) () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#4  0xb4dcbe65 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#5  0xb50f46b2 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#6  0xb510bac1 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#7  0xb298518a in start_thread (arg=0xa8afdb40) at pthread_create.c:333
#8  0xb5fd600e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 2 (Thread 0x8f7b9b40 (LWP 24956)):
#0  0xb7753c31 in __kernel_vsyscall ()
#1  0xb298a606 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_timedwait.S:245
#2  0xb5fe2d6a in __pthread_cond_timedwait (cond=0x8a9a9f8, mutex=0x8a9a9e0, abstime=0x8f7b9138) at forward.c:162
#3  0xb62ca5ac in QWaitConditionPrivate::wait_relative (time=30000, this=0x8a9a9e0) at thread/qwaitcondition_unix.cpp:126
#4  QWaitConditionPrivate::wait (time=30000, this=0x8a9a9e0) at thread/qwaitcondition_unix.cpp:134
#5  QWaitCondition::wait (this=0x8a9a408, mutex=0x8a9d760, time=30000) at thread/qwaitcondition_unix.cpp:208
#6  0xb62c5d58 in QThreadPoolThread::run (this=0x8a9a400) at thread/qthreadpool.cpp:127
#7  0xb62c93fb in QThreadPrivate::start (arg=0x8a9a400) at thread/qthread_unix.cpp:331
#8  0xb298518a in start_thread (arg=0x8f7b9b40) at pthread_create.c:333
#9  0xb5fd600e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 1 (Thread 0xad898840 (LWP 21826)):
[KCrash Handler]
#7  0xb64a9297 in QMetaObject::cast(QObject*) const () at kernel/qmetaobject.cpp:312
#8  0xa5ddff3a in qobject_cast<Akregator::BrowserFrame*> (object=<optimized out>) at /usr/include/i386-linux-gnu/qt5/QtCore/qobject.h:520
#9  Akregator::FrameManager::saveProperties (this=0x8865860, config=...) at ../../../akregator/src/framemanager.cpp:397
#10 0xa5ea251f in Akregator::MainWidget::saveProperties (this=0x97f9a60, config=...) at ../../../akregator/src/mainwidget.cpp:1186
#11 0xa5e9a122 in Akregator::Part::saveProperties (this=0x9c616c0, config=...) at ../../../akregator/src/akregator_part.cpp:442
#12 0xa5e9b866 in Akregator::Part::saveCrashProperties (this=0x9c616c0) at ../../../akregator/src/akregator_part.cpp:825
#13 0xa5e9b8e5 in Akregator::Part::slotAutoSave (this=0x9c616c0) at ../../../akregator/src/akregator_part.cpp:862
#14 0xa5ebbb71 in Akregator::Part::qt_static_metacall (_o=0x9c616c0, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x88deed0) at moc_akregator_part.cpp:227
#15 0xb64cdf00 in QMetaCallEvent::placeMetaCall (this=0x9e8c680, object=0x9c616c0) at kernel/qobject.cpp:486
#16 0xb64d1d23 in QObject::event (this=0x9c616c0, e=0x9e8c680) at kernel/qobject.cpp:1239
#17 0xb6d850ea in QApplicationPrivate::notify_helper (this=0x82ad1a8, receiver=0x9c616c0, e=0x9e8c680) at kernel/qapplication.cpp:3716
#18 0xb6d8a780 in QApplication::notify (this=0xbfea7124, receiver=0x9c616c0, e=0x9e8c680) at kernel/qapplication.cpp:3499
#19 0xb64a11af in QCoreApplication::notifyInternal (this=0xbfea7124, receiver=0x9c616c0, event=0x9e8c680) at kernel/qcoreapplication.cpp:965
#20 0xb64a388d in QCoreApplication::sendEvent (event=0x9e8c680, receiver=<optimized out>) at kernel/qcoreapplication.h:224
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8295400) at kernel/qcoreapplication.cpp:1593
#22 0xb64a3d77 in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1451
#23 0xb64f9353 in postEventSourceDispatch (s=0x82d25d8) at kernel/qeventdispatcher_glib.cpp:271
#24 0xb26c2e39 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb26c30d9 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#26 0xb26c31a4 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#27 0xb64f9743 in QEventDispatcherGlib::processEvents (this=0x82d56f0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#28 0xad570931 in QPAEventDispatcherGlib::processEvents (this=0x82d56f0, flags=...) at eventdispatchers/qeventdispatcher_glib.cpp:115
#29 0xb649e2d3 in QEventLoop::processEvents (this=0xbfea6fe8, flags=...) at kernel/qeventloop.cpp:128
#30 0xb649e72a in QEventLoop::exec (this=0xbfea6fe8, flags=...) at kernel/qeventloop.cpp:204
#31 0xb64a6d15 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1229
#32 0xb67c6571 in QGuiApplication::exec () at kernel/qguiapplication.cpp:1530
#33 0xb6d80fb4 in QApplication::exec () at kernel/qapplication.cpp:2976
#34 0x0804bd22 in main (argc=1, argv=0xbfea7204) at ../../../kontact/src/main.cpp:220

Possible duplicates by query: bug 354804, bug 354495.

Reported using DrKonqi
Comment 1 Christoph Feck 2017-05-07 12:36:04 UTC

*** This bug has been marked as a duplicate of bug 378513 ***