Bug 358555 - kconsole's background is transparent on second screen
Summary: kconsole's background is transparent on second screen
Status: RESOLVED DUPLICATE of bug 356343
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-25 19:57 UTC by Terry Barnaby
Modified: 2016-01-30 11:43 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Terry Barnaby 2016-01-25 19:57:03 UTC
On a Fedora 23 system with kconsole 15.12.1. I have a conventional twin monitor setup with the desktop extending across both monitors.
If you try and start a kconsole application on the second monitor it starts with a transparent background and with no text content and is unusable.
If you start the kconsole of the main lefthand screen and drag it across to the second monitor it works fine.
After using the desktop for 10 mins or so, this fault is cleared and all works ok. No idea what causes the system to fix itself.
Tested on two systems with two different user configurations. One system using ATI graphics and the other using Intel graphics.
Not sure if this is a kconsole or a Plasma desktop issue.
Comment 1 Ian Pilcher 2016-01-27 00:14:27 UTC
I am also seeing this on Fedora 23, also with both AMD and Intel graphics.

One thing that I did notice is that the shell does appear to be running in the konsole, even though it isn't visible.  If one blindly starts an application (such as top) and then clicks on the close button, the "Confirm Close" dialog will pop up.

So this seems like it may be more of a rendering/compositing issue (but I'm not sure if that actually helps).
Comment 2 Wolfgang Bauer 2016-01-30 00:05:45 UTC
Sounds very much like Bug#357388.

Is the problem fixed when you turn off Compositing or run "QT_STYLE_OVERRIDE=Fusion konsole" instead?
Comment 3 Terry Barnaby 2016-01-30 09:00:47 UTC
Many thanks for the response.

Yes, turning the compositor off fixes the problem.
Also running "QT_STYLE_OVERRIDE=Fusion konsole" fixes the problem.

Error messages when kconsole fails include:
0x55f01f446ec0 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x55f01f1670c0) ): Attempt to set a screen on a child window.
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1637, resource id: 69206113, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1645, resource id: 69206113, major code: 130 (Unknown), minor code: 3

Yes, this sound exactly like Bug#357388.
Comment 4 Wolfgang Bauer 2016-01-30 11:43:20 UTC
(In reply to Terry Barnaby from comment #3)
> Yes, this sound exactly like Bug#357388.

Ok, let's mark it as duplicate then.

This was actually a problem in the breeze style and should be fixed in Plasma 5.5.4.

*** This bug has been marked as a duplicate of bug 356343 ***