Bug 357388 - Konsole on 2nd monitor shows only empty window-frame
Summary: Konsole on 2nd monitor shows only empty window-frame
Status: RESOLVED DUPLICATE of bug 356343
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR major with 47 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-01 13:40 UTC by slartibart70
Modified: 2016-01-25 10:25 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot 01 - Launching Konsole (591.40 KB, image/png)
2016-01-08 14:59 UTC, Laven Pillay
Details
Screenshot 02 - Moving window (548.11 KB, image/png)
2016-01-08 15:01 UTC, Laven Pillay
Details
Screenshot 03 - Resizing window (1.55 MB, image/png)
2016-01-08 15:04 UTC, Laven Pillay
Details
Screenshot 04 - Launch second instance of Konsole (1.33 MB, image/png)
2016-01-08 15:05 UTC, Laven Pillay
Details
1st konsole bad (contains background image), subsequent konsoles OK (228.75 KB, image/png)
2016-01-20 18:53 UTC, gene smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description slartibart70 2016-01-01 13:40:55 UTC
Two-monitor setup (laptop and 2nd hdmi screen)
I made the 2nd monitor the default screen (systemsettings - display&monitor - display config - primary monitor)
Right-Klicking on 1st screen and opening konsole from contextmenu opens a konsole window with the terminal inside.
Right-klicking on 2nd screen and opening konsole from contextmenu opens a konsole window without anything inside, just a copy of the background (which is then movable with the window). Opening a second konsole window on 2nd monitor is then ok and contains the terminal

Reproducible: Always
Comment 1 Julien HENRY 2016-01-05 09:26:34 UTC
I had exactly the same problem yesterday but since the update to plasma 5.5.1 I am no more able to reproduce.
Comment 2 slartibart70 2016-01-05 10:13:23 UTC
Well, i forgot to mention in the original bug report that i was testing on fedora repos5.5.1, so the bug is/was still there even with 5.5.1
Comment 3 Julien HENRY 2016-01-05 10:25:48 UTC
Then maybe the fact I'm not able to reproduce is due to some other changes I did that were only taken into account after a reboot. In compositor properties I changed to:
Rendering backend = OpenGL 2.0 (was XRender previously)
Tearing prevention "vsync" = Never (was auto)

Not sure it has any impact but maybe you can give a try.
Comment 4 maldun.finsterschreck 2016-01-07 07:37:06 UTC
Hi!
It appears that your bug is related to a similar problem I observed (I had an additional crash of konsole)
https://bugs.kde.org/show_bug.cgi?id=357331
Comment 5 Laven Pillay 2016-01-08 14:59:31 UTC
Created attachment 96527 [details]
Screenshot 01 - Launching Konsole
Comment 6 Laven Pillay 2016-01-08 15:01:36 UTC
Created attachment 96528 [details]
Screenshot 02 - Moving window
Comment 7 Laven Pillay 2016-01-08 15:04:40 UTC
Created attachment 96529 [details]
Screenshot 03 - Resizing window
Comment 8 Laven Pillay 2016-01-08 15:05:35 UTC
Created attachment 96530 [details]
Screenshot 04 - Launch second instance of Konsole
Comment 9 Laven Pillay 2016-01-08 15:09:26 UTC
Also experiencing the exact same thing : 
1. First Konsole window opened gets rendered with the desktop image at that location (2nd window works normally)
2. Moving the window retains that image and does not redraw
3. Attempting to launch from a terminal displays some errors - QT-related

System Information : 
Korora 23 (4.2.5-300.fc23.x86_64)
Plasma 5.5.1

Konsole version information :
(note the QCoreApplication message)
$ konsole -v
QCoreApplication::arguments: Please instantiate the QApplication object first
Qt: 5.5.1
KDE Frameworks: 5.18.0
Konsole: 15.08.3

Screenshot 1 : Launch Konsole - render issue occurs
Screenshot 2 : Move window - maintains content and does not redraw
Screenshot 3 : Resize window - maintains content and does not redraw 
Screenshot 4 : Launch second instance - works properly

When attempting to launch from a terminal, the following messages are shown, which seems to be the same as in this Bug :
https://bugs.kde.org/show_bug.cgi?id=357331

NOTE : I'm using the default Monospace font

------- from terminal ---------
The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
0x564cbd9456f0 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x564cbd588db0) ): Attempt to set a screen on a child window.
0x564cbd945c30 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x564cbd588db0) ): Attempt to set a screen on a child window.
0x564cbd946430 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x564cbd588db0) ): Attempt to set a screen on a child window.
0x564cbd94b590 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x564cbd588db0) ): Attempt to set a screen on a child window.
0x564cbd986900 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x564cbd588db0) ): Attempt to set a screen on a child window.
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1713, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1716, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1724, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1727, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1734, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1741, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1760, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1766, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1775, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1784, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1813, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1821, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1829, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1837, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1845, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1853, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1861, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1869, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1877, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1885, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1893, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1901, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1909, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1917, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1925, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1933, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1942, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1950, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1958, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1966, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1974, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1982, resource id: 88080487, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1990, resource id: 88080487, major code: 130 (Unknown), minor code: 3
Comment 10 Johannes Pfrang 2016-01-09 11:49:12 UTC
This could be a regression of bug 356343.
Comment 11 maldun.finsterschreck 2016-01-14 08:06:05 UTC
After disabling the Compositor, konsole opens normally.
Comment 12 gene smith 2016-01-20 18:53:57 UTC
Created attachment 96756 [details]
1st konsole bad (contains background image), subsequent konsoles OK

Just noticed this happening recently. Only on secondary monitor, 1st konsole instance is bad and then subsequent konsole instances are OK. But no problems with konsole if 1st instance appears on the "primary" monitor (monitor containing the panel at the bottom).
Just an additional confirmation of the bug.
Comment 13 Cristiano da Cunha Duarte 2016-01-20 19:40:34 UTC
(In reply to maldun.finsterschreck from comment #11)
> After disabling the Compositor, konsole opens normally.

Same behaviour here with FC23 KDE 5. With Compositor disabled (Shift+Alt+F12), konsole opens normally on the second monitor.
Comment 14 Thomas Lübking 2016-01-22 21:51:39 UTC
bug #356343 ?(!)

run "pkill konsole; sleep 1; QT_STYLE_OVERRIDE=Fusion konsole" and see whether the problem exists with the fusion style. If not, it's a dupe.
Comment 15 Julien HENRY 2016-01-25 08:13:18 UTC
(In reply to Thomas Lübking from comment #14)
> bug #356343 ?(!)
> 
> run "pkill konsole; sleep 1; QT_STYLE_OVERRIDE=Fusion konsole" and see
> whether the problem exists with the fusion style. If not, it's a dupe.

I confirm I don't have the issue when using this command
Comment 16 Yaroslav Sidlovsky 2016-01-25 09:08:52 UTC
Solution with "QT_STYLE_OVERRIDE=Fusion konsole" works for me too.
Comment 17 Thomas Lübking 2016-01-25 10:25:07 UTC

*** This bug has been marked as a duplicate of bug 356343 ***