Bug 357670 - KMail 16.04.1: Composer auto-completion fails on first try
Summary: KMail 16.04.1: Composer auto-completion fails on first try
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: composer (show other bugs)
Version: 5.1.3
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 356431 359057 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-07 20:22 UTC by Till Schäfer
Modified: 2016-08-31 17:09 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Till Schäfer 2016-01-07 20:22:12 UTC
Whenever i compose a message and type in a name/email, etc in the to-field, the auto-completion does not pop up. Only if I type something, then delete the text again and start typing again, the auto-completion pops up. 

This bug was introduces in the KF5 version (I am also quite sure i have not observed it in 18.08., but it is definitely different in the KDE4 version)-

Reproducible: Always
Comment 1 Laurent Montel 2016-01-07 20:32:32 UTC
I confirm it (I saw it from some weeks/months)
I couldn't success to understand why it doesn't work.
I continue to investigate
Comment 2 Simone 2016-01-08 16:41:44 UTC
I confirm it too. I'm on ArchLinux.
Comment 3 Milian Wolff 2016-02-03 10:31:55 UTC
Confirmed from me as well. Note that the "Reply To" field works fine apparently.
Comment 4 Laurent Montel 2016-03-07 06:12:30 UTC
in qt5.6 it works fine now.
Comment 5 Till Schäfer 2016-04-12 11:42:03 UTC
i cannot confirm that qt 5.6 fixes the bug. I have just upgraded qt on my gentoo box an the bug still appears.

software stack: 
- qt 5.6.0
- plasma 5.6.2
- kde-frameworks 5.21
- kdepim 5.12.3
Comment 6 Till Schäfer 2016-04-28 19:00:39 UTC
checked and verified, that the bug still exists in 16.04.0
Comment 7 Andreas Sturmlechner 2016-05-02 18:41:59 UTC
Also happens for me in Applications 16.04.0 / Qt 5.5.1. The interesting bit: No matter how often I retry to type in the name, via select+overwrite, it does not work. If I use backspace to remove all but the first character, then type again, it does not work. Only if I use backspace to get back to 'position 0' does it then spawn the auto-completion popup as I begin to type again.
Comment 8 Andreas Sturmlechner 2016-06-12 15:25:41 UTC
Upgraded to Qt-5.6.1 and the issue is still present. I made another observation though:

- Indeed "To:" field works fine
- "CC:" does show same behaviour as described in my above comment
- However "CC:" works fine if _at first_ you were using "To:", which is often not happening when you reply to someone and put people into CC.
Comment 9 Till Schäfer 2016-06-13 10:23:19 UTC
(In reply to andreas.sturmlechner from comment #8)
> Upgraded to Qt-5.6.1 and the issue is still present. I made another
> observation though:
> 
> - Indeed "To:" field works fine
> - "CC:" does show same behaviour as described in my above comment
> - However "CC:" works fine if _at first_ you were using "To:", which is
> often not happening when you reply to someone and put people into CC.

I am also on qt 5.6.1, but i am still facing the problem, regardless of the field type (to, cc). However, i have also notices some very rare (looks random to me) cases, where the completion did work. 

Frameworks: 5.22
kde-apps 16.04.1
plasma 5.6.4
Comment 10 Andreas Sturmlechner 2016-08-05 21:41:28 UTC
Good news from my system at least - since upgrading to 16.07.80 I could not see the problem anymore.
Comment 11 Till Schäfer 2016-08-06 20:28:17 UTC
(In reply to andreas.sturmlechner from comment #10)
> Good news from my system at least - since upgrading to 16.07.80 I could not
> see the problem anymore.

woohoo. same here, 16.07.80 fixed it for me.. 

@kdepim-team: did you change anything intentionally or are we hit by luck that some "race condition" does not occur anymore?
Comment 12 Allen Winter 2016-08-11 12:51:54 UTC
*** Bug 359057 has been marked as a duplicate of this bug. ***
Comment 13 Andreas Sturmlechner 2016-08-31 17:04:53 UTC
*** Bug 356431 has been marked as a duplicate of this bug. ***
Comment 14 Andreas Sturmlechner 2016-08-31 17:09:28 UTC
Closing as fixed in kmail 5.3.0 (KDE Applications 16.08.0).