Bug 357069 - KMail5 Crashes on exit
Summary: KMail5 Crashes on exit
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: misc (show other bugs)
Version: 5.1
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi, triaged
Depends on:
Blocks:
 
Reported: 2015-12-22 21:07 UTC by Angelos Skembris
Modified: 2018-10-28 03:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Angelos Skembris 2015-12-22 21:07:44 UTC
Application: kmail (5.1)

Qt Version: 5.5.0
Operating System: Linux 4.1.13-5-default x86_64
Distribution: "openSUSE Leap 42.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Closed KMail5's window, right clicked on tray icon, clicked quit.

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa66a08d800 (LWP 4390))]

Thread 14 (Thread 0x7fa645816700 (LWP 4397)):
#0  0x00007fa6670a6c1d in poll () at /lib64/libc.so.6
#1  0x00007fa65a574422 in  () at /usr/lib64/libxcb.so.1
#2  0x00007fa65a57600f in xcb_wait_for_event () at /usr/lib64/libxcb.so.1
#3  0x00007fa647540c29 in  () at /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007fa6679b455f in  () at /usr/lib64/libQt5Core.so.5
#5  0x00007fa65d84c0a4 in start_thread () at /lib64/libpthread.so.0
#6  0x00007fa6670af04d in clone () at /lib64/libc.so.6

Thread 13 (Thread 0x7fa63f5ef700 (LWP 4402)):
#0  0x00007fa6670a6c1d in poll () at /lib64/libc.so.6
#1  0x00007fa65d32fe64 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fa65d32ff7c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fa667be5a5b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007fa667b8ca63 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007fa6679af84a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007fa6679b455f in  () at /usr/lib64/libQt5Core.so.5
#7  0x00007fa65d84c0a4 in start_thread () at /lib64/libpthread.so.0
#8  0x00007fa6670af04d in clone () at /lib64/libc.so.6

Thread 12 (Thread 0x7fa62d561700 (LWP 4431)):
#0  0x00007fa65d85005f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fa6583cb4a3 in  () at /usr/lib64/libQt5WebKit.so.5
#2  0x00007fa6583cb4c9 in  () at /usr/lib64/libQt5WebKit.so.5
#3  0x00007fa65d84c0a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007fa6670af04d in clone () at /lib64/libc.so.6

Thread 11 (Thread 0x7fa5e57a0700 (LWP 4434)):
#0  0x00007fa65d85005f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fa5ec228ff3 in  () at /usr/lib64/dri/r600_dri.so
#2  0x00007fa5ec228777 in  () at /usr/lib64/dri/r600_dri.so
#3  0x00007fa65d84c0a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007fa6670af04d in clone () at /lib64/libc.so.6

Thread 10 (Thread 0x7fa5e1e0c700 (LWP 4440)):
#0  0x00007fa65d85005f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fa6580d74cd in  () at /usr/lib64/libQt5WebKit.so.5
#2  0x00007fa6583f9da1 in  () at /usr/lib64/libQt5WebKit.so.5
#3  0x00007fa65d84c0a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007fa6670af04d in clone () at /lib64/libc.so.6

Thread 9 (Thread 0x7fa5e160b700 (LWP 4441)):
#0  0x00007fa65d85005f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fa6580d84a3 in  () at /usr/lib64/libQt5WebKit.so.5
#2  0x00007fa6583f9da1 in  () at /usr/lib64/libQt5WebKit.so.5
#3  0x00007fa65d84c0a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007fa6670af04d in clone () at /lib64/libc.so.6

Thread 8 (Thread 0x7fa5e0e0a700 (LWP 4442)):
#0  0x00007fa65d85005f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fa6580d84a3 in  () at /usr/lib64/libQt5WebKit.so.5
#2  0x00007fa6583f9da1 in  () at /usr/lib64/libQt5WebKit.so.5
#3  0x00007fa65d84c0a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007fa6670af04d in clone () at /lib64/libc.so.6

Thread 7 (Thread 0x7fa5dbfff700 (LWP 4443)):
#0  0x00007fa65d85005f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fa6580d84a3 in  () at /usr/lib64/libQt5WebKit.so.5
#2  0x00007fa6583f9da1 in  () at /usr/lib64/libQt5WebKit.so.5
#3  0x00007fa65d84c0a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007fa6670af04d in clone () at /lib64/libc.so.6

Thread 6 (Thread 0x7fa5db7fe700 (LWP 4444)):
#0  0x00007fa65d85005f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fa6580d84a3 in  () at /usr/lib64/libQt5WebKit.so.5
#2  0x00007fa6583f9da1 in  () at /usr/lib64/libQt5WebKit.so.5
#3  0x00007fa65d84c0a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007fa6670af04d in clone () at /lib64/libc.so.6

Thread 5 (Thread 0x7fa5daffd700 (LWP 4445)):
#0  0x00007fa65d85005f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fa6580d84a3 in  () at /usr/lib64/libQt5WebKit.so.5
#2  0x00007fa6583f9da1 in  () at /usr/lib64/libQt5WebKit.so.5
#3  0x00007fa65d84c0a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007fa6670af04d in clone () at /lib64/libc.so.6

Thread 4 (Thread 0x7fa5b1ffb700 (LWP 4697)):
#0  0x00007fa6670a6c1d in poll () at /lib64/libc.so.6
#1  0x00007fa65d32fe64 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fa65d32ff7c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fa667be5a5b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007fa667b8ca63 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007fa6679af84a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007fa6679b455f in  () at /usr/lib64/libQt5Core.so.5
#7  0x00007fa65d84c0a4 in start_thread () at /lib64/libpthread.so.0
#8  0x00007fa6670af04d in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7fa5b1538700 (LWP 4718)):
#0  0x00007fa6679adb8a in QMutex::lock() () at /usr/lib64/libQt5Core.so.5
#1  0x00007fa667be5985 in  () at /usr/lib64/libQt5Core.so.5
#2  0x00007fa65d32f4ad in g_main_context_prepare () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fa65d32fd80 in  () at /usr/lib64/libglib-2.0.so.0
#4  0x00007fa65d32ff7c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#5  0x00007fa667be5a5b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#6  0x00007fa667b8ca63 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#7  0x00007fa6679af84a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#8  0x00007fa6679b455f in  () at /usr/lib64/libQt5Core.so.5
#9  0x00007fa65d84c0a4 in start_thread () at /lib64/libpthread.so.0
#10 0x00007fa6670af04d in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7fa59bfff700 (LWP 4779)):
#0  0x00007fa6670a6c1d in poll () at /lib64/libc.so.6
#1  0x00007fa65d32fe64 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fa65d32ff7c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fa667be5a5b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#4  0x00007fa667b8ca63 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007fa6679af84a in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#6  0x00007fa6679b455f in  () at /usr/lib64/libQt5Core.so.5
#7  0x00007fa65d84c0a4 in start_thread () at /lib64/libpthread.so.0
#8  0x00007fa6670af04d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7fa66a08d800 (LWP 4390)):
[KCrash Handler]
#6  0x00007fa66151fb96 in  () at /usr/lib64/libKF5AkonadiCore.so.5
#7  0x00007fa667bbe40f in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib64/libQt5Core.so.5
#8  0x00007fa667b94631 in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
#9  0x0000000000404520 in main ()

Reported using DrKonqi
Comment 1 Denis Kurz 2017-04-11 18:18:11 UTC
Thanks for your report. Have you ever had this kind of crash in more recent versions? I think quite some crash-on-exit problems have been fixed in the past 1,5 years.

If this still happens to you, would you please state your version number and provide a more recent backtrace with debug packages installed? In the backtrace below, debug symbols for Akonadi seem to be missing.

Probably a duplicate of Bug 357030.
Comment 2 Andrew Crouthamel 2018-09-28 02:42:54 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Andrew Crouthamel 2018-10-28 03:41:14 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!