Bug 357030 - Close button crashes kmail
Summary: Close button crashes kmail
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.1
Platform: Slackware Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi, triaged
Depends on:
Blocks:
 
Reported: 2015-12-22 07:46 UTC by Ar Ivci
Modified: 2018-10-28 03:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ar Ivci 2015-12-22 07:46:27 UTC
Application: kmail (5.1)

Qt Version: 5.5.1
Operating System: Linux 4.1.15 x86_64
Distribution (Platform): Slackware Packages

-- Information about the crash:
- What I was doing when the application crashed:
 
I simply click the close button. Kmail crashed with "Executable: kmail PID: 3008 Signal: Segmentation fault (11) Time: 12/22/15 09:43:04"

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fcedb48e800 (LWP 3008))]

Thread 4 (Thread 0x7fceb4cb3700 (LWP 3010)):
#0  0x00007fced402f03d in read () at /lib64/libc.so.6
#1  0x00007fcec87905d0 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fcec874e484 in g_main_context_check () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fcec874e8f8 in  () at /usr/lib64/libglib-2.0.so.0
#4  0x00007fcec874ea5c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#5  0x00007fced4e59c9b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#6  0x00007fced4e03fda in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#7  0x00007fced4c3116c in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#8  0x00007fced4c35f6f in  () at /usr/lib64/libQt5Core.so.5
#9  0x00007fced0d0d704 in start_thread () at /lib64/libpthread.so.0
#10 0x00007fced403ef8d in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7fce8f7c6700 (LWP 3028)):
#0  0x00007fcec87917e9 in g_mutex_lock () at /usr/lib64/libglib-2.0.so.0
#1  0x00007fcec874df89 in g_main_context_prepare () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fcec874e883 in  () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fcec874ea5c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#4  0x00007fced4e59c9b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007fced4e03fda in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#6  0x00007fced4c3116c in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#7  0x00007fced4c35f6f in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007fced0d0d704 in start_thread () at /lib64/libpthread.so.0
#9  0x00007fced403ef8d in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7fce8ebc1700 (LWP 3033)):
#0  0x00007fcec874bb37 in  () at /usr/lib64/libglib-2.0.so.0
#1  0x00007fcec874df1b in g_main_context_prepare () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fcec874e883 in  () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fcec874ea5c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#4  0x00007fced4e59c9b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007fced4e03fda in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#6  0x00007fced4c3116c in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#7  0x00007fced4c35f6f in  () at /usr/lib64/libQt5Core.so.5
#8  0x00007fced0d0d704 in start_thread () at /lib64/libpthread.so.0
#9  0x00007fced403ef8d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7fcedb48e800 (LWP 3008)):
[KCrash Handler]
#6  0x0000000000000018 in  ()
#7  0x00007fced9a3d42c in  () at /usr/lib64/libKF5AkonadiCore.so.5
#8  0x00007fced4e330a7 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib64/libQt5Core.so.5
#9  0x00007fced4e0bbcb in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
#10 0x00000000004044a8 in main ()

Reported using DrKonqi
Comment 1 Denis Kurz 2017-04-11 18:14:32 UTC
Thanks for your report. Have you ever had this kind of crash in more recent versions? I think quite some crash-on-exit problems have been fixed in the past 1,5 years.

If this still happens to you, would you please provide a more recent backtrace with debug packages installed? In the backtrace below, debug symbols for Akonadi seem to be missing.
Comment 2 Andrew Crouthamel 2018-09-28 02:43:53 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Andrew Crouthamel 2018-10-28 03:40:32 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!