Bug 357063 - New konsole uses desktop for background; echoing command input/out NOT displaying
Summary: New konsole uses desktop for background; echoing command input/out NOT displa...
Status: RESOLVED DUPLICATE of bug 356343
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 15.08.3
Platform: Fedora RPMs Linux
: NOR grave with 40 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-22 19:13 UTC by George R. Goffe
Modified: 2016-01-28 11:46 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description George R. Goffe 2015-12-22 19:13:43 UTC
I finally got around to rebooting after installing updates. This system is now
up to date according to DNF. Konsoles started via saved session display the KDE
startup screen and then freeze. They do seem to respond to ctrl-d and commands
seem to run but the normal echo of command output is missing. Konsoles started
via the desktop menu seem to just display the desktop background or parts of
this bug report screen as a background. Same behavior though. ctrl-d exits.

This bug also exists on bugzilla.redhat.com and is marked urgent, bug id: 1293236


Reproducible: Always

Steps to Reproduce:
1.problem applies to konsoles started from saved session or CLI type in "konsole"
2.
3.

Actual Results:  
konsole displays desktop image or image from where the mouse is located. echo of command input/output does not ever appear. konsole does appear to respond to commands though NO output is displayed.
Comment 1 PhillB 2015-12-23 03:07:34 UTC
Same here.

One exception, however. Konsole runs just fine on the second screen. This only happens on the primary screen.
Comment 2 George R. Goffe 2015-12-23 08:07:18 UTC
I'm thinking that there is something not right with dual screen support. I have a laptop screen as screen 1, screen 2 is a 27" Samsung. some commands (xv, mplayer, Konsole edit settings) started in screen 2 display in screen 1 even though screen 2 is set to primary.

As for the Konsole problem, it starts just right on the lhs screen. moving "Konsole term" to the rhs screen remains fully functional.

I hope some of this helps. Fedora 22 x86_64
Comment 3 Trevin Fitz 2015-12-29 11:24:46 UTC
Same problem here.
1. When I open Konsole through "konsole" command in Yakuake and it puts it on my laptop screen - all works fine then.
2. When I open it on my second or third monitor it just catches "screenshot" of whatever is on the screen and keeps displaying it no matter how I move it, or whatever I type to it. It seems to be active though, because typing "exit" or ctrl+d works.
3. Opening through krunner or start menus defaults its location to second monitor, so it is always broken like this.
Comment 4 Trevin Fitz 2016-01-04 10:22:04 UTC
Behavior just changed for me after rearranging screens.
What I described in previous comments is valid when my screens are arranged in order: [laptop|fullHD|fullHD]. Konsole was working fine when opened on laptop screen and froze when opened on one of HD screens.

Now I have arranged them as [fullHD|fullHD|laptop]. Konsole works fine under both HD screens and freezes under laptop screen.

I double checked it and this behavior is repeatable.

When it opens correctly there is only one line in stderr:
"The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly."

When it "catches screenshot" there is more:

0x5580dd0af360 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x5580dcd65070) ): Attempt to set a screen on a child window.
0x5580dd109a30 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x5580dcd65070) ): Attempt to set a screen on a child window.
0x5580dd108ff0 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x5580dcd65070) ): Attempt to set a screen on a child window.
0x5580dd10b930 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x5580dcd65070) ): Attempt to set a screen on a child window.
0x5580dd10bf70 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x5580dcd65070) ): Attempt to set a screen on a child window.
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1939, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1942, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1950, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1953, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1960, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1967, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1975, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1983, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1991, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1999, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 2002, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 2010, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 2056, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 2059, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 2070, resource id: 102760569, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 2073, resource id: 102760569, major code: 130 (Unknown), minor code: 3
Comment 5 Michael 2016-01-06 06:50:34 UTC
Same problem here. Started this morning.
When I open konsole through the menu or when opening it on the second screen from XTerm it opens with the background, and its not possible to change anything, If opening on my primary screen, it opens correctly.

The output when opening the console from XTerm:

[mih@localhost ~]$ konsole
QCoreApplication::arguments: Please instantiate the QApplication object first
[mih@localhost ~]$ The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
0x29633a0 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x1db3800) ): Attempt to set a screen on a child window.
0x2963940 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x1db3800) ): Attempt to set a screen on a child window.
0x2964630 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x1db3800) ): Attempt to set a screen on a child window.
0x29d6220 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x1db3800) ): Attempt to set a screen on a child window.
0x29c8d50 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x1db3800) ): Attempt to set a screen on a child window.
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1700, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1703, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1711, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1714, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1721, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1728, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1736, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1742, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1751, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1758, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1765, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1774, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1777, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1792, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1810, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1828, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1836, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1844, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1852, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1860, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1868, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1876, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1884, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1892, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1900, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1908, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1916, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1925, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1933, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1941, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1949, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1957, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1965, resource id: 8388711, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1973, resource id: 8388711, major code: 130 (Unknown), minor code: 3
Comment 6 Johannes Pfrang 2016-01-09 11:47:57 UTC
Duplicate of bug 357388
Comment 7 Rex Dieter 2016-01-28 11:46:31 UTC

*** This bug has been marked as a duplicate of bug 356343 ***