Bug 357061 - Kmail5 crashes on shutdown
Summary: Kmail5 crashes on shutdown
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.1
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-12-22 18:07 UTC by wodenhof
Modified: 2017-04-18 20:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wodenhof 2015-12-22 18:07:22 UTC
Application: kmail (5.1)

Qt Version: 5.5.0
Operating System: Linux 4.1.13-5-default x86_64
Distribution: "openSUSE Leap 42.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I clicked on the "X" in the upper right corner or used <ctrl> + q.

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0c8392c800 (LWP 12949))]

Thread 13 (Thread 0x7f0c5f125700 (LWP 12950)):
#0  0x00007f0c80956c1d in poll () from /lib64/libc.so.6
#1  0x00007f0c73e2f422 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f0c73e3100f in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f0c60e4fc29 in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f0c8126455f in ?? () from /usr/lib64/libQt5Core.so.5
#5  0x00007f0c771060a4 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f0c8095f04d in clone () from /lib64/libc.so.6

Thread 12 (Thread 0x7f0c5cfee700 (LWP 12951)):
#0  0x00007f0c80952ced in read () from /lib64/libc.so.6
#1  0x00007f0c76c2ab60 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f0c76be9999 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f0c76be9df8 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f0c76be9f7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f0c81495a5b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#6  0x00007f0c8143ca63 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#7  0x00007f0c8125f84a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#8  0x00007f0c8126455f in ?? () from /usr/lib64/libQt5Core.so.5
#9  0x00007f0c771060a4 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f0c8095f04d in clone () from /lib64/libc.so.6

Thread 11 (Thread 0x7f0c40f6e700 (LWP 12967)):
#0  0x00007f0c7710a05f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0c71c864a3 in ?? () from /usr/lib64/libQt5WebKit.so.5
#2  0x00007f0c71c864c9 in ?? () from /usr/lib64/libQt5WebKit.so.5
#3  0x00007f0c771060a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f0c8095f04d in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7f0becf8d700 (LWP 12968)):
#0  0x00007f0c7710a05f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0c379f9ff3 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007f0c379f9777 in ?? () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007f0c771060a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f0c8095f04d in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f0bdbdf8700 (LWP 12978)):
#0  0x00007f0c7710a05f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0c719924cd in ?? () from /usr/lib64/libQt5WebKit.so.5
#2  0x00007f0c71cb4da1 in ?? () from /usr/lib64/libQt5WebKit.so.5
#3  0x00007f0c771060a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f0c8095f04d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f0bdb5f7700 (LWP 12979)):
#0  0x00007f0c7710a05f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0c719934a3 in ?? () from /usr/lib64/libQt5WebKit.so.5
#2  0x00007f0c71cb4da1 in ?? () from /usr/lib64/libQt5WebKit.so.5
#3  0x00007f0c771060a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f0c8095f04d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f0bdadf6700 (LWP 12980)):
#0  0x00007f0c7710a05f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0c719934a3 in ?? () from /usr/lib64/libQt5WebKit.so.5
#2  0x00007f0c71cb4da1 in ?? () from /usr/lib64/libQt5WebKit.so.5
#3  0x00007f0c771060a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f0c8095f04d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f0bda5f5700 (LWP 12981)):
#0  0x00007f0c7710a05f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0c719934a3 in ?? () from /usr/lib64/libQt5WebKit.so.5
#2  0x00007f0c71cb4da1 in ?? () from /usr/lib64/libQt5WebKit.so.5
#3  0x00007f0c771060a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f0c8095f04d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f0bd9df4700 (LWP 12982)):
#0  0x00007f0c7710a05f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0c719934a3 in ?? () from /usr/lib64/libQt5WebKit.so.5
#2  0x00007f0c71cb4da1 in ?? () from /usr/lib64/libQt5WebKit.so.5
#3  0x00007f0c771060a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f0c8095f04d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f0bd95f3700 (LWP 12983)):
#0  0x00007f0c7710a05f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0c719934a3 in ?? () from /usr/lib64/libQt5WebKit.so.5
#2  0x00007f0c71cb4da1 in ?? () from /usr/lib64/libQt5WebKit.so.5
#3  0x00007f0c771060a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f0c8095f04d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f0bbbfff700 (LWP 12988)):
#0  0x00007f0c76c2bcf5 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f0c76be96a1 in g_main_context_query () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f0c76be9dcf in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f0c76be9f7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f0c81495a5b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007f0c8143ca63 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#6  0x00007f0c8125f84a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#7  0x00007f0c8126455f in ?? () from /usr/lib64/libQt5Core.so.5
#8  0x00007f0c771060a4 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f0c8095f04d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f0bbafdf700 (LWP 12991)):
#0  0x00007f0c80952ced in read () from /lib64/libc.so.6
#1  0x00007f0c76c2ab60 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f0c76be9999 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f0c76be9df8 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f0c76be9f7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f0c81495a5b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#6  0x00007f0c8143ca63 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#7  0x00007f0c8125f84a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#8  0x00007f0c8126455f in ?? () from /usr/lib64/libQt5Core.so.5
#9  0x00007f0c771060a4 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f0c8095f04d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f0c8392c800 (LWP 12949)):
[KCrash Handler]
#6  0x0000000000000018 in ?? ()
#7  0x00007f0c7add1b9c in operator() (__closure=<synthetic pointer>) at /usr/src/debug/kdepimlibs-15.12.0/akonadi/src/core/session.cpp:306
#8  call (arg=<optimized out>, f=...) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:495
#9  call<QtPrivate::List<>, void> (arg=<optimized out>, f=...) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:552
#10 QtPrivate::QFunctorSlotObject<Akonadi::SessionPrivate::SessionPrivate(Akonadi::Session*)::__lambda22, 0, QtPrivate::List<>, void>::impl(int, QtPrivate::QSlotObjectBase *, QObject *, void **, bool *) (which=<optimized out>, this_=<optimized out>, r=<optimized out>, a=<optimized out>, ret=<optimized out>) at /usr/include/qt5/QtCore/qobject_impl.h:192
#11 0x00007f0c8146e40f in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQt5Core.so.5
#12 0x00007f0c81444631 in QCoreApplication::exec() () from /usr/lib64/libQt5Core.so.5
#13 0x0000000000404520 in main (argc=1, argv=0x7fffe5c7f4b8) at /usr/src/debug/kdepim-15.12.0/kmail/main.cpp:151

Possible duplicates by query: bug 351165, bug 350237, bug 349953.

Reported using DrKonqi
Comment 1 wodenhof 2016-01-10 16:12:10 UTC
There seems to have been an update. Now I get the kwallet popup when I log in to KDE (whatever for). When I start kmail the normal screen appears and on top of it is the popup telling about kamil crashing etc.
Sending the crash-information is not possible. I stored the report on the disk but I don't see how to upload it here... Ah, I just tried againto send it, maybe it worked, I didn't get any messages about success though and I wasn't asked for my description of the problem.

When I close the popup kmail works. Quitting kmail and re-starting it starts the same cycle of events.
Comment 2 wodenhof 2016-01-13 17:24:16 UTC
(In reply to wodenhof from comment #1)
> There seems to have been an update. Now I get the kwallet popup when I log
> in to KDE (whatever for). 

I'll try to clarify. Kwallet is called by kmail -- which is not started yet (at least not by me). This is what is running right after boot with no further action of me:

matthias@linux-1vgm:~> ps aux | grep mail
matthias  1991  0.3  0.5 1078328 68496 ?       Sl   17:59   0:00 /usr/bin/kmail -session 1014b1039feb000145262478300000019020014_1452626860_756855
matthias  2197  0.1  0.4 1048692 60764 ?       Sl   18:00   0:00 /usr/bin/akonadi_archivemail_agent --identifier akonadi_archivemail_agent
matthias  2258  0.1  0.3 603980 40868 ?        Sl   18:00   0:00 /usr/bin/akonadi_maildir_resource --identifier akonadi_maildir_resource_1
matthias  2262  0.1  0.3 603284 37432 ?        Sl   18:00   0:00 /usr/bin/akonadi_maildir_resource --identifier akonadi_maildir_resource_2
matthias  2263  0.1  0.3 833852 38540 ?        Sl   18:00   0:00 /usr/bin/akonadi_maildispatcher_agent --identifier akonadi_maildispatcher_agent
matthias  2279  0.1  0.5 1185760 65832 ?       Sl   18:00   0:00 /usr/bin/akonadi_mailfilter_agent --identifier akonadi_mailfilter_agent
matthias  2296  0.1  0.3 686664 41188 ?        Sl   18:00   0:00 /usr/bin/akonadi_newmailnotifier_agent --identifier akonadi_newmailnotifier_agent
matthias  2715  0.0  0.0  10524  1572 pts/0    S+   18:02   0:00 grep --color=auto mail
matthias@linux-1vgm:~> 

HTH.
Comment 3 Denis Kurz 2017-04-11 18:30:36 UTC
Thanks for your report. The problems you describe are probably unrelated: KWallet is summoned by Akonadi, which is started automatically at login in the background. Have you ever had this kind of crash in more recent versions? I think quite some crash-on-exit problems have been fixed in the past 1,5 years.

If this still happens to you, would you please state your version number and provide a more recent backtrace with debug packages installed? Ideally, you'd just paste the backtrace to the end of your comment. There's also the "Add an attachment" link above the Comment box, but backtraces as attachments only make it harder to search them.

Probably a duplicate of Bug 357030.
Comment 4 wodenhof 2017-04-12 17:08:23 UTC
Well, as you say this error report is nearly 1 1/2 years old. I'm on tumbleweed now, with kmail 5.4.3 and no problems of this sort -- no idea whether Leap is still plagued by this, sorry.
Comment 5 Denis Kurz 2017-04-18 20:17:04 UTC
Ok, since noone else seems to be interested in this bug, I close it as WORKSFORME. Thanks for your report and feedback.