Bug 356305 - Ascending/Descending sort arrow reversed
Summary: Ascending/Descending sort arrow reversed
Status: RESOLVED FIXED
Alias: None
Product: Breeze
Classification: Plasma
Component: QStyle (show other bugs)
Version: 5.4.3
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-05 11:16 UTC by Unknown
Modified: 2015-12-06 03:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2015-12-05 11:16:26 UTC
It seems to me the arrow of the sorting interface should be the other way. It is pointing downward when things are sorted in ascending order.

Reproducible: Always

Steps to Reproduce:
1. Open Dolphin (or another app with sorting capabilities)
2. Sort files ascending
3. The arrow of the interface is pointing down

(and vice versa)

Actual Results:  
The arrow of the interface is pointing in the other direction, counter intuitive

Expected Results:  
Correct direction

Not sure if this is mean to work this way. Just noticed it a few times and decided to write.
Comment 1 Christoph Feck 2015-12-05 14:45:06 UTC

*** This bug has been marked as a duplicate of bug 297807 ***
Comment 2 Christoph Feck 2015-12-05 14:51:44 UTC
See also bug 349608.
Comment 3 Hugo Pereira Da Costa 2015-12-05 15:50:05 UTC
Re-oppening/reassigning.
Thing is, I have not ported the infamous option to breeze.
Also maybe we should move it upstream to kstyle 
(mmm but then that would break oxygen installation).
Comment 4 Hugo Pereira Da Costa 2015-12-05 17:10:26 UTC
Git commit c327915a8d864501ff0c7f701693225d457a8369 by Hugo Pereira Da Costa.
Committed on 05/12/2015 at 17:09.
Pushed by hpereiradacosta into branch 'master'.

added ViewInvertSortIndicator hidden option (to be added to $HOME/.config5/breezerc) in order to changed sort
order arrow orientation.
(copied from oxygen)

M  +4    -0    kstyle/breeze.kcfg
M  +3    -0    kstyle/breezestyle.cpp

http://commits.kde.org/breeze/c327915a8d864501ff0c7f701693225d457a8369
Comment 5 Christoph Feck 2015-12-06 03:18:18 UTC
Oh sorry, I had falsely assumed that Breeze was built on Oxygen code, and had the option already implemented.