Bug 354400 - In Kmail 5.0.2 autocompletion only shows recent email addresses but not stored emails in Kaddressbook
Summary: In Kmail 5.0.2 autocompletion only shows recent email addresses but not store...
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: contact completion (show other bugs)
Version: 5.2.3
Platform: Ubuntu Packages Linux
: NOR normal with 296 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-26 13:16 UTC by avlas
Modified: 2019-11-06 17:14 UTC (History)
34 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
attachment-300-0.html (2.43 KB, text/html)
2016-01-28 16:55 UTC, Donovan Hoare
Details
attachment-2945-0.html (2.76 KB, text/html)
2016-05-10 12:40 UTC, Donovan Hoare
Details
attachment-23227-0.html (2.50 KB, text/html)
2016-06-30 04:10 UTC, Donovan Hoare
Details
attachment-4199-0.html (729 bytes, text/html)
2016-11-16 02:30 UTC, Donovan Hoare
Details
attachment-30250-0.html (1.33 KB, text/html)
2016-11-16 12:21 UTC, Clay Weber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description avlas 2015-10-26 13:16:24 UTC
There is a regression in the e-mail composer of Kmail 5.0.2. Autocompletion of e-mail addresses only displays recent e-mail addresses but not those that are stored in Kaddressbook.

Reproducible: Always
Comment 1 fisch 2015-11-04 20:06:05 UTC
I have identified precisely the same behaviour.  Auto-complete works fine for "recent addresses" and those "contacts found in your data" but does not seem to complete from the (akonadi) address books.

Just to be clear, I am running Kubuntu 15.10, KMail 5.0.2 and KDE Frameworks 5.15.0.
Comment 2 Andreas T 2015-11-30 18:57:52 UTC
Same issue here: Only "Recent addresses" is working. If I click on the button right beside the entry field to select recipients in a separate window (German: "Auswählen..." Button), the full address book is shown and I can select addresses from there.

Kubuntu 15.10, KMail 5.0.2, KDE Frameworks 5.15.0, Locale: German
Comment 3 Gerhard Lehnhoff 2015-12-01 11:35:31 UTC
Same problem (Kubuntu 15.10, kmail 5.0.2, kontact 5.0.2)
Comment 4 Donovan Hoare 2015-12-28 03:53:06 UTC
The same here. does it on 3 machines with a kubuntu 15.10 install
I have backports enabled on mine and still doing it.

I can auto complete recent address but nothing from google address book or current emails
This makes it very hard to use, as well as convince people to switch to kde.

How to reproduce.
Install fresh copy 15.10, setup email and add google address book.
try type an address when creating new email.

I expect to see matching items.
What is see : NOTHING

If this is only an kubuntu issue please let me know so i can file a bug there
Comment 5 AndreasH59 2015-12-30 09:29:48 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 Matt Hubert 2015-12-30 21:46:58 UTC
+1. Recent addresses are fine, Google Contacts all show up correctly in KAddressBook, but no autocomplete anymore in KMail composer.

KMail 5.0.2
KF 5.15.0
Kubuntu 15.10
Comment 7 Laurent Montel 2016-01-02 10:32:13 UTC
Please test in 5.1 I fixed some bug in akonadisearch.
Comment 8 Gerhard Lehnhoff 2016-01-04 14:19:48 UTC
"Please test in 5.1 I fixed some bug in akonadisearch."

I use standard Kubuntu 15.10, which seems not to provide 5.1. How do I upgrade (I am not a Guru)?

Cheers, gl
Comment 9 Martin Tlustos 2016-01-18 07:47:47 UTC
You need to add "ppa:kubuntu-ppa" (and maybe "ppa:kubuntu-backports") to your repository. The version there is still 5.0.3, though, but 5.1 should make it there eventually.
Comment 10 piedro 2016-01-26 02:26:35 UTC
In Arch with KF5 15.12 and plasma 5.5.3 this is still the case. 

p.
Comment 11 piedro 2016-01-28 09:07:00 UTC
This is Kmail 5.1.1 btw.
Comment 12 Michael D 2016-01-28 14:46:16 UTC
Kubuntu 15.10 with backports, Plasma 5.5.3 and Frameworks 15.18.0 is still on KMail2 5.0.2, Applications 15.08.2. Can I ask which version of Applications 5.1 ships with? Is it in Applications 15.12.1?

I still have the bug, of course.
Comment 13 Donovan Hoare 2016-01-28 16:19:49 UTC
I think we will have to suffer until 16.04 is released. Ive switched to gnome and thunderbird. this is such a big bug. everyone and i mean every linux user uses email and to not be able to email an address-book contact from the to line... Really ppl

They have "Fixed" the problem but no one can test it. so if the fix didn’t work 16.04 is out of use aswell.

And linus torvald wanders why we cant get the desktop. Its because users cant wait this long for this.
Perhaps the admin, for us "stupid" users can explain how we can get the fix now rather than say it will be there eventually.

Ha ve an awesome day. sorry for the rant but over 6 months i cant work
Comment 14 Michael D 2016-01-28 16:28:43 UTC
Donovan, you do know you can access the address book by simply clicking the "Select" button next to the "To/CC/BCC" field and then searching for your contact that way?

You can also just open kaddressbook, find your contact there, and click their email address.

It's mildly inconvenient, especially in today's age, but come on, it's not like it prevents people from working (though it may add up to 3 minutes more to your work day).
Comment 15 Donovan Hoare 2016-01-28 16:55:18 UTC
Created attachment 96888 [details]
attachment-300-0.html

I send 300 emails a day.  And i have 10 support calls a day about it.  My staff that i FORCE to use linux all day.  (that say cant we use windows)  complain every day.  Im not a home user.  Im an IT support company.  The main reason i used kmail is that not even did the last version seach address book.  It also searched the actual emails.
So yes why dont i just stick with LTS.  Im a qt developer as well and need to stay current.
There are alotnof other reasons i stay current aswell. 
If you look at my bug reports. I had one about sast time not working.  Someone didnt fix it for 2 years.  So my calendar entries didnt work properly.  After a rant it took someone 1 hoir to fix.  I still had to wait 6 months for release.
So 3 mins a day for a normal person is 1 hour for me. 
But thia is not a rant place.  Even though im the one doing it.  Its a please pretty please fix. And let us know how to test. 






Sent from my Samsung device

-------- Original message --------
From: Michael D via KDE Bugzilla <bugzilla_noreply@kde.org> 
Date: 28/01/2016  18:28  (GMT+02:00) 
To: donovan@atstech.co.za 
Subject: [kmail2] [Bug 354400] In Kmail 5.0.2 autocompletion only shows
  recent email addresses but not stored emails in Kaddressbook 

https://bugs.kde.org/show_bug.cgi?id=354400

--- Comment #14 from Michael D <nortexoid@gmail.com> ---
Donovan, you do know you can access the address book by simply clicking the
"Select" button next to the "To/CC/BCC" field and then searching for your
contact that way?

You can also just open kaddressbook, find your contact there, and click their
email address.

It's mildly inconvenient, especially in today's age, but come on, it's not like
it prevents people from working (though it may add up to 3 minutes more to your
work day).
Comment 16 piedro 2016-02-02 09:47:20 UTC
I do not think that opening the addressbook is a valid workaround. 

A well done feature for auto-completion should   

- be usable to instantly open available addressbook entries (preferably with a configuration option to exclude some addressbooks to prevent privacy issues and needless clutter with big huge contact lists)  

- include addresses that are not in the addressbooks but have been answered to before (also configuration options within kmails settings are required) 

- be ahead of the competition by featuring configuration options for pre-filtering and pre-sorting the entries shown plus a quick access button for changing the order of appearance on the fly 

Being content with the limitations of a mediocre and buggy approach shouldn't suit KDE well. 
I would hope for a bit more inspiration and ambition. Thunderbird is old as and more or less abandoned but still does a better job in many areas as new and shiny kmail... Mild inconveniences can't be the place to settle on for a self acclaimed ambitious project like KDE. 

back to the bug: 
It's probably not helping but it seems like since the last updates (ARCH fully upgraded) the search doesn't work initially but after a while it suddenly starts working until closing kmail. 
Same after restarting kmail - sadly I can't see any useful pattern to report here. 

cheers, p.
Comment 17 Ken Freeland 2016-02-19 22:27:52 UTC
selecting from "TO" button crashes akonodi resource 9 times out of ten for me...it's not much of a solution to this dreadful issue
Comment 18 Donovan Hoare 2016-04-25 07:07:54 UTC
I have just installed kubuntu 16.04

And it still doesn't work.
I really want to cry right now.

Is there ANYTHING i can do to get this working.
Please pretty please
Comment 19 Adam Dymitruk 2016-04-28 03:06:26 UTC
Still broken. I'm adding contacts by accident now. Recents doesn't seem to update properly either.
Comment 20 Donovan Hoare 2016-04-28 04:05:55 UTC
BTW i can also confirm recent addresses are now ALSO not working.
not kmail is not even usable, atleast recent you could set to 2000 then it was ok after a while.
Comment 21 Michael D 2016-04-28 08:46:53 UTC
Recent addresses sort of work. Type in the recepient field (To, BCC, etc.) and then backspace to the beginning. Then type again and recents will show up. I suppose this qualifies as part of this bug.
Comment 22 Stephan Küffner 2016-04-28 12:58:08 UTC
Can confirm this behavior.
No recent addresses, no owncloud addresses through akonadi

Kubuntu 16.04, Kontact 5.1.3
Comment 23 contremaitre1 2016-05-04 20:13:17 UTC
I confirm Michael D #21 comment :
You need to type some letters, backspace to the beginning, and type again to get it working.
Kmail 5.1.3
Comment 24 AndreasH59 2016-05-10 09:17:33 UTC
Is nobody able (or willing) to finally fix this bug ? Aunt google tells this bug exists for years ?! Really ?
back to thunderbird, have fun playing with this toy, i need a working mail client
Comment 25 Laurent Montel 2016-05-10 10:29:53 UTC
(In reply to AndreasH59 from comment #24)
> Is nobody able (or willing) to finally fix this bug ? Aunt google tells this
> bug exists for years ?! Really ?
> back to thunderbird, have fun playing with this toy, i need a working mail
> client

Ok bye :)
Comment 26 Gerhard Lehnhoff 2016-05-10 12:11:15 UTC
Well Laurent, it is not that easy to just say "bye". AndreasH59 is right. This bug is annoying if you like to use KMail in a productive environment with many contacts in your address-book. It annoys me too and I also have in the meanwhile Ubuntu (and Thunderbird) installed (but have to admit, that I still work mainly with Kubuntu and KMail). It is not only for that bug, there are plenty of bugs in Kubuntu. In KMail e.g. putting new words to the spelling dictionary does not work too. And, and, and.

I like Kubuntu more than Ubuntu, but it is sometimes hard to stay with Kubuntu.

On the other side, I know that most of you are doing this job for free and that this is free software. However, this worked in a previous version why not now anymore?

Cheers, gl
Comment 27 Donovan Hoare 2016-05-10 12:40:26 UTC
Created attachment 98875 [details]
attachment-2945-0.html

Agreed. ive mentioned it all before.
My current next hope is that as soon as kde neon gets kde apps that it 
will work there.
Other than that i dont know.

there is something about kmail that makes me want to use it, but it 
UNUSABLE.
ofter the last update not even recent address works unless you backspace 
after starting to type.

I will personally pay someone for a few hours of work via paypal in 
order to fix this bug.
But after the fix i need a way to install it.
if anyone would like to accept my ofer please let me know

Regards

Donovan Hoare



On 10/05/2016 14:11, Gerhard Lehnhoff via KDE Bugzilla wrote:
> https://bugs.kde.org/show_bug.cgi?id=354400
>
> --- Comment #26 from Gerhard Lehnhoff <public@glehnhoff.de> ---
> Well Laurent, it is not that easy to just say "bye". AndreasH59 is right. This
> bug is annoying if you like to use KMail in a productive environment with many
> contacts in your address-book. It annoys me too and I also have in the
> meanwhile Ubuntu (and Thunderbird) installed (but have to admit, that I still
> work mainly with Kubuntu and KMail). It is not only for that bug, there are
> plenty of bugs in Kubuntu. In KMail e.g. putting new words to the spelling
> dictionary does not work too. And, and, and.
>
> I like Kubuntu more than Ubuntu, but it is sometimes hard to stay with Kubuntu.
>
> On the other side, I know that most of you are doing this job for free and that
> this is free software. However, this worked in a previous version why not now
> anymore?
>
> Cheers, gl
>
Comment 28 Laurent Montel 2016-05-10 12:55:28 UTC
(In reply to Gerhard Lehnhoff from comment #26)
> Well Laurent, it is not that easy to just say "bye". AndreasH59 is right.

As I wrote in 
"Bug 357670 - KMail 16.04.0: Composer auto-completion fails on first try"
it fixed in qt 5.6.0
It works fine here.
So ok this bug annoying you but I can't fix all bug when it depends against qt or lower lib.


> This bug is annoying if you like to use KMail in a productive environment
> with many contacts in your address-book. It annoys me too and I also have in
> the meanwhile Ubuntu (and Thunderbird) installed (but have to admit, that I
> still work mainly with Kubuntu and KMail). It is not only for that bug,
> there are plenty of bugs in Kubuntu. In KMail e.g. putting new words to the
> spelling dictionary does not work too. And, and, and.

If you have some bug in spellchecking perhaps report it against sonnet component.
It's not because you have a bug in kmail that it's depend just against kmail.

> 
> I like Kubuntu more than Ubuntu, but it is sometimes hard to stay with
> Kubuntu.
> 
> On the other side, I know that most of you are doing this job for free and
> that this is free software. However, this worked in a previous version why
> not now anymore?

Bug ?

> 
> Cheers, gl

I have a little tired to see comment as
"Is nobody able (or willing) to finally fix this bug ? Aunt google tells this bug exists for years ?! Really ?"

Yes kmail and other kde application or opensource application has some bugs, and indeed we don't have 24h to work by day on application. It's during free time.
And sometime we don't have a solution because it's a bug in qt or a bug that we can't reproduce.
For this bug I investigate in Bug 357670 and I didn't find a solution.

It works fine here.

I will take time to install another distro on my computer to evaluate it.
But for sure if it will easy to fix bug as it it already fixed.

Regards
Comment 29 jrohwer 2016-05-11 14:59:29 UTC
(In reply to Laurent Montel from comment #28)
> I have a little tired to see comment as
> "Is nobody able (or willing) to finally fix this bug ? Aunt google tells
> this bug exists for years ?! Really ?"
> 
> Yes kmail and other kde application or opensource application has some bugs,
> and indeed we don't have 24h to work by day on application. It's during free
> time.
> And sometime we don't have a solution because it's a bug in qt or a bug that
> we can't reproduce.
> For this bug I investigate in Bug 357670 and I didn't find a solution.
> 
> It works fine here.

I experienced the same bug (kmail not finding email addresses from kaddressbook) on a fresh install of Kubuntu 16.04. It turns out the binary files for akonadi search (package libkf5akonadisearch-bin) were not installed. After installing the specific package and allowing kontact to index my PIM data, everything now works as it should (except for the typing an initial character and backspacing to bring up the search results).

So maybe this is a kubuntu packaging/dependency issue? I must also mention that I had akonadi_baloo_indexer (package baloo_utils) installed, which is from KDE 4 and most probably conflicts with the KF5 akonadi search. (This is a fresh install, not upgrade from previous ubuntu version). I had to manually remove that package and its dependencies.
Comment 30 Andreas T 2016-05-11 16:10:07 UTC
I'm on a Kubuntu 16.04 installation (upgraded from 15.04)

I can confirm that installing libkf5akonadisearch-bin brings back the auto-completion for contacts in KAdressbook; the completion of recent addresses also works. For the completion to start, it is required to enter something in the recipient field and backspace to the beginning.

In my case, it was not required to uninstall baloo or trigger a reindex of PIM data.

Is someone else affected by this bug, ...
a) who is not using Kubuntu.
b) for whom installing libkf5akonadisearch-bin does not bring back the autocompletion?
Comment 31 Christian Heller 2016-05-11 18:41:26 UTC
Well, I am running Debian stable 8.4 with KDE 4.14.2 and KMail 4.14.1.
At home (i386), I have updated from version to version, for years.
At work (amd64), I had done a fresh install on a new box in January 2016.
The bug appears on both computers (recent addresses work, but not address book).

There is no package "libkf5akonadisearch-bin" in Debian stable.
It is categorised as "experimental" at:
https://packages.debian.org/experimental/libkf5akonadisearch-bin

Hence, this does not help me, unfortunately.
Patiently awaiting a solution for about a year now :)
Thanks for your attention, time and work.
Comment 32 jrohwer 2016-05-11 19:30:12 UTC
I was previously running kubuntu 14.04 with kmail 4.13.3 and everything was running perfectly. Do you have baloo installed and is akonadi_baloo_indexer running?
Comment 33 Donovan Hoare 2016-05-12 03:14:38 UTC
This bug started with 15.04 but got worse with 15.10 but atleast in 15 .10 recent addresses worked.
On 16.04, nothing works but if you start typing a email. then backspace to begin and start again it will search recent.

testing on 14.04 will not help
Comment 34 Donovan Hoare 2016-05-12 03:19:53 UTC
(In reply to jrohwer from comment #29)
> (In reply to Laurent Montel from comment #28)
> > I have a little tired to see comment as
> > "Is nobody able (or willing) to finally fix this bug ? Aunt google tells
> > this bug exists for years ?! Really ?"
> > 
> > Yes kmail and other kde application or opensource application has some bugs,
> > and indeed we don't have 24h to work by day on application. It's during free
> > time.
> > And sometime we don't have a solution because it's a bug in qt or a bug that
> > we can't reproduce.
> > For this bug I investigate in Bug 357670 and I didn't find a solution.
> > 
> > It works fine here.
> 
> I experienced the same bug (kmail not finding email addresses from
> kaddressbook) on a fresh install of Kubuntu 16.04. It turns out the binary
> files for akonadi search (package libkf5akonadisearch-bin) were not
> installed. After installing the specific package and allowing kontact to
> index my PIM data, everything now works as it should (except for the typing
> an initial character and backspacing to bring up the search results).
> 

What must we do to get contact to reindex after installing, or does it do it itself.
I have just installed and will give feedback
Comment 35 jrohwer 2016-05-12 06:00:36 UTC
(In reply to Donovan Hoare from comment #34)

> What must we do to get contact to reindex after installing, or does it do it
> itself.
> I have just installed and will give feedback

On the terminal just do
$ akonadictl restart

Then:
$ ps -ef |grep akonadi

If you see a process "/usr/bin/akonadi_indexing_agent" it should be good and will index by itself. May take a while depending on the amount of email you have.
Comment 36 Christian Heller 2016-05-12 07:11:26 UTC
(In reply to jrohwer from comment #32)
> I was previously running kubuntu 14.04 with kmail 4.13.3 and everything was
> running perfectly. Do you have baloo installed and is akonadi_baloo_indexer
> running?

The "akonadi_baloo_indexer" was not running in my KDE.

Automatically installed Debian packages (only these) were:
- libbaloocore4
- libbaloofiles4
- libbaloopim4
- libbalooqueryparser4
- libbalooxapian4
- libbaloowidgets4

Following your suggestion, I additionally installed these:
- baloo4
- baloo-utils (automatically, dependency)

Still no "akonadi_baloo_indexer" process running.
A restart did help. IT WORKS NOW! :))
The process view shows "baloo_file" and "akonadi_baloo_indexer".

Remark 1:

The tick at "Enable Desktop Search" has to be set at:
| KDE System Settings | Workspace Appearance and Behaviour | Desktop Search
It was set automatically after having had installed the "baloo4" package.

Remark 2:

For convenience in configuration, I afterwards also installed the package:
- kde-config-baloo-advanced

However, it is not really needed, so that I removed it again.

Remark 3:

After my restart, I got this authentication dialogue requesting a password:

"An application is attempting to perform an action that requires privileges.
Authentication is required to perform this action."
Action: Folder Watch Limit

It seems to be related to the process "kde_baloo_filewatch_limit",
which showed up in the process view, but disappeared after some seconds.

This issue (bug?) is described here:
https://forum.kde.org/viewtopic.php?f=66&t=127876

Remark 4:

I have filed a bug report for the "kmail" package to Debian.

Thank you very much!
Christian Heller
Comment 37 Christian Heller 2016-05-12 07:45:53 UTC
(In reply to Christian Heller from comment #36)

My joy was premature.

When typing a name, kmail offers me email addresses from the categories:
- Recent Addresses
- Contacts found in your data

But the address book is still missing :(
Comment 38 Gerhard Lehnhoff 2016-05-13 19:21:17 UTC
I installed "libkf5akonadisearch-bin" on Kubuntu 15.10. Address Completion works now!

Success. Thanks to Andreas T.




. (In reply to Andreas T from comment #30)
> I'm on a Kubuntu 16.04 installation (upgraded from 15.04)
> 
> I can confirm that installing libkf5akonadisearch-bin brings back the
> auto-completion for contacts in KAdressbook; the completion of recent
> addresses also works. For the completion to start, it is required to enter
> something in the recipient field and backspace to the beginning.
> 
> In my case, it was not required to uninstall baloo or trigger a reindex of
> PIM data.
> 
> Is someone else affected by this bug, ...
> a) who is not using Kubuntu.
> b) for whom installing libkf5akonadisearch-bin does not bring back the
> autocompletion?
Comment 39 Gerhard Lehnhoff 2016-05-13 21:19:46 UTC
I installed "libkf5akonadisearch-bin" on Kubuntu 15.10. Address Completion works, also after upgrade to 16.04.



I installed "libkf5akonadisearch-bin" on Kubuntu 15.10. Address Completion works now! Success. Thanks to Andreas T. . (In reply to Andreas T from comment #30) > I'm on a Kubuntu 16.04 installation (upgraded from 15.04)
> 
> I can confirm that installing libkf5akonadisearch-bin brings back the
> auto-completion for contacts in KAdressbook; the completion of recent
> addresses also works. For the completion to start, it is required to enter
> something in the recipient field and backspace to the beginning.
> 
> In my case, it was not required to uninstall baloo or trigger a reindex of
> PIM data.
> 
> Is someone else affected by this bug, ...
> a) who is not using Kubuntu.
> b) for whom installing libkf5akonadisearch-bin does not bring back the
> autocompletion?
Comment 40 Jacopo Torrini 2016-05-14 07:39:33 UTC
I have kubuntu 16.04, clean install.
I have installed libkf5akonadisearch-bin and now quick search and search in messages work again (they were not working since kubuntu 15.04). But... address completion is not working, only recent addresses are shown. (I have google contacts).

(In reply to Gerhard Lehnhoff from comment #39)
> I installed "libkf5akonadisearch-bin" on Kubuntu 15.10. Address Completion
> works, also after upgrade to 16.04.
> 
> 
> 
> I installed "libkf5akonadisearch-bin" on Kubuntu 15.10. Address Completion
> works now! Success. Thanks to Andreas T. . (In reply to Andreas T from
> comment #30) > I'm on a Kubuntu 16.04 installation (upgraded from 15.04)
> > 
> > I can confirm that installing libkf5akonadisearch-bin brings back the
> > auto-completion for contacts in KAdressbook; the completion of recent
> > addresses also works. For the completion to start, it is required to enter
> > something in the recipient field and backspace to the beginning.
> > 
> > In my case, it was not required to uninstall baloo or trigger a reindex of
> > PIM data.
> > 
> > Is someone else affected by this bug, ...
> > a) who is not using Kubuntu.
> > b) for whom installing libkf5akonadisearch-bin does not bring back the
> > autocompletion?
Comment 41 Gerhard Lehnhoff 2016-05-16 15:12:44 UTC
(In reply to Gerhard Lehnhoff from comment #39)
> I installed "libkf5akonadisearch-bin" on Kubuntu 15.10. Address Completion
> works, also after upgrade to 16.04.

I was wrong. Address completion only works, ...

(a) if "libkf5akonadisearch-bin" has been installed,
(b) if I type something in the To-field (not working), 
(c) than go back completely with Backspace, 
(d) and then type again. 

Then it works for both, Google Address book and Recent Emails.
Comment 42 Fabio Coatti 2016-05-17 07:38:31 UTC
The issue with autocompletion is still here on kmail 5.2.1 (kdeapps 16.04.01), qt 5.6.0, plasma 5.6.4 (gentoo kde overlay)

The workaround that involves hitting backspace seems to point to a input form issue, but it is only a wild guess :)
Comment 43 Martin Steigerwald 2016-05-17 07:43:25 UTC
I can confirm this issue here as well as the exact work-around from comment #41 to delete till beginning of text input field. Thanks for taking the time for testing this.
Comment 44 flyos 2016-05-30 08:40:35 UTC
I can confirm this behaviour (auto-completion from Kaddressbook working only after typing-backslash-to-the-beginning-and-typing-again) on OpenSUSE Leap 42.1, KDE Applications 16.04, KF5.22, Qt 5.6 (well, everything KDE/Qt-related mostly bleeding edge really...).
Comment 45 Michel Grentzinger 2016-05-30 19:09:26 UTC
For me, on Kubuntu 16.04, this solutions works only for recent addresses.
Comment 46 Martin Tlustos 2016-06-02 13:28:17 UTC
Disabling the use of recent addresses helps in my case (kmail 5.1.3 on Kubuntu 16.04). i don't need to type - delete again - type to enable autocompletion. Which also hints towards recent addresses being the bad guy...
Comment 47 bill p. (aka google01103) 2016-06-02 13:40:38 UTC
confirmation of Martin Tlustos comment # 46 "Disabling the use of recent addresses helps"

running openSuse Leap, Kmail 5.2.1
Comment 48 Stephan Küffner 2016-06-13 14:55:44 UTC
With KDE Updates from Backports no changes.

- Recent Addresses only with type->Backslash->type behavior
- Addresses from other sources (owncloud) not working

Kontact Version 5.1.3
KDE Plasma Version 5.6.4
KDE Frameworks 5.22.0
Qt 5.5.1 (kompiliert gegen 5.5.1)
Comment 49 GK 2016-06-29 08:36:35 UTC
Struggling with this bug a week now after fresh installation of Kubuntu 16.04LTS.  
I tried all options as suggested in various comments above with no result. 

libkf5akonadisearch-bin is installed.  

Still the bug is there:
- recent addresses works only after Type in TO field --->Delete it ---> Type again 
- addresses from other sources like Google not working

Kontact Version 5.1.3 
KDE Plasma Version 5.6.4 
KDE Frameworks 5.22.0 
Qt 5.5.1
4.4.0-28-generic
Comment 50 Donovan Hoare 2016-06-30 04:10:48 UTC
Created attachment 99766 [details]
attachment-23227-0.html

Guys if your reading this, you will notice that the problem has been 
around for ages.
With no planned fix in site.

Switch to Thunderbird.
There is far less problems.

I actually only find one thing annoying and that is wen you send an 
email it stays in the forground until its complete.
Ill live with that to have contacts



On 29/06/2016 10:36, GK via KDE Bugzilla wrote:
> https://bugs.kde.org/show_bug.cgi?id=354400
>
> GK <gkourtev@gmail.com> changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                   CC|                            |gkourtev@gmail.com
>
> --- Comment #49 from GK <gkourtev@gmail.com> ---
> Struggling with this bug a week now after fresh installation of Kubuntu
> 16.04LTS.
> I tried all options as suggested in various comments above with no result.
>
> libkf5akonadisearch-bin is installed.
>
> Still the bug is there:
> - recent addresses works only after Type in TO field --->Delete it ---> Type
> again
> - addresses from other sources like Google not working
>
> Kontact Version 5.1.3
> KDE Plasma Version 5.6.4
> KDE Frameworks 5.22.0
> Qt 5.5.1
> 4.4.0-28-generic
>
Comment 51 pietz 2016-07-04 21:47:33 UTC
I can confirm this bug for years now. I have kmail 5.1.3 and only recent addresses are working, although completion order is set to FIRST search CardDav and THEN recent addresses.

The select button next to the address bar is showing me all my CardDav contacts.

Please fix this because kmail rocks besides this! Thanks :-)
Comment 52 kubik 2016-07-07 21:26:07 UTC
In my Debian (jessie or stretch) installing package kdepim (and reboot) solved this problem.
Comment 53 kubik 2016-07-21 04:03:22 UTC
(In reply to kubik from comment #52)
> In my Debian (jessie or stretch) installing package kdepim (and reboot)
> solved this problem.

Edit: Another package is needed: baloo-utils :-)
Comment 54 contremaitre1 2016-09-25 19:20:17 UTC
This bug is still in kmail 5.1.3, KDE framework 5.24.0 :(
Any plan to fix it ?
Comment 55 GK 2016-09-30 07:50:40 UTC
Indeed it is still here as well and no solution found. Very annoying bug.
Kubuntu 16.04
Plasma 5.6.5
Comment 56 Michel Grentzinger 2016-10-20 06:18:39 UTC
Ubuntu 16.10 (Kmail 5.2.3) : still present
Comment 57 flyos 2016-10-20 07:04:26 UTC
Using KDE Applications 16.08.2 and KF 5.26.0 on openSUSE Tumbleweed, I cannot reproduce this bug anymore. As far as I'm concern, it seems to be fixed (I didn't check for a while, so couldn't say which version offered the fix).

Can anybody with recent release reproduce this bug anymore?
Comment 58 contremaitre1 2016-10-20 07:09:06 UTC
It's fixed for me, I am running KDE Frameworks 5.27
Comment 59 pietz 2016-10-28 19:18:55 UTC
I upgraded to kubuntu 16.10 and it is still not working. It is kmail 5.2.3. Since which version should this bug be fixed again?
Comment 60 flyos 2016-10-28 19:23:35 UTC
For me, the bug is fixed with 5.3.0 (KDE Applications 16.08), but it might have been fixed earlier.
Comment 61 jackdinn 2016-11-15 23:49:22 UTC
Iv just installed mint18 KDE Plasma 5.6.5 kontact/kmail 5.1.3 and iv also got this bug. I suspect it is also what is causing another problem with the "allow HTML/remote content from individual contacts" for me.

Is there a definitive fix for this as iv read the thread and there are a lot of suggestions so im not sure what to try as i dont like to mess around to much as i tend to break my OS.
Comment 62 Donovan Hoare 2016-11-16 02:30:42 UTC
Created attachment 102252 [details]
attachment-4199-0.html

The bug ha been there for years now, with no one fixing it.
I would advise you stop hassling yourself and just switch to another 
email client

Im using thunderbird, even though i prefer kontact.
After some tweeks it works rather well.

Donovan Hoare
Comment 63 jackdinn 2016-11-16 06:03:02 UTC
(In reply to Donovan Hoare from comment #62)
> Created attachment 102252 [details]
> attachment-4199-0.html
> 
> The bug ha been there for years now, with no one fixing it.
> I would advise you stop hassling yourself and just switch to another 
> email client
> 
> Im using thunderbird, even though i prefer kontact.
> After some tweeks it works rather well.
> 
> Donovan Hoare

Id love to but http://www.linuxquestions.org/questions/linux-software-2/cant-find-an-email-client-that-works-4175593341/

Its more like stop trying to use KDE by the looks of it. Thx
Comment 64 flyos 2016-11-16 07:42:03 UTC
Can someone confirm the bug still being there for Kmail >5.3.0 (KDE Applications > 16.08)? Right now, we have only 2 people stating that it is fixed for these latter versions, so unless someone confirms the bug still being there, I think it's fair to say the bug is likely being fixed, but we'd need more confirmation to actually be sure. 

If you don't have 5.3.0 installed, the best way would be to fire up a live USB Neon image, set up your accounts and try to send an e-mail and see if the bug is still triggered.
Comment 65 Michael D 2016-11-16 08:20:31 UTC
On KDE Neon Developer Edition (git stable), the bug is gone. I'm not at my home computer at the moment, so I can't check the version, but one could check the repos to determine the current kmail build.
Comment 66 Clay Weber 2016-11-16 12:21:31 UTC
Created attachment 102256 [details]
attachment-30250-0.html

It is working fine for me, KDE Neon user edition. I'm away from my laptop so I can't verify the version.

On November 16, 2016 2:42:03 AM EST, bugzilla_noreply@kde.org wrote:
>https://bugs.kde.org/show_bug.cgi?id=354400
>
>--- Comment #64 from flyos@mailoo.org ---
>Can someone confirm the bug still being there for Kmail >5.3.0 (KDE
>Applications > 16.08)? Right now, we have only 2 people stating that it
>is
>fixed for these latter versions, so unless someone confirms the bug
>still being
>there, I think it's fair to say the bug is likely being fixed, but we'd
>need
>more confirmation to actually be sure. 
>
>If you don't have 5.3.0 installed, the best way would be to fire up a
>live USB
>Neon image, set up your accounts and try to send an e-mail and see if
>the bug
>is still triggered.
>
>-- 
>You are receiving this mail because:
>You are on the CC list for the bug.
Comment 67 jackdinn 2016-11-16 18:10:23 UTC
some info regarding progress with kmail/kontacts here https://ubuntuforums.org/showthread.php?t=2341803&p=13564260#post13564260 so might be some movement going on. 
Ignore this if its already in the backport, i dont know how to check that really without switching it on.
Comment 68 Thomas Zell 2016-12-06 20:22:54 UTC
For me contact completion from the address book was not working at all. It was fixed by right clicking on "Personal Contacts" in the Akonadi Console (akonadiconsole) and selecting "Clear Akonadi Cache". I'm on openSUSE Leap 42.2 with KMail 5.3.0 and KDE Frameworks 5.26.0.
Comment 69 Michel Grentzinger 2016-12-16 19:30:10 UTC
I confirm that this solution works for me. I use Ubuntu 16.10 with KMail 5.2.3 and KDE Framework 5.26.0

Right click on "Personal Contacts" in the Akonadi Console (akonadiconsole) and select "Clear Akonadi Cache" !

-:)
Comment 70 jackdinn 2016-12-17 18:04:04 UTC
hmm , where exactly is that option ?
https://i.sli.mg/OBcKSF.png
Comment 71 Thomas Zell 2016-12-17 19:12:22 UTC
You need to go to the "Browser" tab (your screenshot shows the "Agents" tab).
Comment 72 jackdinn 2016-12-17 19:22:33 UTC
Cheers, but did not work. I still have to write at least 1 letter in the TO field and then rub it out before it will auto fill the address from my personal address book :( 

Just had a large update for kmail, akonadi, pim etc etc so thought it might be fixed but unfortunately not in my case.

mint 18
plasma 5.8.4
framework 5.28.0
QT 5.6.1
kernal 4.4.0-53
Kmail 5.2.3


But thx.
Comment 73 jackdinn 2016-12-17 19:28:41 UTC
Ops , my mistake. It had removed ALL my personal address after cache reset & reboot so i re-imported them again and seems to work now.

Thank you very much.
Comment 74 Michael Barraclough 2017-04-21 01:46:57 UTC
I have Kubuntu 17.04 with KMail 5.2.3. As far as I aw aware, these are the latest. THIS PROBLEM STILL EXISTS. If Kubuntu/KMail wish to be taken seriously then this needs to be addressed FAST. For now I am advising all my clients to avoid KMail (and therefore Kubuntu)

Reprodcable - always

Kubuntu 17.04
Frameworks 5.31.0
QT 5.7.1
Comment 75 flyos 2017-04-21 02:06:56 UTC
Unfortunately, Kubuntu is not as up-to-date as it has been. It seems the version of KDE PIM provided in Zetsy is from KDE Applications 16.04, so from a year ago. The latest version of Kmail is 5.4.3 (with an imminent update with KDE Applications 17.04).

Using the feedback from this bug, it seems to have been fixed around KDE Applications 16.08 (Kmail 5.3.0).
Comment 76 Michael Barraclough 2017-04-21 02:36:19 UTC
Thank you for this update. Where can I find 5.4.3 to download please?
Comment 77 flyos 2017-04-21 02:44:29 UTC
Sorry, I don't know. It is not provided in the Kubuntu Backports PPA. You can try to get it from KDE Neon, but I suspect you will need a whole bunch of deps including QtWebEngine, so you might be better off directly trying Neon (or another distribution) if this is important for you.
Comment 78 Denis Kurz 2017-05-19 08:14:47 UTC
Scanning all the comments, it seems to work now, or at least to be no longer a KMail bug, but a distribution problem. If you think I'm wrong because a very recent version of KMail (version 16.12.0 or later?) still fails to autocomplete although you have the required packages installed, please tell me so and I'll reopen. In that case, please at least try to convince me that this is not a downstream problem.
Comment 79 Michael Barraclough 2017-05-19 19:01:46 UTC
I managed to implement KMail 5.4.3 but this did not seem to fix the issue. However, very shortly after that I received a flurry of updates via the updater and it started working after that.
Comment 80 flyos 2017-05-20 02:46:05 UTC
I suspect the bunch of updates you had was the recent Kubuntu updates specifically for KDE PIM (finally bumping it to a recent release, they probably had issues with QtWebEngine), so it would appear that up-to-date versions are not affected anymore.
Comment 81 kubik 2017-07-31 11:42:33 UTC
It is possible for older versions (for example in Debian) to install akonadi-backend-postgresql insteat akonadi-backend-mysql. It seems to have helped me.