Bug 353671 - Full Search does not find any Mails
Summary: Full Search does not find any Mails
Status: RESOLVED DUPLICATE of bug 277007
Alias: None
Product: kmail2
Classification: Applications
Component: search (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal with 76 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-07 22:12 UTC by kramski
Modified: 2017-01-13 13:18 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kramski 2015-10-07 22:12:14 UTC
Search (shortcut "s") does not find any results at all, regardless of search criteria.

Reproducible: Always

Steps to Reproduce:
1. Open "Find message windows" on a folder (IMAP inbox in my case)
2. Search for something you know there should be matches, e.g. a known subject or sender

Actual Results:  
Empty result list, empty search folder

Expected Results:  
Result list containing matching mails.

Kmail Version 5.0.1 KDE Frameworks 5.14.0 Qt 5.5.0 (built against 5.5.0)

After initial setup of Kmail and accounts, "Folder Properties / Maintenance / Indexing" of the folder in question was showing
   [x] Enable Full Text Indexing
   Still not indexed

I was able to change this to
   Indexed 30 items of this collection
by deleting ./config/baloorc and "akonadictl restart", however, search result still is empty regardless of what I search for.
Comment 1 kramski 2015-12-21 12:10:46 UTC
Still unresolved with KMail 5.1.
Comment 2 Tom Warnke 2016-01-14 12:29:56 UTC
Is this still an issue in KMail 5.1.1? I had a similar problem, but it seems to be fixed now.
Comment 3 kramski 2016-01-14 14:17:32 UTC
Unfortunately still unresolved with KMail 5.1.1
Comment 4 Tom Warnke 2016-01-14 14:26:57 UTC
Can you check if you have a package called "akonadi-search" or similar installed?
Comment 5 kramski 2016-01-14 16:42:28 UTC
extra/akonadi-search 15.12.1-1 [Installiert]

I also tried again the "deleting ./config/baloorc and 'akonadictl restart'" thing and cycling the "Enable Full Text indexing" property (Folder Properties / Maintenance / Indexing) of my the mail folders I'm testing with to no avail.

The indexing status shown here ("Indexed n items of this collection") matches the actual number of mail items of my folders, however all indexing results seem to be hidden somewhere.
Comment 6 kramski 2016-01-14 16:44:53 UTC
Sorry, typo again, it's "~/.config/baloorc".
Comment 7 Tom Warnke 2016-01-14 17:10:26 UTC
Can you try with a fresh user? I.e., set up an IMAP account, let it download and index some emails, and try to search in them? This should show if some configuration error is the reason.
Comment 8 kramski 2016-01-14 22:48:48 UTC
I see a strange behaviour: When I tried this with another  (barely used) account, the bug was also there (no results at all). I then deleted the search folder (to see if https://bugs.kde.org/show_bug.cgi?id=353318 also applies to me) and after that and a KMail restart, my searches for the first time showed some results. The same is true for my own account.

So my current workaround seems to be:
1. Delete the search folder
2. Restart KMail to fix the folder control corruption
3. Search
Sometimes the result list is empty then, sometimes not, but opening the search folder always seems to show the results expected, at least in a few quick tests.
Comment 9 Tom Warnke 2016-01-15 08:27:35 UTC
I see the same behavior. Also choosing a different name for the search folder seems to help sometimes.
I think this is actually the same bug as https://bugs.kde.org/show_bug.cgi?id=353318
Comment 10 kramski 2016-04-23 17:54:36 UTC
Stili unresolved in Version 5.2.0 
(Arch pacman: upgraded kmail (15.12.3-1 -> 16.04.0-2))
Comment 11 Alvin 2016-09-22 08:09:12 UTC
Add Kmail 5.3.0 to the list. 0 search results.
Comment 12 Denis Kurz 2017-01-13 13:18:09 UTC

*** This bug has been marked as a duplicate of bug 277007 ***