Bug 352077 - KSysGuard crash on exit
Summary: KSysGuard crash on exit
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.3.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
: 361767 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-31 23:49 UTC by Darryl
Modified: 2018-02-16 22:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darryl 2015-08-31 23:49:57 UTC
Application: ksysguard (5.3.2)

Qt Version: 5.4.1
Operating System: Linux 4.1.6-040106-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
KSysGuard crashed when I exited the program. I didn't notice any other unusual behaviour.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f06e8c97800 (LWP 1997))]

Thread 2 (Thread 0x7f06cdab6700 (LWP 1998)):
#0  0x00007f06e86e28dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f06de0b9b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f06de0bb64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f06d0054099 in QXcbEventReader::run (this=0x2470270) at qxcbconnection.cpp:1105
#4  0x00007f06e45a0b0e in QThreadPrivate::start (arg=0x2470270) at thread/qthread_unix.cpp:337
#5  0x00007f06ddc966aa in start_thread (arg=0x7f06cdab6700) at pthread_create.c:333
#6  0x00007f06e86edeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f06e8c97800 (LWP 1997)):
[KCrash Handler]
#6  0x00007f06e522e199 in QLabelPrivate::clearContents (this=this@entry=0x274f910) at widgets/qlabel.cpp:1268
#7  0x00007f06e522ecea in QLabel::setText (this=0x2610990, text=...) at widgets/qlabel.cpp:282
#8  0x00007f06e8a2a539 in ?? () from /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#9  0x00007f06e787826b in KSGRD::SensorAgent::processAnswer (this=this@entry=0x26d9730, buf=<optimized out>, buflen=<optimized out>) at ../../ksgrd/SensorAgent.cpp:188
#10 0x00007f06e787fb60 in KSGRD::SensorShellAgent::msgRcvd (this=0x26d9730) at ../../ksgrd/SensorShellAgent.cpp:94
#11 0x00007f06e480f9c9 in QMetaObject::activate (sender=0x26d9500, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3716
#12 0x00007f06e470833c in QProcessPrivate::tryReadFromChannel (this=0x26d7f50, channel=0x1) at io/qprocess.cpp:966
#13 0x00007f06e4708eb0 in _q_canReadStandardOutput (this=<optimized out>) at io/qprocess.cpp:977
#14 QProcess::qt_static_metacall (_o=0x191, _c=43519488, _id=0, _a=0x7f06e89abc10 <main_arena+16>) at .moc/moc_qprocess.cpp:136
#15 0x00007f06e480f9c9 in QMetaObject::activate (sender=0x26d9640, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffe7955a780) at kernel/qobject.cpp:3716
#16 0x00007f06e4810057 in QMetaObject::activate (sender=<optimized out>, m=m@entry=0x7f06e4a39480 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffe7955a780) at kernel/qobject.cpp:3582
#17 0x00007f06e488f45e in QSocketNotifier::activated (this=<optimized out>, _t1=14) at .moc/moc_qsocketnotifier.cpp:133
#18 0x00007f06e481d51b in QSocketNotifier::event (this=0x26d9640, e=0xffeb0101) at kernel/qsocketnotifier.cpp:296
#19 0x00007f06e50e8b2c in QApplicationPrivate::notify_helper (this=0x24463c0, receiver=0x26d9640, e=0x7ffe7955a9e0) at kernel/qapplication.cpp:3720
#20 0x00007f06e50ee000 in QApplication::notify (this=0x7ffe7955ad10, receiver=0x26d9640, e=0x7ffe7955a9e0) at kernel/qapplication.cpp:3503
#21 0x00007f06e47dec2b in QCoreApplication::notifyInternal (this=0x7ffe7955ad10, receiver=0x26d9640, event=event@entry=0x7ffe7955a9e0) at kernel/qcoreapplication.cpp:935
#22 0x00007f06e4838345 in sendEvent (event=0x7ffe7955a9e0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#23 socketNotifierSourceDispatch (source=0x24952c0) at kernel/qeventdispatcher_glib.cpp:101
#24 0x00007f06dd110c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f06dd110f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f06dd110fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f06e4837c57 in QEventDispatcherGlib::processEvents (this=0x249f7b0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#28 0x00007f06e47dc3e2 in QEventLoop::exec (this=this@entry=0x7ffe7955ac00, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#29 0x00007f06e47e402c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#30 0x00007f06e8a2bed9 in kdemain () from /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#31 0x00007f06e8607a40 in __libc_start_main (main=0x400730 <main>, argc=1, argv=0x7ffe7955ae58, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe7955ae48) at libc-start.c:289
#32 0x0000000000400769 in _start ()

Possible duplicates by query: bug 345592, bug 341857.

Reported using DrKonqi
Comment 1 Christoph Feck 2016-04-15 03:24:01 UTC
*** Bug 361767 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2018-02-16 22:46:43 UTC

*** This bug has been marked as a duplicate of bug 350140 ***