Bug 341857 - KSysGuard crash on exit
Summary: KSysGuard crash on exit
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
: 345592 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-13 21:52 UTC by Antonio Froio
Modified: 2018-02-16 22:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Froio 2014-12-13 21:52:28 UTC
Application: ksysguard (4.11.13)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.16.3-0.1-samwise-ufsrw x86_64
Distribution: Debian GNU/Linux 8.0 (jessie)

-- Information about the crash:
The application crashed when closing the window (by pushing the 'x' button)

-- Backtrace:
Application: Monitor di sistema (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x00007ff595a02bb6 in QLabelPrivate::clearContents (this=this@entry=0x1dc28a0) at widgets/qlabel.cpp:1378
#7  0x00007ff595a038fa in QLabel::setText (this=0x1caea00, text=...) at widgets/qlabel.cpp:360
#8  0x00007ff598a3f5bb in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_ksysguard.so
#9  0x00007ff597ae4bd4 in KSGRD::SensorAgent::processAnswer(char const*, int) () from /usr/lib/libksgrd.so.4
#10 0x00007ff597aec2ee in ?? () from /usr/lib/libksgrd.so.4
#11 0x00007ff5962acf4c in QMetaObject::activate (sender=sender@entry=0x1d352f0, m=m@entry=0x7ff5965fa240 <QProcess::staticMetaObject>, local_signal_index=local_signal_index@entry=5, argv=argv@entry=0x0) at kernel/qobject.cpp:3567
#12 0x00007ff596226ed3 in QProcess::readyReadStandardOutput (this=this@entry=0x1d352f0) at .moc/release-shared/moc_qprocess.cpp:175
#13 0x00007ff596227a72 in QProcessPrivate::_q_canReadStandardOutput (this=0x1daa9b0) at io/qprocess.cpp:936
#14 0x00007ff59622a2c9 in QProcess::qt_static_metacall (_o=0x7500710069006c, _id=30747984, _a=0x710069, _c=<optimized out>) at .moc/release-shared/moc_qprocess.cpp:83
#15 0x00007ff5962acf4c in QMetaObject::activate (sender=sender@entry=0x1dd0bf0, m=m@entry=0x7ff5965fdbc0 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff414675d0) at kernel/qobject.cpp:3567
#16 0x00007ff5962fa16e in QSocketNotifier::activated (this=this@entry=0x1dd0bf0, _t1=13) at .moc/release-shared/moc_qsocketnotifier.cpp:102
#17 0x00007ff5962b618b in QSocketNotifier::event (this=0x1dd0bf0, e=0x7fff414678a0) at kernel/qsocketnotifier.cpp:316
#18 0x00007ff5955ec29c in QApplicationPrivate::notify_helper (this=this@entry=0x1b710b0, receiver=receiver@entry=0x1dd0bf0, e=e@entry=0x7fff414678a0) at kernel/qapplication.cpp:4570
#19 0x00007ff5955f2da8 in QApplication::notify (this=this@entry=0x1b5e770, receiver=receiver@entry=0x1dd0bf0, e=e@entry=0x7fff414678a0) at kernel/qapplication.cpp:4356
#20 0x00007ff596fbc2ca in KApplication::notify (this=0x1b5e770, receiver=0x1dd0bf0, event=0x7fff414678a0) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x00007ff596297f8d in QCoreApplication::notifyInternal (this=0x1b5e770, receiver=0x1dd0bf0, event=event@entry=0x7fff414678a0) at kernel/qcoreapplication.cpp:955
#22 0x00007ff5962c7b50 in sendEvent (event=0x7fff414678a0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#23 socketNotifierSourceDispatch (source=0x1b712a0) at kernel/qeventdispatcher_glib.cpp:110
#24 0x00007ff58f0eec5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007ff58f0eef48 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007ff58f0eeffc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007ff5962c74ed in QEventDispatcherGlib::processEvents (this=0x1b47770, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#28 0x00007ff595690b96 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007ff596296ae1 in QEventLoop::processEvents (this=this@entry=0x7fff41467af0, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007ff596296e45 in QEventLoop::exec (this=this@entry=0x7fff41467af0, flags=...) at kernel/qeventloop.cpp:204
#31 0x00007ff59629c8b9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1227
#32 0x00007ff598a41248 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_ksysguard.so
#33 0x00007ff598651b45 in __libc_start_main (main=0x4006e0, argc=1, argv=0x7fff41467d48, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff41467d38) at libc-start.c:287
#34 0x000000000040070e in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2015-03-28 01:32:00 UTC
*** Bug 345592 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2018-02-16 22:45:45 UTC

*** This bug has been marked as a duplicate of bug 350140 ***