Bug 351431 - Many menu items are missing in 15.08
Summary: Many menu items are missing in 15.08
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-18 08:37 UTC by Antonio Rojas
Modified: 2016-02-17 14:41 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Rojas 2015-08-18 08:37:14 UTC
Many menu items are missing in gwenview 15.08: for instance, the rotating, reflecting, and cropping items from the "Edit" menu. Launching it from the command line shows the error:

cannot find .rc file "org.kde.gwenviewui.rc" for component "org.kde.gwenview"

Note that this is unrelated to bug 344675 (which is caused by a missing kf5 kipi-plugins). This is a regression in 15.08. I traced it back to this commit:

https://quickgit.kde.org/?p=gwenview.git&a=commit&h=78e4e57af3a5476dd949797c559a3d25d8ce50a1


Reproducible: Always
Comment 1 Antonio Rojas 2015-08-18 08:38:07 UTC
CC'ing commit author
Comment 2 Antonio Rojas 2015-08-18 13:12:00 UTC
Moving /usr/share/kxmlgui5/gwenview/gwenviewui.rc to /usr/share/kxmlgui5/org.kde.gwenview/org.kde.gwenviewui.rc fixes this
Comment 3 Mike 2015-09-08 16:40:41 UTC
I have a gwenviewui.rc located in "/usr/share/kxmlgui5/org.kde.gwenview/" but I have still the same problem that there is nothing in the menu. 
I have  a fresh install of  Manjarolinux 15.09 Bellatrix with KDE Plasma 5.4.0 and Gwenview 15.08.0 from the "standard" Repos in Manjaro.  
I have Digikam 5.12 and all Plugins are usable there. 
Best regards,
Mike
Comment 4 Mike 2015-09-08 16:42:39 UTC
Ahh..I dont have the directory gwenview under  "usr/share/kxmlgui5". The .rc-file was just on the position mentioned above... I dont had to move it. But its still not working.
Comment 5 Antonio Rojas 2015-09-08 16:50:42 UTC
(In reply to Mike from comment #3)
> I have a gwenviewui.rc located in "/usr/share/kxmlgui5/org.kde.gwenview/"
> but I have still the same problem that there is nothing in the menu. 
> I have  a fresh install of  Manjarolinux 15.09 Bellatrix with KDE Plasma
> 5.4.0 and Gwenview 15.08.0 from the "standard" Repos in Manjaro.  
> I have Digikam 5.12 and all Plugins are usable there. 
> Best regards,
> Mike

Your issue is unrelated to this, see bug 344675
Comment 6 Mike 2015-09-08 17:59:18 UTC
oh sorry... seems I mixed something up here.. please ignor/delete my comments if possible. I will repost in the correct bug !  thanks - Mike
Comment 7 Andreas Sturmlechner 2015-10-05 17:43:34 UTC
I've finally posted an RR: https://git.reviewboard.kde.org/r/125524/

Anyone watching here to approve the merge before 15.08.2 tagging?
Comment 8 David Edmundson 2015-10-10 11:03:50 UTC
Git commit 2420e0d3108e79c675b7d6a024d3d564ccc79189 by David Edmundson, on behalf of Andreas Sturmlechner.
Committed on 10/10/2015 at 10:30.
Pushed by davidedmundson into branch 'Applications/15.08'.

Fix missing menu items

Since the app name was changed in
78e4e57af3a5476dd949797c559a3d25d8ce50a1 we need to update where we
install our xmgui files to match
REVIEW: 125524

M  +2    -1    app/CMakeLists.txt

http://commits.kde.org/gwenview/2420e0d3108e79c675b7d6a024d3d564ccc79189