Bug 349805 - Plasma quits even some other applications block logout
Summary: Plasma quits even some other applications block logout
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.5.4
Platform: Chakra Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
: 337182 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-02 01:14 UTC by Weng Xuetian
Modified: 2016-03-02 14:07 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.6


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Weng Xuetian 2015-07-02 01:14:02 UTC
In KDE4, if there's an application blocks logout/shutdown, e.g. unsaved kwrite, plasma will still be there until real shutdown starts.
In Plasma 5, plasma will exit immediately when other application are still blocking the logout procedure. This might leave user a uneasy environment to do their pre-shutdown stuff. 

Reproducible: Always

Steps to Reproduce:
1. Open kwrite and edit some thing, don't save it.
2. Try to logout the system

Actual Results:  
Plasma closed and kwrite ask you about "save the unsaved documents"

Expected Results:  
Plasma doesn't close until you do something with kwrite dialog
Comment 1 Wolfgang Bauer 2016-02-20 14:51:51 UTC
This is actually no problem in ksmserver, but the general "Qt5 closing all windows on logout" issue (see bug#354724 and https://bugreports.qt.io/browse/QTBUG-49667).

Proposed fix for plasmashell:
https://git.reviewboard.kde.org/r/127125/
(requires Qt 5.6.0)
Comment 2 Wolfgang Bauer 2016-02-22 11:57:33 UTC
The fix has been submitted to master:
https://quickgit.kde.org/?p=plasma-workspace.git&a=commitdiff&h=b5e814a7b2867914327c889794b1088027aaafd6&hp=724bd005b9b3ae0300fdae40483effcd02c192b3

So this should work in Plasma 5.6 when compiled against Qt 5.6.
Comment 3 Wolfgang Bauer 2016-03-02 14:07:04 UTC
*** Bug 337182 has been marked as a duplicate of this bug. ***