Bug 348944 - a zip of mp3's from dropbox are corrupted when unzipped by ark
Summary: a zip of mp3's from dropbox are corrupted when unzipped by ark
Status: RESOLVED DUPLICATE of bug 348357
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: 2.19
Platform: Kubuntu Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-09 23:34 UTC by Gus Gustafson
Modified: 2016-02-09 23:49 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Zip from Dropbox (405.04 KB, application/zip)
2015-06-16 15:11 UTC, jeremy9856
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gus Gustafson 2015-06-09 23:34:44 UTC
If you go to Dropbox and select multiple MP3 files, Dropbox will allow you to download them as a zip file. When extracting these MP3's with Ark, the MP3's appear to be corrupted. They are not playable by VLC nor Amarok, and cannot be parsed by Audacity. Note that I do have the necessary packages for playing MP3s already installed, and mp3s that I already had on my computer play just fine.
(Note that this is a zip CREATED BY DROPBOX. It is not a zip that I create, then upload to dropbox, then download again.)

Reproducible: Always

Steps to Reproduce:
1. download a zip that Dropbox.com creates from multiple MP3 files
2. extract MP3s with Ark
3. try to play in any audio software

Actual Results:  
MP3 are corrupted / cannot be played

Expected Results:  
files should play

The same zip, when extracted by various archive utilities in Windows 8.1, produces playable files, so this appears to be an Ark-specific issue.
Also, I have had this problem for a long time now, perhaps more than 2 years, perhaps less--can't remember exactly.
Comment 1 Ragnar Thomsen 2015-06-10 07:24:32 UTC
Can you upload a Zip file that this happens for here?
Comment 2 Raphael Kubo da Costa 2015-06-10 08:27:34 UTC
Yes, that would be really helpful, especially since you mention this has happened for a long time. My guess is that it doesn't even have to be MP3s, but anything else you have stored on Dropbox that can be zipped.
Comment 3 jeremy9856 2015-06-16 15:11:49 UTC
Created attachment 93198 [details]
Zip from Dropbox

This is a Zip created by Dropbox that contain 2 wallpapers (.jpg)
If you extract it with Ark the wallpapers are corrupted. With file-roller there is no problem.
Comment 4 Ragnar Thomsen 2015-06-17 19:48:10 UTC
I can't reproduce this. I suspect this is caused by Kubuntu using the libarchive plugin for zip archives.
Comment 5 Ragnar Thomsen 2015-06-17 19:52:51 UTC
Can you try modifying the file: /usr/share/kde4/services/kerfuffle_clizip.desktop

Change the line:
MimeType=application/x-java-archive;
to
MimeType=application/x-java-archive;application/zip;

Then run (from a terminal): kbuildsycoca4 --noincremental
and try extracting the file again.
Comment 6 jeremy9856 2015-06-17 20:03:08 UTC
That works !

About the use of libarchive plugin, kubuntu use it because of these problems :
https://bugs.kde.org/show_bug.cgi?id=319712
https://bugs.kde.org/show_bug.cgi?id=35371
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=723963

A bug report is opened on launchpad to avoid the use of libarchive plugin (https://bugs.launchpad.net/ubuntu/+source/ark/+bug/1404239) but maybe the proper solution is to "fix" these problems in ark directly ?

The use of Ark on kubuntu is "dangerous" because that can lead to data loss (zip from dropbox corrupted if extracted with ark, dummy file extracted if the archive is password protected, etc...). To avoid this I use file-roller until these problems are fixed.
Comment 7 Christoph Feck 2015-07-28 09:06:20 UTC

*** This bug has been marked as a duplicate of bug 348357 ***
Comment 8 noric 2016-02-09 23:49:56 UTC
Comment #5 works in Mint 17 KDE (= Kubuntu 14.04).