Bug 319712 - Turkish specific letters problem
Summary: Turkish specific letters problem
Status: RESOLVED DUPLICATE of bug 240727
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: 2.19
Platform: Ubuntu Linux
: NOR major with 20 votes (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-12 10:19 UTC by Fatih Yazıcı
Modified: 2015-10-03 15:57 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
ark does not support Turkish characters. Fails to extract... (217 bytes, application/zip)
2013-11-12 15:39 UTC, Serkan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fatih Yazıcı 2013-05-12 10:19:05 UTC
Ark cannot extract archives named with Turkish specific characters (for example 'ö').
Archive contents is ok. But previewing files or extracting them not working...

Reproducible: Always

Steps to Reproduce:
1. Try to extract an archive that has Turkish-Specific characters or preview its files.
Actual Results:  
Cannot extract.

Expected Results:  
Successful extraction of archive.

I tried a ZIP archive.
Comment 1 Serkan 2013-11-12 15:39:32 UTC
Created attachment 83520 [details]
ark does not support Turkish characters. Fails to extract...
Comment 2 Serkan 2013-11-12 15:47:59 UTC
When I try to open some files compressed with the ark, 
the file names do not appear correctly. I can not see the contents of the file also I can not delete this file. It is a seriously problem.

For example;

example_ş_ı_ğ_İ_ö_Ö_ü_Ü_Ş_Ğ_I     to      example_+�_-�_-�_-�_+�_+�_++_+�_+�_-�_I

-- System Information:
Debian Release: wheezy, jessie
Architecture: amd64
Comment 3 Christoph Feck 2013-11-19 23:12:18 UTC
Serkan, KDE 4.11 and UTF-8 locale and file system?
Comment 4 Maximiliano Curia 2014-02-27 10:51:26 UTC
Hi.

The "issue" is that the zip header doesn't contain the encoding information (please correct me if I'm wrong), and while the use of libarchive by ark or the p7zip commands do decode the filenames zipinfo and friends don't.

So, a very simple fix for this is to use libarchive to handle zip files, instead of the zip command line tools.

This doesn't even require recompiling, just editing the kerfuffle_clizip.desktop and kerfuffle_libarchive.desktop files, and removing application/zip from the first to add it to the second.

Also, kerfuffle_cli7z.desktop could handle the application/zip, but that is more seldomly available.
Comment 5 jeremy9856 2015-06-11 19:43:22 UTC
The use of libarchive cause problems with password protected zip files. 
Ark don't ask for password and extract a "dummy" file

https://bugs.launchpad.net/ubuntu/+source/ark/+bug/1404239
Comment 6 jeremy9856 2015-07-05 10:27:57 UTC
The use of Ark on Kubuntu is "dangerous" and can lead to data loss (zip from dropbox corrupted if extracted with ark, dummy file extracted if the archive is password protected, etc...) because of the use of libarchive. 

This have to be fixed.
Comment 8 Elvis Angelaccio 2015-10-03 15:57:42 UTC

*** This bug has been marked as a duplicate of bug 240727 ***