Bug 347246 - Appear many repeated bookmaks; when I try delete or hide these repeated bookmarks, Dolphin do not works any more.
Summary: Appear many repeated bookmaks; when I try delete or hide these repeated book...
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: panels: places (show other bugs)
Version: 16.12.2
Platform: Kubuntu Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
: 347765 348368 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-05 16:42 UTC by Víctor
Modified: 2015-06-01 21:04 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Dolphin bug: repeated bookmarks in Places panel (128.86 KB, image/png)
2015-05-05 16:44 UTC, Víctor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Víctor 2015-05-05 16:42:41 UTC
After a uptade, appaers a Home and a Root bokmarks repeated in hte Places panel. Then I tried hide o delete these repeated bookmarks but Dolphin does not works, it has crashsed.

I open again Dolphin but now there are more repeated bookmarks, and if i repeat the mentionated action before, appear more repated bookmarks.

Reproducible: Always

Steps to Reproduce:
1. If you have repeated bookmarksin Places panel, try delete or hide them. Dolphin crashes.
2. Open again Dolphin and you will see that there are more repeated bokmarks.

Actual Results:  
You will see that there are more repeated bokmarks. Every that you try delete o hide then appears more.
Comment 1 Víctor 2015-05-05 16:44:42 UTC
Created attachment 92435 [details]
Dolphin bug: repeated bookmarks in Places panel
Comment 2 Emmanuel Pescosta 2015-05-05 18:41:37 UTC
Thanks for the bug report.

Can you please provide the version numbers of KIO, Dolphin and kdelibs?
Comment 3 Víctor 2015-05-05 18:57:41 UTC
Versions

KIO: 5.9.0-0ubuntu1.1
Dolphin: 4:15.04.0-0ubuntu1~ubuntu15.04~ppa1
kdelibs: 4:4.14.7-4~ubuntu15.04~ppa1
Comment 4 Frank Reininghaus 2015-05-15 15:08:51 UTC
*** Bug 347765 has been marked as a duplicate of this bug. ***
Comment 5 Oz 2015-05-15 17:11:52 UTC
happens the same to me after updated to KDE 5.3
The bug importance should change to major, as each time Dolphin opens take more time to load and freeze while loading
Comment 6 Oz 2015-05-15 21:00:17 UTC
I manually removed the duplicated bookmarks from 
~/.kde/share/apps/kfileplaces/bookmarks.xml
and as long I don't do any modification on places panel, doesn't appear any more duplicates.
but any operation on places panel like hide or delete or add, make appear duplicates again.
meanwhile, this helped me with the load when started.
Comment 7 Oz 2015-05-15 21:37:15 UTC
I noticed now that when places panel is edited, XML of new site is saved in file
~/.local/share/user-places.xbel
but when Dolphins opens read places data from
~/.kde/share/apps/kfileplaces/bookmarks.xml
I managed to create my bookmarks manually on bookmarks.xml files and works fine.
Hopes that helps t find the root problem
Comment 8 Oz 2015-05-15 21:58:01 UTC
Sorry, is the other way around

Saves on
~/.kde/share/apps/kfileplaces/bookmarks.xml
read when opens from
~/.local/share/user-places.xbel
Comment 9 Sven Eden 2015-05-18 08:59:18 UTC
Hi,

I can confirm this issue, but manually editing ".kde4/share/apps/kfileplaces/bookmarks.xml" only helps once. dolphin adds the four "Home", "Network", "Root", "Trash" entries on every start.

I have removed both "~/.local/share/user-places.xbel" and ".local/share/kfileplaces/bookmarks.xml" but this did not help.

When I started to edit the duplicates out of ".kde4/share/apps/kfileplaces/bookmarks.xml" it had almost 10k lines with dozens of duplicates of all sort of drives.

Note: I recently tried out KF 5.3, but moved back to KDE 4 (4.14.7, will update to 4.14.8 today.)
Comment 10 Simon 2015-05-28 00:07:54 UTC
I can also confirm the bug. I could hardly use dolphin before i removed the bookmarks.xml file. I also removed ~/.kde/share/config/dolphinrc and ~/.kde/share/apps/dolphin, but it didn't help.
And I have exactly the same versions of kde, kio and kdelibs as Victor.
Comment 11 Sven Eden 2015-05-28 12:26:05 UTC
Update: After updating to 4.14.8 the issue disappeared for me.
Comment 12 Frank Reininghaus 2015-05-28 17:38:47 UTC
*** Bug 348368 has been marked as a duplicate of this bug. ***
Comment 13 Emmanuel Pescosta 2015-05-28 17:57:22 UTC
This bug should be fixed with the following package versions: 
* kde-baseapps >= 15.04.1 
* kdelibs >= 4.14.8 
* KIO >= 5.10 (if you have KF5 installed)

@Sven: Can you confirm it? :)
Comment 14 Sven Eden 2015-05-29 11:15:20 UTC
@Emmanuel: I have the following packages installed, and dolphin no longer duplicates the basic bookmarks:

kdelibs-4.14.8
kio-4.14.3
dolphin-4.14.3

So the updates of kdelibs from 4.14.7 to 4.14.8 seems to be the fix for the problem.
Comment 15 Víctor 2015-06-01 21:04:09 UTC
The bug has been fixed with the update to Plasma 5.3.1. Thanks to the devs.