Bug 345095 - gwenview gets error after closing
Summary: gwenview gets error after closing
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-03-12 19:31 UTC by victorias1
Modified: 2015-03-12 21:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description victorias1 2015-03-12 19:31:44 UTC
Application: gwenview (4.14.0 pre)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.13.0-46-generic x86_64
Distribution: Ubuntu 14.04.2 LTS

-- Information about the crash:
That happens in all KDE apps. App just crashes after closing, but before closing it works fine.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f12406b7880 (LWP 10031))]

Thread 3 (Thread 0x7f122715b700 (LWP 10035)):
#0  0x00007f123d18612d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1239219fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f123921a0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f123f50c7be in QEventDispatcherGlib::processEvents (this=0x7f12200008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007f123f4de0af in QEventLoop::processEvents (this=this@entry=0x7f122715ad20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f123f4de3a5 in QEventLoop::exec (this=this@entry=0x7f122715ad20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f123f3dac5f in QThread::exec (this=this@entry=0x19fa160) at thread/qthread.cpp:537
#7  0x00007f123f4bf823 in QInotifyFileSystemWatcherEngine::run (this=0x19fa160) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f123f3dd32f in QThreadPrivate::start (arg=0x19fa160) at thread/qthread_unix.cpp:349
#9  0x00007f12396e5182 in start_thread (arg=0x7f122715b700) at pthread_create.c:312
#10 0x00007f123d19347d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f12261db700 (LWP 10036)):
#0  0x00007f123d18482d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1233498f45 in ?? () from /usr/lib/nvidia-340/tls/libnvidia-tls.so.340.76
#2  0x00007f123925ac10 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1239219b14 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1239219f7b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f123921a0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f123f50c7be in QEventDispatcherGlib::processEvents (this=0x7f12180008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#7  0x00007f123f4de0af in QEventLoop::processEvents (this=this@entry=0x7f12261dad20, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f123f4de3a5 in QEventLoop::exec (this=this@entry=0x7f12261dad20, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f123f3dac5f in QThread::exec (this=this@entry=0x1a29090) at thread/qthread.cpp:537
#10 0x00007f123f4bf823 in QInotifyFileSystemWatcherEngine::run (this=0x1a29090) at io/qfilesystemwatcher_inotify.cpp:265
#11 0x00007f123f3dd32f in QThreadPrivate::start (arg=0x1a29090) at thread/qthread_unix.cpp:349
#12 0x00007f12396e5182 in start_thread (arg=0x7f12261db700) at pthread_create.c:312
#13 0x00007f123d19347d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f12406b7880 (LWP 10031)):
[KCrash Handler]
#6  0x00007f123dfdf8c9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1d30500, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007f123dfdf949 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1d30500, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007f123dff7c5c in QWidgetBackingStore::~QWidgetBackingStore (this=0x1a271a0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007f123de30009 in QWidgetBackingStoreTracker::destroy (this=0x1f8a150) at kernel/qwidget.cpp:225
#10 0x00007f123de301a9 in QWidgetPrivate::deleteExtra (this=this@entry=0x1d86980) at kernel/qwidget.cpp:1833
#11 0x00007f123de303bd in QWidgetPrivate::~QWidgetPrivate (this=0x1d86980, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#12 0x00007f123de30649 in QWidgetPrivate::~QWidgetPrivate (this=0x1d86980, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#13 0x00007f123f4f8735 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x1d866b8, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x1d866b0, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#16 0x00007f123de38dcc in QWidget::~QWidget (this=0x1d866b0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#17 0x00007f123de39049 in QWidget::~QWidget (this=0x1d866b0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1703
#18 0x00007f123e388995 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7f123e8d51a0 <_ZZL21globalStyleInfoWidgetvE7cleanup>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1960
#19 0x00007f123d0d5259 in __run_exit_handlers (status=0, listp=0x7f123d4576c8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#20 0x00007f123d0d52a5 in __GI_exit (status=<optimized out>) at exit.c:104
#21 0x00007f123d0baecc in __libc_start_main (main=0x427580 <main(int, char**)>, argc=6, argv=0x7fffc7411298, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffc7411288) at libc-start.c:321
#22 0x0000000000427b22 in _start ()

Possible duplicates by query: bug 344049, bug 344044, bug 343148, bug 341464.

Reported using DrKonqi
Comment 1 Christoph Feck 2015-03-12 21:32:36 UTC

*** This bug has been marked as a duplicate of bug 261539 ***