Bug 344180 - Allow separate set of widgets for Dashboard
Summary: Allow separate set of widgets for Dashboard
Status: CLOSED INTENTIONAL
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Desktop Dashboard (show other bugs)
Version: 5.2.0
Platform: Fedora RPMs Linux
: NOR wishlist
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
: 346172 348346 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-15 04:41 UTC by SP
Modified: 2018-04-02 17:45 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Old "Make Plasmoids Unique" to Dashboard Setting (46.03 KB, image/jpeg)
2015-08-15 16:50 UTC, electricprism
Details
attachment-7051-0.html (308 bytes, text/html)
2015-10-22 06:31 UTC, Brian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SP 2015-02-15 04:41:10 UTC
If Dashboard is enable and widgets are unlocked, the selected widgets are fixed to the desktop - not the Dashboard.  Close the Dashboard and the widgets remain on the desktop.  This was never the case in KDE4*

Reproducible: Always
Comment 1 Bhushan Shah 2015-02-16 10:18:16 UTC
Umm, I can not reproduce this..

1) unlock all widgets
2) open dashboard?
3) try to add widgets
4) they are shown for me..

whats bug?
Comment 2 Kai Uwe Broulik 2015-02-16 20:15:33 UTC
You mean you want to have a separate set of widget for dashboard and desktop?
Comment 3 SP 2015-02-16 20:29:09 UTC
Bhushan,  Thank you for your response.  Are you using Plasma 5.2?  I have had no problems with adding widgets to the Dashboard in KDE 4.  
This is what happens with my installation of Plasma 5.2:
1.  Show Dashboard
2.  Unlock Widgets
3.  Drag widget to Dashboard
3.  Hide Dashboard
4.  The widget remains on the desktop
5.  Expected result:  The widgets that have been added to the Dashboard should be hidden with the Dashboard and not remain on the main desktop.

Perhaps I am missing something or the method to add widgets to the Dashboard have changed?
Comment 4 SP 2015-02-16 20:30:12 UTC
Kai - Yes, of course.
Comment 5 Kai Uwe Broulik 2015-02-17 10:28:39 UTC
Thanks for your reply, I changed the bug title for clarification
Comment 6 SP 2015-02-17 18:06:53 UTC
Here is the problem.  I have been using Dashboard to display a collection of widgets for so long I had forgotten where to configure it.  In KDE4 it is under System Settings/Workspace Behavior/Workspace where there are the following configurable options:  "Workspace Type"; "Dashboard"; "Show Informational Tips".  My normal preference is to select "Desktop" as the Workspace Type and "Show an Independent Widget set" for the Dashboard.
In my installation of Plasma 5.2, Workspace Behavior has been moved to "Desktop Behavior" and under "Workspace" it has only one configurable option: "Show Informational Tips".  
The other two options are missing - unless they have been moved to another location (which I cannot find).  So this is a bug, it would seem.
I suggest that it would be a lot simpler to provide configurable options for the Dashboard under its icon on the Desktop - rather than in System Settings alone.
Comment 7 Bhushan Shah 2015-02-17 18:10:45 UTC
Umm no this configuration options are not available at moment, dashboard only uses Desktop applets
Comment 8 SP 2015-02-17 18:42:31 UTC
OK - I guess it is still early days for Plasma 5.  The best is yet to come;)
Comment 9 Brian 2015-04-09 15:53:32 UTC
This is an issue for me, too.  I miss the old behaviour that allows independent widget sets for the desktop and dashboard.  It really helps to not have the visual clutter of (most) widgets during normal desktop usage, but to still have a quick set of commonly-used widgets available via the dashboard.
Comment 10 Brian 2015-04-09 15:58:53 UTC
To be clear, this is a request to reinstate a feature which already exists in Plasma 4, but is currently absent in Plasma 5.
Comment 11 Bhushan Shah 2015-04-14 14:50:38 UTC
*** Bug 346172 has been marked as a duplicate of this bug. ***
Comment 12 Janet 2015-05-10 14:39:03 UTC
I hope this feature will come back soon, together with the different widgets and wallpapers per virtual desktop and the screensavers ;).
Comment 13 Jean-Christophe Baptiste 2015-05-30 08:33:25 UTC
Same issue, very disappointed to see such regressions (among many others, so many that I feel discouraged to report them).

So until it's fixed, I haved stopped using any widgets...
Comment 14 David Edmundson 2015-05-31 19:05:14 UTC
*** Bug 348346 has been marked as a duplicate of this bug. ***
Comment 15 Shmerl 2015-08-03 00:16:36 UTC
I also used separate widgets in Dashboard and now with migration of Debian testing to Plasma 5 this feature is lost.

To be clear, is this functionality missing now in Plasma 5 altogether, or it's simply missing configuration in the System Settings? Can it be set manually in some config files?
Comment 16 electricprism 2015-08-15 16:50:50 UTC
Created attachment 94046 [details]
Old "Make Plasmoids Unique" to Dashboard Setting
Comment 17 Thomas Pfeiffer 2015-10-15 14:58:27 UTC
Even though this is no technical bug, I'll confirm it anyway because it contains two things: A request to bring back a feature from Plasma 4 and a usability problem with what we did in Plasma 5

The feature request is: People want an actual dashboard. A dashboard is the thing that e.g. Mac OS X has: A separate layer with its own set of widgets that are only shown as long as the dashboard is shown. This, and only this, is a dashboard.

Plasma 5 currently does not have such a dashboard, plain and simple. Yet we have an entry in the desktop menu called "Show Dashboard", which in fact shows the desktop, not a dashboard. This is confusing. I've therefore opened a bug 353928 to rename that menu entry.
This does not satisfy users who want an actual dashboard, but until we have that (and I think it would be a very useful feature!) we have to communicate clearly what that menu entry does.
Comment 18 SP 2015-10-15 20:10:24 UTC
Thank you, Thomas.
Comment 19 Martin Flöser 2015-10-18 11:12:25 UTC
As people complain loudly in the Internet about this "bug" and that it's not even confirmed (which it is now, thanks to Thomas), I'm going to do what needs to be done. Sorry, the separate dashboard mode is gone and won't come back. It's merged together with show desktop and that won't be changed any more. Technically it's very challenging to get the "separate dashboard" to work correctly and we think for the overall quality of the whole product it's better to not have this special mode any more. The old implementation had lots of quirks and lots of bugs. There is no point in denying that. It just didn't really work.

That said we also improved the experience for show desktop to help make this work better as a replacement for the dashboard mode.

The references to show dashboard needs to be removed of course, but each of these cases is a bug.
Comment 20 Thomas Pfeiffer 2015-10-18 21:53:16 UTC
Thank you for the clarification, Martin! It's a bit of a pity that it's technically impossible to provide such a feature properly, but better not at all then in a broken way.
And WONTFIX is a much more useful status than UNCONFIRMED :)
Comment 21 Brian 2015-10-22 06:31:29 UTC
Created attachment 95078 [details]
attachment-7051-0.html

Well, for the record, that's disappointing.  ..but then again, I'm not
deeply involved in the project, and don't have much of a say one way or the
other as i'm not the one that's dealing with the technical hurdles
involved.  Thanks for communicating the wontfix status.
Comment 22 SP 2015-10-22 20:09:37 UTC
Yes - While I understand their may be technical difficulties and this is probably not a priority at this point in time - the Dashboard applet allowing a separate set of widget was definitely a useful enhancement to KDE4.  I hope that someone may be inclined to rebirth it in the future.  This and so many other missing components have kept me upgrading my main desktop to FC22 and Plasma 5 - though I will have to relent soon as FC23 is about to be released and the updates for FC21 will end.
Comment 23 schwarzwelle 2016-02-05 12:42:15 UTC
Sorry for the late entrance to the discussion.
In my opinion, I'm quite sure that the original dashboard was difficult to make, but I'm thinking maybe a containment plasmoid which a) has a hidden icon and b) allows for free placement of other plasmoids inside it would be a great compromise. Since it's a plasmoid, a pre-assigned shortcut to it could be made, and could perhaps be activated by dragging it into the desktop like a regular plasmoid. Some details in the implementation need to be tuned, though.

Also, I saw the new Application Dashboard, which looks like basically the old dashboard, but with the start menu items on it. Maybe this could be modified to add the "canvas" and the menu of which I spoke about in the first paragraph?
Comment 24 Thomas Platzer 2018-03-21 16:13:21 UTC
@Martin Flöser 

Only the heavens know how much I'd like to flame you to hell and back for your arrogance. If it's any consolation I'd extend the courtesy to the rest of the guys who decide things in KDE/Plasma/whatever.
I *love* this project but *hate* the decisions of the steering commitee or whatever.

Let me summarize, since I was recently forced to upgrade from 14.04 to 16.04:

* Lost the ability to tab windows (this was huge for me)
* Lost the ability for dashboard (loved this feature)
* Lost lots of plasma-applets that where actually useful like switching desktop resolution WITHOUT the taskbar rioting. 
* Plasmoid "Regression": Compare network-monitor and cpu-monitor with the Plasma-4 version and weep
* Stability issues (random hangs)

What have I gained:
* If viewed favorably: a new skin. Breeze.
* If not: a whole lot of nothing.
* I like the new Application Menu tough

Dashboard is to complicated? A feature that worked in the last iteration? (Never saw any of the bugs you spoke of). So you level-up the framework to gain more possibilities (I presume), but can't replicate features of the old version? I mean it when I ask: Aren't you ashamed as devs?

Whenever KDE arrives at a stable version you guys start anew and the next years your users are demoted to beta-testers all over again. Do you get any money from somewhere to actively boycott the project? From where I sit it surely looks that way, considering that the tech-base with Qt is vastly superior to GTK and Gnome. There should be no rational reason to not be the best desktop environment in town... if it weren't for your management decisions.

But I guess the "tone" of this post will result in no answers or dismissive ones. I'm all for cutting devs some slack but what has transpired the last years is a horrendous mess. You actually have users, you know. Like people who use your product to work. Yet you sh*t all over them again and again.
Comment 25 Christoph Feck 2018-03-21 17:15:30 UTC
Plasma was well received since the Plasma 5.8 releases. In fact, many people using Gnome previously either came back to Plasma, or switched to Plasma the first time. But yes, we cannot please everyone, and I hope you swich away from Plasma, because developers really are not interested to hear rants the style you wrote.
Comment 26 Thomas Platzer 2018-03-21 18:18:38 UTC
(In reply to Christoph Feck from comment #25)
> Plasma was well received since the Plasma 5.8 releases. In fact, many people
> using Gnome previously either came back to Plasma, or switched to Plasma the
> first time. But yes, we cannot please everyone, and I hope you swich away
> from Plasma, because developers really are not interested to hear rants the
> style you wrote.

Yeah, a rant were I explicitly stated that I *love* KDE. I'm using it for decades now, with an interruption when 4 was just released and it was pretty unusable for the first couple of versions.

Was there anything objectively wrong with what I wrote?

I really wonder what it is with German projects (wikipedia-de being another example) and the way they respond to user criticism. You know, when your first couple of messages are ignored, and this goes on for years, the tone tends to shift. It's frustration, pure and simple.

It's invariably a German developer that comes in and lays down the law like "This feature is gone and won't come back. We have decided that you don't need this feature. Be silent from now on, case closed." I don't say that you have to coddle users either, if somebody comments in a rude manner, it's perfectly acceptable to respond in kind. But damn it, address the issues at least. This "wah wah wah you are not nice enough, get lost" is getting old.

I'm aware that bug-trackers are not the place for this kind of more general comment, but then again, is there any forum where the direction of KDE/Plasma is discussed and people can vent their frustrations? Maybe that's the reason why there are such bizarre decisions as regarding the overall direction of the project if those in charge are only surrounded by yay-sayers. Just a case in point: when Qt6 comes around, will KDE/Plasma start this whole spiel again? *Years* of unstable releases until feature-parity is reached again, with some odd features that differentiated Plasma dropped yet again?

If you really think that I write this rather long comments just because I want to disparage devs or ridicule Plasma, you are sadly mistaken.
Comment 27 SP 2018-04-02 17:08:51 UTC
Goodness, surprised to see this "bug" report revived after all these years.  After so many upgrades I had quite forgotten about the dashboard - which would now seem inappropriate.  Current Plasma is beautiful and fast - at least in my configuration.  That is what is great about Plasma - it is highly configurable to the user's needs and taste.
Comment 28 SP 2018-04-02 17:27:41 UTC
@Thomas Platzer You are still using KDE4???  That's two years out of date! Kde Applications 16.04 was released April 2016.  14.04 must have been pre December 2014.  Treat yourself to an upgrade to at least Fedora 27 and KDE Plasma 5.12.3 - Or wait until May for Fedora 28.