Bug 342938 - Background is a mess of white and gray patterns
Summary: Background is a mess of white and gray patterns
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.14.2
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 351878 400884 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-17 00:27 UTC by Albert Astals Cid
Modified: 2018-12-03 21:57 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.15.0


Attachments
The screenshot (206.83 KB, image/png)
2015-01-17 00:27 UTC, Albert Astals Cid
Details
The same issue is present in breeze dark, although less faint (210.83 KB, image/png)
2018-11-14 10:18 UTC, Jan Przybylak
Details
System Settings background, non-breeze (279.29 KB, image/png)
2018-12-03 17:49 UTC, austin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Astals Cid 2015-01-17 00:27:02 UTC
Created attachment 90464 [details]
The screenshot

The systemsettings background is not white, it has a mesh of grey and white. I'm attaching a screenshot.
Comment 1 Bhushan Shah 2015-02-08 16:37:16 UTC
I can confirm this
Comment 2 Marco Martin 2015-04-14 15:05:43 UTC
it has a slight gradient, and that pattern of grey and white is due to 24 bits not being enough to represent the gradient correctly
Comment 3 Christoph Feck 2015-09-03 11:15:30 UTC
*** Bug 351878 has been marked as a duplicate of this bug. ***
Comment 4 romuluspb 2015-09-07 17:35:03 UTC
dithering is the only solution to anyone without a 10 bits per channel monitor, it really become visible in low quality TN, well calibrated sRGB will show very slight changes, but still an 8 bit channels limitation present in majority of monitors...
Comment 5 Christoph Feck 2018-11-13 19:13:47 UTC
*** Bug 400884 has been marked as a duplicate of this bug. ***
Comment 6 Jan Przybylak 2018-11-14 10:18:59 UTC
Created attachment 116303 [details]
The same issue is present in breeze dark, although less faint

The bug is still present in 5.14.2.
I attached a screenshot to show what it looks like in breeze dark
Comment 7 Nate Graham 2018-11-19 02:33:23 UTC
Git commit ed4367d86a6324023ba17624b6731f861f68f173 by Nate Graham, on behalf of Jan Przybylak.
Committed on 19/11/2018 at 02:32.
Pushed by ngraham into branch 'master'.

Remove the background gradient from icon view

Summary:
The icon view showed a very faint gradient in the background. It looked weird, broken and not really like a gradient for some reason. I think it looks better now.
There are some screenshots attached to the bug report.
FIXED-IN: 5.15.0

Reviewers: #vdg, ngraham

Reviewed By: #vdg, ngraham

Subscribers: ngraham, plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D16998

M  +0    -44   icons/CategoryDrawer.cpp

https://commits.kde.org/systemsettings/ed4367d86a6324023ba17624b6731f861f68f173
Comment 8 austin 2018-12-03 17:49:03 UTC
Created attachment 116657 [details]
System Settings background, non-breeze

I know this bug is marked resolved / fixed, but just wanted to point out that this function *can* look nice and add a touch of class when used with different color schemes, for example the attached custom QtCurve / color combo
Comment 9 Christoph Feck 2018-12-03 21:57:35 UTC
... and the screen shot in comment #8 still shows a vertical lines pattern because Qt doesn't use dithering in gradients. If you don't see it, you are lucky. Either bad sight, or bad display :)