Bug 341268 - Digikam freeze each time I select a photograph in a collection
Summary: Digikam freeze each time I select a photograph in a collection
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Files (show other bugs)
Version: 4.5.0
Platform: Microsoft Windows Microsoft Windows
: NOR grave (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-25 21:01 UTC by Pascal
Modified: 2018-08-30 14:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pascal 2014-11-25 21:01:27 UTC
The problem appears after I filled information about description, tags and geolocation for approximately 30 photographs. I have to kill and restart Digikam. Much more information is available in "Steps to Reproduce" below.

Reproducible: Always

Steps to Reproduce:
1. Open Digikam 4.5.0 in french language
2. Create a collection of thousands of raw and jpeg photographs taken with an EOS 5d camera (28200 .CR2 and .JPG files in my case)
3. Select a directory containing test photographs in this collection (250 .CR2 and .JPG files in my case)
4. Fill the following information for 29 .JPG files : captions (a description of each photograph), tags (one to three tags per photograph) and geolocations (e.g. 50.359584, 7.604821 using the Image/Geolocation menu)
5. Close Digikam
6. Run Digikam
7. Digikam freeze each time I select a JPG photograph. I have to restart the software.



I noticed that GPS information in the JPEG file Windows properties is not as expected. When I fill latitude 50.359584 and lontitude 7.604821. The GPS Windows properties are respectively "50; 21; 24.502340000006413" and "7; 36; 17.355599999999072". It could be the problem.

My configuration is 64 bits Windows 8.1 in french configuration.
Comment 1 caulier.gilles 2014-11-26 07:27:24 UTC
Please try to get a backtrace of digiKam using DebugView under Windows, as it's explained here :

https://techbase.kde.org/Development/Tutorials/Debugging/Debugging_on_MS_Windows

Gilles Caulier
Comment 2 Pascal 2014-11-26 20:24:43 UTC
Following you will find the trace :

00000001	0.00000000	[1108] rmt rpc_send_receive_server3: 0x1171338D96BC6BAE <- 0x1171338D0FD5664A	
00000002	0.00005192	[1108] 	
00000003	0.00017086	[1108] rmt rpc_send_receive_server called, obj 0x0419DEB8	
00000004	0.00021946	[1108] 	
00000005	0.00027078	[1108] rmt public objects: checked 0x0419DEB8 - exists	
00000006	0.00030821	[1108] 	
00000007	0.00214903	[6444] rmt rpc_send_receive_server3: 0x1171339DA391E51E <- 0x1171339D0FD5664B	
00000008	0.00221333	[6444] 	
00000009	0.00231989	[6444] rmt rpc_send_receive_server called, obj 0x0237DEB8	
00000010	0.00235642	[6444] 	
00000011	0.00241528	[6444] rmt public objects: checked 0x0237DEB8 - exists	
00000012	0.00244879	[6444] 	
00000013	0.00454982	[2820] rmt rpc_send_receive_server3: 0x117133AC9F5A058E <- 0x117133AC0FD5664C	
00000014	0.00461201	[2820] 	
00000015	0.00471918	[2820] rmt rpc_send_receive_server called, obj 0x0495DE58	
00000016	0.00475540	[2820] 	
00000017	0.00481638	[2820] rmt public objects: checked 0x0495DE58 - exists	
00000018	0.00492686	[2820] 	
00000019	0.08956683	[5996] SHIMVIEW: ShimInfo(Complete) 	
00000020	0.41920877	[8008] QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.	
00000021	0.51452506	[3032] SHIMVIEW: ShimInfo(Complete) 	
00000022	0.58024395	[4736] digikam(4736)/phonon (KDE plugin): Can not create backend object from factory for  "VLC" ,  "phonon_vlc" :	
00000023	0.58024395	[4736]  "Could not find plugin 'VLC' for application 'digikam'" 	
00000024	0.58119184	[4736] WARNING: bool __thiscall Phonon::FactoryPrivate::createBackend(void) phonon backend plugin could not be loaded 	
00000025	0.58280772	[4736] digikam(4736)/phonon (KDE plugin): Can not create backend object from factory for  "VLC" ,  "phonon_vlc" :	
00000026	0.58280772	[4736]  "Could not find plugin 'VLC' for application 'digikam'" 	
00000027	0.58380663	[4736] WARNING: bool __thiscall Phonon::FactoryPrivate::createBackend(void) phonon backend plugin could not be loaded 	
00000028	0.97260416	[3152] SHIMVIEW: ShimInfo(Complete) 	
00000029	1.01703072	[4736] digikam(4736)/phonon (KDE plugin): Can not create backend object from factory for  "VLC" ,  "phonon_vlc" :	
00000030	1.01703072	[4736]  "Could not find plugin 'VLC' for application 'digikam'" 	
00000031	1.01787841	[4736] WARNING: bool __thiscall Phonon::FactoryPrivate::createBackend(void) phonon backend plugin could not be loaded 	
00000032	1.01930380	[4736] digikam(4736)/phonon (KDE plugin): Can not create backend object from factory for  "VLC" ,  "phonon_vlc" :	
00000033	1.01930380	[4736]  "Could not find plugin 'VLC' for application 'digikam'" 	
00000034	1.02011800	[4736] WARNING: bool __thiscall Phonon::FactoryPrivate::createBackend(void) phonon backend plugin could not be loaded 	
00000035	1.02159965	[4736] digikam(4736)/phonon (KDE plugin): Can not create backend object from factory for  "VLC" ,  "phonon_vlc" :	
00000036	1.02159965	[4736]  "Could not find plugin 'VLC' for application 'digikam'" 	
00000037	1.02248859	[4736] WARNING: bool __thiscall Phonon::FactoryPrivate::createBackend(void) phonon backend plugin could not be loaded 	
00000038	1.02253866	[4736] WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ). 	
00000039	1.02404118	[4736] digikam(4736)/phonon (KDE plugin): Can not create backend object from factory for  "VLC" ,  "phonon_vlc" :	
00000040	1.02404118	[4736]  "Could not find plugin 'VLC' for application 'digikam'" 	
00000041	1.02492535	[4736] WARNING: bool __thiscall Phonon::FactoryPrivate::createBackend(void) phonon backend plugin could not be loaded 	
00000042	1.02497971	[4736] WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::VideoWidget ( no objectName ). 	
00000043	1.02649200	[4736] digikam(4736)/phonon (KDE plugin): Can not create backend object from factory for  "VLC" ,  "phonon_vlc" :	
00000044	1.02649200	[4736]  "Could not find plugin 'VLC' for application 'digikam'" 	
00000045	1.02733278	[4736] WARNING: bool __thiscall Phonon::FactoryPrivate::createBackend(void) phonon backend plugin could not be loaded 	
00000046	2.05897331	[4180] SHIMVIEW: ShimInfo(Complete) 	
00000047	2.17447186	[4524] SHIMVIEW: ShimInfo(Complete) 	
00000048	2.20382333	[7528] SHIMVIEW: ShimInfo(Complete)
Comment 3 caulier.gilles 2014-11-26 22:20:14 UTC

*** This bug has been marked as a duplicate of bug 340139 ***
Comment 4 caulier.gilles 2018-08-30 14:06:25 UTC
Not reproducible with 6.0.0