Bug 340139 - digiKam hangs after selecting folder with pictures
Summary: digiKam hangs after selecting folder with pictures
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Preview-Image (show other bugs)
Version: 4.5.0
Platform: Microsoft Windows Microsoft Windows
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-20 00:00 UTC by Miroslav
Modified: 2020-08-26 03:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.0


Attachments
DigKAM Log.LOG (3.66 KB, application/octet-stream)
2014-10-20 15:47 UTC, Miroslav
Details
attachment-1943-0.html (142 bytes, text/html)
2014-10-21 18:14 UTC, Miroslav
Details
attachment-6756-0.html (1023 bytes, text/html)
2014-12-02 22:16 UTC, Miroslav
Details
attachment-9001-0.html (2.38 KB, text/html)
2015-01-02 08:48 UTC, Miroslav
Details
attachment-10058-0.html (1.41 KB, text/html)
2015-03-31 22:35 UTC, Miroslav
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miroslav 2014-10-20 00:00:27 UTC
Hi all,

after startup of Digikam, when selecting folder which contains pictures it just hangs and stay in that condition. No mather if folder contains .jpg or RAW formats.

Does anyone have same situation? Any sugestion?

Br,
Miroslav

Reproducible: Always

Steps to Reproduce:
1. Run digikam
2. point to folder with pictures
3.

Actual Results:  
hangs

Expected Results:  
-

In the beggining it was working OK, but after some tasks in queue manager (renaming of some files) it start to happen described behavour.
Comment 1 caulier.gilles 2014-10-20 04:17:32 UTC
We need a debug trace of operations processus done in background. Look how to get this trace to this page :

https://www.digikam.org/contrib
Comment 2 Miroslav 2014-10-20 15:47:20 UTC
Created attachment 89216 [details]
DigKAM Log.LOG

Hi,

please find in attachment.

Br,
Miroslav

On Mon, Oct 20, 2014 at 6:17 AM, Gilles Caulier <caulier.gilles@gmail.com>
wrote:

> https://bugs.kde.org/show_bug.cgi?id=340139
>
> Gilles Caulier <caulier.gilles@gmail.com> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |RESOLVED
>                  CC|                            |caulier.gilles@gmail.com
>          Resolution|---                         |BACKTRACE
>
> --- Comment #1 from Gilles Caulier <caulier.gilles@gmail.com> ---
> We need a debug trace of operations processus done in background. Look how
> to
> get this trace to this page :
>
> https://www.digikam.org/contrib
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 3 caulier.gilles 2014-10-20 17:16:50 UTC
00000021	6.15802336	[1752] digikam(1752)/phonon (KDE plugin): Can not create backend object from factory for  "VLC" ,  "phonon_vlc" :	
00000022	6.15802336	[1752]  "Could not find plugin 'VLC' for application 'digikam'" 

It miss Phonon VLC component to get video thumbnails

Gilles Caulier
Comment 4 Miroslav 2014-10-21 18:14:30 UTC
Created attachment 89241 [details]
attachment-1943-0.html

Hi Gilles,
Thanks on your update. Do you have in mind posible workaround or maybe
solution?

Br, Miroslav
Comment 5 Miroslav 2014-10-28 21:16:08 UTC
Hi,
I have short update. Even I don't open DigiKAM application but only go to system configuration (from start button, all programs, digikam), and under system configuration click to multimedia (under hardware section) then system setings just frozes. I tried with diferent versions of Digikam. Always same situation.

Br,
Miroslav
Comment 6 Miroslav 2014-11-24 12:33:02 UTC
Hi all,
this weekend I upgraded to 4.5.0 version and problem still persists. I guess it is to implementation on my laptom. Do you have suggestion how to check which path application is looking for phonon backend? Also how to change that path?

Br,
Miroslav
Comment 7 caulier.gilles 2014-11-26 22:20:14 UTC
*** Bug 341268 has been marked as a duplicate of this bug. ***
Comment 8 Pascal 2014-12-02 22:01:26 UTC
Hi all,
Why this bug has a "RESOLVED BACKTRACE" status? It is not solved. Isn't it?
Regards
Comment 9 caulier.gilles 2014-12-02 22:04:31 UTC
We need more info in fact...

Gilles Caulier
Comment 10 Miroslav 2014-12-02 22:16:22 UTC
Created attachment 89815 [details]
attachment-6756-0.html

Hi all,

please send me what is needed. I'll send you.

Br,
Miroslav

On Tue, Dec 2, 2014 at 11:04 PM, Gilles Caulier <caulier.gilles@gmail.com>
wrote:

> https://bugs.kde.org/show_bug.cgi?id=340139
>
> --- Comment #9 from Gilles Caulier <caulier.gilles@gmail.com> ---
> We need more info in fact...
>
> Gilles Caulier
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 11 Pascal 2015-01-01 17:39:44 UTC
Hi all,

I think the problem is related to JPG pictures. I created four directories :
1) one containing CR2 (raw) and JPG files (containing tags or no tag)
2) one containing only CR2 files
3) one containing only JPG files (containing tags or no tag)
4) one containing only JPG files without tags

Digikam does not freeze with the directory containing only raw files. The program freeze with all directories containing JPG even if pictures contain tags or not.

Miroslav, do you notice the same problem? What is your camera?
My pictures are taken using a Canon EOS 5D camera.

Best regards
Comment 12 Miroslav 2015-01-02 08:48:45 UTC
Created attachment 90193 [details]
attachment-9001-0.html

Hi,

I checked. Actually to me it hangs also on RAW and JPEG format (NEF). I use
Nikon D7000 (RAW), Nikon Coolpix S5100 and smartphones for JPG.
I added collection on folder containing only RAW files. Nothing else, and
it hangs when I selected that collection.
Same is with folder with JPG.
What is very strange, in the beginning, it worked (with some older
version). I was doing some tagging of JPGs through batch manger and
soddenly it stoped to work. After that whatever I do, (deinstall, install
from scrach, remove collection and database, add them again ...) just same
situation, always hangs.
More interesting, I removed collection and database, and then go to:
start menu ->All Programs->Digikam 4.5.0->System Setings
and then under hardware click on Multimedia where I should be able to
configure Phonon, and then system setings hangs. I guess it is related to
same issue.

Br,
Miroslav

On Thu, Jan 1, 2015 at 6:39 PM, Pascal <pascal_auge@msn.com> wrote:

> https://bugs.kde.org/show_bug.cgi?id=340139
>
> --- Comment #11 from Pascal <pascal_auge@msn.com> ---
> Hi all,
>
> I think the problem is related to JPG pictures. I created four directories
> :
> 1) one containing CR2 (raw) and JPG files (containing tags or no tag)
> 2) one containing only CR2 files
> 3) one containing only JPG files (containing tags or no tag)
> 4) one containing only JPG files without tags
>
> Digikam does not freeze with the directory containing only raw files. The
> program freeze with all directories containing JPG even if pictures contain
> tags or not.
>
> Miroslav, do you notice the same problem? What is your camera?
> My pictures are taken using a Canon EOS 5D camera.
>
> Best regards
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 13 Pascal 2015-01-02 09:51:21 UTC
Hi,

Approximately the same for me. All was working with digiKam 4.5.0 in french configuration. The problem occurred after manually tagging and geolocating 8 JPG pictures. I used hierarchical tags like "continent/country/area/city".

After checking, I can view pictures in RAW folders but each time I want to see properties, tags, geolocation information and so on, it hangs.

Concerning phonon, I have the same problem when using KDE Release System Settings in Windows 8.1. When I click on "Multimedia" in "Hardware" section, the systemsettings.EXE program hangs and then crashes after 1 minute.

Best regards
Comment 14 Pascal 2015-03-28 11:27:45 UTC
Hi,

I tried the 4.6.0, 4.7.0 and 4.8.0 versions. The problem had not been solved.

I think this is related to the KDE cache and configuration. Following you will find a workaround that solved my problem.

Delete the following files and directories and restart digiKam:
C:\Users\<USER>\AppData\Roaming\.kde\cache*
C:\Users\<USER>\AppData\Roaming\.kde\share\config\digikam*
C:\Users\<USER>\AppData\Roaming\.kde\share\apps\digikam

I hope it will work your you.

Best regards
Comment 15 Miroslav 2015-03-31 22:35:09 UTC
Created attachment 91836 [details]
attachment-10058-0.html

Hi,

it looks that it helped to me also! Many thanks on your support!

Br, Miroslav

On Sat, Mar 28, 2015 at 12:27 PM, Pascal <pascal_auge@msn.com> wrote:

> https://bugs.kde.org/show_bug.cgi?id=340139
>
> --- Comment #14 from Pascal <pascal_auge@msn.com> ---
> Hi,
>
> I tried the 4.6.0, 4.7.0 and 4.8.0 versions. The problem had not been
> solved.
>
> I think this is related to the KDE cache and configuration. Following you
> will
> find a workaround that solved my problem.
>
> Delete the following files and directories and restart digiKam:
> C:\Users\<USER>\AppData\Roaming\.kde\cache*
> C:\Users\<USER>\AppData\Roaming\.kde\share\config\digikam*
> C:\Users\<USER>\AppData\Roaming\.kde\share\apps\digikam
>
> I hope it will work your you.
>
> Best regards
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 16 Pascal 2015-04-28 19:50:52 UTC
Hi,

The problem appears repeatedly even with version 4.9.0. The solution I have outlined is only a workaround. It fixes the problem temporarily and after several launches of digikam, the problem appears again and again. Digikam is not usable.

Miroslav, do you have the same problem?

Best regards