Bug 340699 - Plasma 5 Icon tasks and plasma 5 task manager issue
Summary: Plasma 5 Icon tasks and plasma 5 task manager issue
Status: RESOLVED WORKSFORME
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Icons-only Task Manager (show other bugs)
Version: 5.1.0
Platform: Kubuntu Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL: https://plus.google.com/+SEDur%C3%A1n...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-06 23:07 UTC by Sergio Durán
Modified: 2015-07-21 23:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
The mentioned bug in action (88.39 KB, image/png)
2014-11-06 23:09 UTC, Sergio Durán
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergio Durán 2014-11-06 23:07:21 UTC
Hello I have a very big issue here I have installed the Nitrux icon theme and after applying it the major part of the system has gotten the changes BUT that has not occurred with the icon tasks task manager and even the task switcher, the icons on this place looks chaotic because in some apps the icon is not correctlly displayed, for example some icons uses a hicolor icon, others uses Breeze and others uses Nitrux icons (see the image on the URL path) but the icons are correctlly applyed, also when I pin Google chrome to the icon tasks and close it when I try to open it again KDE shows me the unknown file type dialog (this one that is displayed every time when the user try to open some unsupported / unknown file) and this is so strange

Reproducible: Always

Steps to Reproduce:
1. Use icon tasks
2. Open an application
3. See wich icon it gets

Actual Results:  
the apps can get diferent icons

Expected Results:  
1.- Uniformity, make the task managers and switchers use the same icon theme on all the apps
2.- make the Google Chrome launcher working

I have use the major severity level because it is grave for me, I want see uniformity on every task manager and use the launcher of all the apps with not issues
Comment 1 Sergio Durán 2014-11-06 23:08:29 UTC
PS: pardon me by my bad English
Comment 2 Sergio Durán 2014-11-06 23:09:34 UTC
Created attachment 89484 [details]
The mentioned bug in action

As you can see this must be fixed as soon as possible
Comment 3 Eike Hein 2014-11-06 23:11:42 UTC
There can be two reasons for this:

1. Most likely the icon theme is simply not complete, and then the system is falling back to other themes.

2. In some cases (I think Chrome is an example, if I recall correctly) application windows don't supply an icon name, but an image. In that case the icon is not themable, it is always provided by the window.
Comment 4 Eike Hein 2014-11-06 23:13:19 UTC
For the Google Chrome launcher not working: I can reproduce this, but please file a separate ticket for it. One issue per ticket please! :)
Comment 5 Sergio Durán 2014-11-07 02:14:50 UTC
Ok, PS; Nitrux icons are complete, breeze not
Comment 6 Sergio Durán 2014-11-07 02:17:30 UTC
For example when the Tomahawk launcher is not open it shows a Nitrux icon but when it is opened it shows the hicolor icon, the same thing with other apps
Comment 7 Sergio Durán 2014-11-07 04:46:17 UTC
Chrome issue is related to the bug #340256
Task managers and switchers issue stills needing an urgent fix
Comment 8 Eike Hein 2014-11-07 10:43:50 UTC
Thanks, I missed bug 340256 because it was incorrectly not assigned to the Task Manager.

The Tomahawk issue is most likely similar to '2' in my explanation, which means there's nothing to fix about it from the Task Manager side. I'll have a closer look later, though.
Comment 9 Eike Hein 2014-11-07 15:27:51 UTC
Git commit 83c5c176567177f70458a0f2890570613b70ab07 by Eike Hein.
Committed on 07/11/2014 at 15:26.
Pushed by hein into branch 'master'.

Install taskmanagerrulesrc again and add a mapping for Google-chrome-stable.

Google Chrome Beta uses a WM_CLASS matching it's .desktop storage id but
the stable version does not.
Related: bug 340256

M  +2    -0    libtaskmanager/CMakeLists.txt
M  +1    -0    libtaskmanager/taskmanagerrulesrc

http://commits.kde.org/plasma-workspace/83c5c176567177f70458a0f2890570613b70ab07
Comment 10 Sergio Durán 2014-11-07 17:28:29 UTC
And what can I do?
Comment 11 Sergio Durán 2014-11-07 17:29:12 UTC
the Konsole has the same problem but with breeze icon, check my G+ attached URL for more info
Comment 12 Sergio Durán 2014-11-07 17:37:30 UTC
Ok, thanks the Google chrome icon now works but the issue with the icons continues, many of the icons uses breeze + hicolor (Chrome Konsole Tomahawk Steam etc,) and others has the correct Nitrux style
Comment 13 Ross Williams 2015-02-13 01:00:43 UTC
I am having the same issue with icons on certain apps only showing the correct icon from the theme when not running but showing an app assigned icon when running. In the Plasma 4 series this was fixed by enabling the "Show launcher icons" option in the task manager but there is no option for that yet in the Plasma 5 version of the widget. Is this planned to be implemented in the future or something I could hack on and submit a fix for 5.3.0?
Comment 14 Eike Hein 2015-02-13 15:53:26 UTC
^ Feel free to work on this for 5.3 -- try to keep me in the loop on your plans though so there's no wasted effort in case something won't work for some reason.
Comment 15 Eike Hein 2015-07-21 23:07:00 UTC
Comment #13 is addressed by the resolution to bug 348050.