Bug 340256 - Launchers not working for certain applications
Summary: Launchers not working for certain applications
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.1.0
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-23 12:43 UTC by Ruchir Brahmbhatt
Modified: 2014-11-07 15:27 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ruchir Brahmbhatt 2014-10-23 12:43:06 UTC
When I right click chrome icon/task in panel and select "show a launcher when not running", it creates launcher but when I try to launch application using it, it doesn't work as expected. It opens program selection dialog to select program to open that executable file. I tried few frequently used applications but chrome doesn't seem to work out of those. 

Reproducible: Always

Steps to Reproduce:
1. Open google chrome
2. Right click taskbar entry and select "Show A Launcher When Not Running".
3. Close chrome.
4. Click newly created launcher

Actual Results:  
Opens program selection dialog to open executable file. 

Expected Results:  
Application should launch
Comment 1 Ruchir Brahmbhatt 2014-10-23 13:01:46 UTC
I figured out the problem. When I launch chrome from krunner by hitting alt+f2 and then typing chrome and selecting chrome, it takes /opt/google/chrome/chrome as launcher path and it doesn't work. When I open chrome from Application Launcher and then pin it to panel, then it works because in that case it takes /usr/bin/google-chrome-stable as path.
Comment 2 Marco Martin 2014-10-24 10:58:41 UTC
so there are two copies of chrome installed which one is not working?
ifthat's the case this is not valid, since we can't know what is the working one ;)
Comment 3 Ruchir Brahmbhatt 2014-10-24 11:01:40 UTC
No just one copy is installed. But different file paths are detected when launched from krunner or application launcher.
Comment 4 David Edmundson 2014-10-24 11:02:28 UTC
What does it say as the group in krunner to the left of where you see chrome? Does it say "Applications" or "Command Line"
Comment 5 Ruchir Brahmbhatt 2014-10-24 11:18:22 UTC
It says "Applications"
Comment 6 Martin Klapetek 2014-10-24 16:25:54 UTC
Maybe related to bug 335877
Comment 7 Sergio Durán 2014-11-07 04:42:18 UTC
Related with the bug #340699
Comment 8 Eike Hein 2014-11-07 15:27:51 UTC
Git commit 83c5c176567177f70458a0f2890570613b70ab07 by Eike Hein.
Committed on 07/11/2014 at 15:26.
Pushed by hein into branch 'master'.

Install taskmanagerrulesrc again and add a mapping for Google-chrome-stable.

Google Chrome Beta uses a WM_CLASS matching it's .desktop storage id but
the stable version does not.
Related: bug 340699

M  +2    -0    libtaskmanager/CMakeLists.txt
M  +1    -0    libtaskmanager/taskmanagerrulesrc

http://commits.kde.org/plasma-workspace/83c5c176567177f70458a0f2890570613b70ab07