Bug 340649 - digiKam doesn't show thumbnails in preview on my Canon 450D (PTP)
Summary: digiKam doesn't show thumbnails in preview on my Canon 450D (PTP)
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Gphoto2 (show other bugs)
Version: 4.4.0
Platform: Debian unstable Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-04 21:16 UTC by boombaxer
Modified: 2021-04-04 09:42 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description boombaxer 2014-11-04 21:16:17 UTC
Digikam doesn't show thumbnails in preview on my Canon 450D (PTP).

I can see those messages in console:
digikam(4365)/digikam (core) Digikam::DigikamApp::checkSolidCamera: Solid returns unsupported driver handle for gphoto2
digikam(4365)/digikam (core) Digikam::ImportStackedView::syncSelection: one or both of the models are null?! from: Digikam::ImportIconView(0x76ef100) to: Digikam::ImportThumbnailBar(0x7722130)

gphoto2 grabs thumbnails without any problem:
gphoto2 --get-all-thumbnails
Downloading 'IMG_4081.JPG' from folder '/store_00020001/DCIM/100CANON'...      
Saving file as thumb_IMG_4081.jpg
Downloading 'IMG_4082.JPG' from folder '/store_00020001/DCIM/100CANON'...
Saving file as thumb_IMG_4082.jpg
Downloading 'IMG_4083.JPG' from folder '/store_00020001/DCIM/100CANON'...
Saving file as thumb_IMG_4083.jpg
Downloading 'IMG_4084.JPG' from folder '/store_00020001/DCIM/100CANON'...
Saving file as thumb_IMG_4084.jpg
Downloading 'IMG_4085.JPG' from folder '/store_00020001/DCIM/100CANON'...
Saving file as thumb_IMG_4085.jpg
Downloading 'IMG_4086.JPG' from folder '/store_00020001/DCIM/100CANON'...
Saving file as thumb_IMG_4086.jpg
Downloading 'IMG_4087.JPG' from folder '/store_00020001/DCIM/100CANON'...
Saving file as thumb_IMG_4087.jpg
Downloading 'IMG_4088.JPG' from folder '/store_00020001/DCIM/100CANON'...
Saving file as thumb_IMG_4088.jpg

gtkam shows thumbnails

I know libgphoto2 had the bug with thumbnails on PTP cameras but now I believe it is fixed and I have bug exactly with Digikam.

Reproducible: Always
Comment 1 Teemu Rytilahti 2014-11-15 16:52:04 UTC
Could you verify if the bug still exists with Digikam 4.5 (when that gets released)? This is probably a dupe of 338407.

*** This bug has been marked as a duplicate of bug 338407 ***
Comment 2 Alex Loes 2014-11-25 19:11:26 UTC
I have a Canon EOS400D and this problem still exists. The terminal shows:
digikam(6589)/digikam (core) Digikam::DigikamApp::checkSolidCamera: Solid returns unsupported driver handle for gphoto2 
digikam(6589)/digikam (core) Digikam::DigikamApp::checkSolidCamera: Solid returns unsupported driver handle for gphoto2 
digikam(6589)/digikam (core) Digikam::ImportStackedView::syncSelection: one or both of the models are null?! from: Digikam::ImportIconView(0xd8c4b50) to: Digikam::ImportThumbnailBar(0xd801910)
Comment 3 caulier.gilles 2021-04-04 09:41:51 UTC
Fixed with #338407