Bug 340559 - digikam crashed at start
Summary: digikam crashed at start
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: DImg-Plugins (show other bugs)
Version: 4.4.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-11-01 18:07 UTC by Pua Moders
Modified: 2022-02-05 22:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.2.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pua Moders 2014-11-01 18:07:29 UTC
Application: digikam (4.4.0)
KDE Platform Version: 4.14.2
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.40-default x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I started digikam on local disk and path and then digikam tried to open via smb a path after that digikam crashed.

I've renamed digikamrc and start without it and get a new one.
There comes a message:
Prozess kann nicht gestartet werden: Aufruf des Ein-/Ausgabemoduls nicht möglich. klauncher meldet: Fehler beim Laden von „kio_digikamalbums“ / dito "kio_digikamdates" and "kio_digikamtags" (I think so).

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Floating point exception
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7435bb9840 (LWP 14677))]

Thread 4 (Thread 0x7f74103d6700 (LWP 14678)):
#0  0x00007f74268dbaa1 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f742689ea99 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f742689ebc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f742f63ea36 in QEventDispatcherGlib::processEvents (this=0x7f74080008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f742f60e252 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f742f60e4a7 in QEventLoop::exec (this=0x7f74103d5cf0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f742f50c777 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007f742f5edcff in QInotifyFileSystemWatcherEngine::run (this=0x2e3c660) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f742f50f7dc in QThreadPrivate::start (arg=0x2e3c660) at thread/qthread_unix.cpp:338
#9  0x00007f742c69be0f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f742e7300dd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f740f256700 (LWP 14697)):
[KCrash Handler]
#6  0x00007f743010470c in read_dib_body (s=..., bi=..., offset=138, startpos=0, image=...) at image/qbmphandler.cpp:322
#7  0x00007f743010533a in QBmpHandler::read (this=0x7f7404076c50, image=0x7f740f254e00) at image/qbmphandler.cpp:770
#8  0x00007f74300dc038 in QImageReader::read (this=0x7f740f254e70, image=0x7f740f254e00) at image/qimagereader.cpp:1205
#9  0x00007f74300dc667 in QImageReader::read (this=0x7f740f254e70) at image/qimagereader.cpp:1155
#10 0x00007f74300d15fc in QImage::load (this=0x7f740f254f90, fileName=..., format=<optimized out>) at image/qimage.cpp:5094
#11 0x00007f74300d1795 in QImage::QImage (this=0x7f740f254f90, fileName=..., format=0x0) at image/qimage.cpp:995
#12 0x00007f74330dc149 in Digikam::QImageLoader::load (this=0x7f740f2552a0, filePath=..., observer=0x0) at /usr/src/debug/digikam-4.4.0/core/libs/dimg/loaders/qimageloader.cpp:55
#13 0x00007f74330afffc in Digikam::DImg::load (this=this@entry=0x7f740404d020, filePath=..., loadFlagsInt=loadFlagsInt@entry=1, observer=observer@entry=0x0, rawDecodingSettings=...) at /usr/src/debug/digikam-4.4.0/core/libs/dimg/dimg.cpp:558
#14 0x00007f74330b1725 in Digikam::DImg::loadImageInfo (this=0x7f740404d020, filePath=..., loadMetadata=<optimized out>, loadICCData=<optimized out>, loadUniqueHash=<optimized out>, loadImageHistory=<optimized out>) at /usr/src/debug/digikam-4.4.0/core/libs/dimg/dimg.cpp:370
#15 0x00007f7432c74a69 in Digikam::ImageScanner::loadFromDisk (this=this@entry=0x7f740f255660) at /usr/src/debug/digikam-4.4.0/core/libs/database/imagescanner.cpp:1529
#16 0x00007f7432c7b688 in Digikam::ImageScanner::newFile (this=0x7f740f255660, albumId=204384) at /usr/src/debug/digikam-4.4.0/core/libs/database/imagescanner.cpp:285
#17 0x00007f7432c1d19b in Digikam::CollectionScanner::scanNewFile (this=this@entry=0x7f740f255cd0, info=..., albumId=204384) at /usr/src/debug/digikam-4.4.0/core/libs/database/collectionscanner.cpp:1247
#18 0x00007f7432c1f8d1 in Digikam::CollectionScanner::scanAlbum (this=this@entry=0x7f740f255cd0, location=..., album=...) at /usr/src/debug/digikam-4.4.0/core/libs/database/collectionscanner.cpp:1089
#19 0x00007f7432c1f5b2 in Digikam::CollectionScanner::scanAlbum (this=this@entry=0x7f740f255cd0, location=..., album=...) at /usr/src/debug/digikam-4.4.0/core/libs/database/collectionscanner.cpp:1112
#20 0x00007f7432c200cb in Digikam::CollectionScanner::scanAlbumRoot (this=this@entry=0x7f740f255cd0, location=...) at /usr/src/debug/digikam-4.4.0/core/libs/database/collectionscanner.cpp:828
#21 0x00007f7432c20335 in Digikam::CollectionScanner::completeScan (this=0x7f740f255cd0) at /usr/src/debug/digikam-4.4.0/core/libs/database/collectionscanner.cpp:489
#22 0x0000000000600346 in Digikam::ScanController::run (this=0x3427410) at /usr/src/debug/digikam-4.4.0/core/app/database/scancontroller.cpp:756
#23 0x00007f742f50f7dc in QThreadPrivate::start (arg=0x3427410) at thread/qthread_unix.cpp:338
#24 0x00007f742c69be0f in start_thread () from /lib64/libpthread.so.0
#25 0x00007f742e7300dd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f740ea55700 (LWP 14726)):
#0  0x00007f742c69f964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f742f50fd4b in wait (time=18446744073709551615, this=0x2ab99c0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2a6b548, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f743327baf9 in Digikam::ParkingThread::run (this=0x2a6b530) at /usr/src/debug/digikam-4.4.0/core/libs/threads/threadmanager.cpp:119
#4  0x00007f742f50f7dc in QThreadPrivate::start (arg=0x2a6b530) at thread/qthread_unix.cpp:338
#5  0x00007f742c69be0f in start_thread () from /lib64/libpthread.so.0
#6  0x00007f742e7300dd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f7435bb9840 (LWP 14677)):
#0  0x00007f742e72717d in poll () from /lib64/libc.so.6
#1  0x00007f7423e19c62 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f7423e1a1bf in ?? () from /usr/lib64/libxcb.so.1
#3  0x00007f7423e1a244 in xcb_writev () from /usr/lib64/libxcb.so.1
#4  0x00007f742cc4733e in _XSend () from /usr/lib64/libX11.so.6
#5  0x00007f742cc47817 in _XReply () from /usr/lib64/libX11.so.6
#6  0x00007f742cc4335d in XSync () from /usr/lib64/libX11.so.6
#7  0x00007f7430212225 in syncX (this=0x2d11540) at painting/qwindowsurface_raster.cpp:134
#8  QRasterWindowSurface::syncX (this=0x2d11540) at painting/qwindowsurface_raster.cpp:130
#9  0x00007f74302126f1 in QRasterWindowSurface::beginPaint (this=0x2d11540, rgn=...) at painting/qwindowsurface_raster.cpp:143
#10 0x00007f743022f713 in QWidgetBackingStore::sync (this=0x2b75ef0) at painting/qbackingstore.cpp:1304
#11 0x00007f7430059300 in QWidgetPrivate::syncBackingStore (this=0x2b7b710) at kernel/qwidget.cpp:1896
#12 0x00007f74300671b6 in QWidget::event (this=0x2c29c60, event=0xdad5c10) at kernel/qwidget.cpp:8679
#13 0x00007f743043cf0b in QMainWindow::event (this=0x2c29c60, event=0xdad5c10) at widgets/qmainwindow.cpp:1478
#14 0x00007f7430e3d658 in KXmlGuiWindow::event (this=0x2c29c60, ev=0xdad5c10) at /usr/src/debug/kdelibs-4.14.2/kdeui/xmlgui/kxmlguiwindow.cpp:126
#15 0x00007f74300161e4 in notify_helper (e=0xdad5c10, receiver=0x2c29c60, this=0x29dd060) at kernel/qapplication.cpp:4562
#16 QApplicationPrivate::notify_helper (this=0x29dd060, receiver=0x2c29c60, e=0xdad5c10) at kernel/qapplication.cpp:4534
#17 0x00007f743001afb3 in QApplication::notify (this=0x7fffd8211da0, receiver=0x2c29c60, e=0xdad5c10) at kernel/qapplication.cpp:4423
#18 0x00007f7430d4b496 in KApplication::notify (this=0x7fffd8211da0, receiver=0x2c29c60, event=0xdad5c10) at /usr/src/debug/kdelibs-4.14.2/kdeui/kernel/kapplication.cpp:311
#19 0x00007f742f60f71c in QCoreApplication::notifyInternal (this=0x7fffd8211da0, receiver=0x2c29c60, event=0xdad5c10) at kernel/qcoreapplication.cpp:946
#20 0x00007f742f612fca in sendEvent (event=0xdad5c10, receiver=0x2c29c60) at kernel/qcoreapplication.h:231
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x29342a0) at kernel/qcoreapplication.cpp:1570
#22 0x00007f742f63e5a3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#23 postEventSourceDispatch (s=0x29df640) at kernel/qeventdispatcher_glib.cpp:279
#24 0x00007f742689e7d5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#25 0x00007f742689eb08 in ?? () from /usr/lib64/libglib-2.0.so.0
#26 0x00007f742689ebc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#27 0x00007f742f63e9cf in QEventDispatcherGlib::processEvents (this=0x2939b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#28 0x00007f74300b9abe in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007f742f60e252 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007f742f60e4a7 in QEventLoop::exec (this=0x32ff9c0, flags=...) at kernel/qeventloop.cpp:204
#31 0x00000000005fd18c in Digikam::ScanController::completeCollectionScanCore (this=0x3427410, needTotalFiles=<optimized out>, defer=false) at /usr/src/debug/digikam-4.4.0/core/app/database/scancontroller.cpp:486
#32 0x000000000052f627 in Digikam::NewItemsFinder::slotStart (this=0xe543cb0) at /usr/src/debug/digikam-4.4.0/core/utilities/maintenance/newitemsfinder.cpp:112
#33 0x00007f742f628946 in QObject::event (this=0xe543cb0, e=<optimized out>) at kernel/qobject.cpp:1203
#34 0x00007f74300161e4 in notify_helper (e=0xe543c00, receiver=0xe543cb0, this=0x29dd060) at kernel/qapplication.cpp:4562
#35 QApplicationPrivate::notify_helper (this=0x29dd060, receiver=0xe543cb0, e=0xe543c00) at kernel/qapplication.cpp:4534
#36 0x00007f743001afb3 in QApplication::notify (this=0x7fffd8211da0, receiver=0xe543cb0, e=0xe543c00) at kernel/qapplication.cpp:4423
#37 0x00007f7430d4b496 in KApplication::notify (this=0x7fffd8211da0, receiver=0xe543cb0, event=0xe543c00) at /usr/src/debug/kdelibs-4.14.2/kdeui/kernel/kapplication.cpp:311
#38 0x00007f742f60f71c in QCoreApplication::notifyInternal (this=0x7fffd8211da0, receiver=0xe543cb0, event=0xe543c00) at kernel/qcoreapplication.cpp:946
#39 0x00007f742f612fca in sendEvent (event=0xe543c00, receiver=0xe543cb0) at kernel/qcoreapplication.h:231
#40 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x29342a0) at kernel/qcoreapplication.cpp:1570
#41 0x00007f742f63e5a3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#42 postEventSourceDispatch (s=0x29df640) at kernel/qeventdispatcher_glib.cpp:279
#43 0x00007f742689e7d5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#44 0x00007f742689eb08 in ?? () from /usr/lib64/libglib-2.0.so.0
#45 0x00007f742689ebc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#46 0x00007f742f63e9cf in QEventDispatcherGlib::processEvents (this=0x2939b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#47 0x00007f74300b9abe in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#48 0x00007f742f60e252 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#49 0x00007f742f60e4a7 in QEventLoop::exec (this=0x7fffd8211780, flags=...) at kernel/qeventloop.cpp:204
#50 0x00007f742f6132c5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#51 0x00000000004a11a8 in main (argc=5, argv=0x7fffd8211fd8) at /usr/src/debug/digikam-4.4.0/core/app/main/main.cpp:236

Possible duplicates by query: bug 335293, bug 329829, bug 328827, bug 328784, bug 327714.

Reported using DrKonqi
Comment 1 caulier.gilles 2014-11-01 19:17:06 UTC

*** This bug has been marked as a duplicate of bug 310798 ***
Comment 2 caulier.gilles 2019-07-28 01:58:34 UTC
Fixed with bug #310798