Bug 339525 - kmix won't show in system tray
Summary: kmix won't show in system tray
Status: RESOLVED WORKSFORME
Alias: None
Product: kmix
Classification: Unclassified
Component: KMix Panel Docking (show other bugs)
Version: 4.5
Platform: Debian testing Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-30 09:54 UTC by adri58
Modified: 2021-03-08 04:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description adri58 2014-09-30 09:54:51 UTC
Hi

At system boot sound starts normally but kmix won't show in system tray. I 
must run from the konsole to show.


Reproducible: Always

Steps to Reproduce:
Boot the computer



Actual Results:  
Sound works fine but there is no kmix icon in the system tray

Expected Results:  
The kmix icon should be present in the system tray

Here's the output of the terminal when running "kmix":

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
KGlobal::locale(): Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work
kmix(6033) GlobalConfig::GlobalConfig: "Orientation" "Vertical"
kmix(6033) GlobalConfig::GlobalConfig: "Orientation" "Vertical"
kmix(6033) Mixer::setGlobalMaster: ref_card= "PulseAudio::Playback_Devices:1" , ref_control= "alsa_output.pci-0000_00_1b.0.analog-stereo" , preferred= true
kmix(6033) Mixer::setGlobalMaster: Mixer::setGlobalMaster() card= "PulseAudio::Playback_Devices:1"  control= "alsa_output.pci-0000_00_1b.0.analog-stereo"
kmix(6033) KMixWindow::loadBaseConfig: Backends:  ()
kmix(6033) KMixPrefDlg::updateWidgets:
kmix(6033) KMixPrefDlg::hasChanged: Orientation MAIN fromConfig= Vert , fromWidget= Vert
kmix(6033) KMixPrefDlg::hasChanged: Orientation TRAY fromConfig= Vert , fromWidget= Vert
kmix(6033) KMixPrefDlg::hasChanged: hasChanged= false
kmix(6033) KMixPrefDlg::hasChanged: Orientation MAIN fromConfig= Vert , fromWidget= Vert
kmix(6033) KMixPrefDlg::hasChanged: Orientation TRAY fromConfig= Vert , fromWidget= Vert
kmix(6033) KMixPrefDlg::hasChanged: hasChanged= false
kmix(6033) MixerToolBox::initMixerInternal: multiDriverMode= 1 , backendList= ()
kmix(6033) MixerToolBox::initMixerInternal: Looking for mixers with the :  "PulseAudio"  driver
kmix(6033) Mixer_PULSE::Mixer_PULSE: Probing for PulseAudio...
kmix(6033) source_cb: Ignoring Monitor Source:  Monitor of Barts HDMI Audio [Radeon HD 6800 Series] Digital Surround 5.1 (HDMI)
kmix(6033) source_cb: Ignoring Monitor Source:  Monitor of Audio Interno Estéreo Analógico
kmix(6033) Mixer_PULSE::Mixer_PULSE: PulseAudio probe complete.
kmix(6033) Mixer_PULSE::connectToDaemon: Attempting connection to PulseAudio sound daemon
kmix(6033) Mixer_PULSE::Mixer_PULSE: PulseAudio status:  Active
kmix(6033) Mixer_Backend::registerCard: cardBaseName= "Dispositivos de reproducción" , cardDiscriminator= 1
kmix(6033) Mixer_PULSE::addDevice: Adding Pulse volume  "alsa_output.pci-0000_01_00.1.hdmi-surround" , isCapture=  false , isAppStream=  false = false , devnum= 0
kmix(6033) Mixer::recreateId: Early _id= "PulseAudio::Playback_Devices:1"
kmix(6033) Mixer_PULSE::addDevice: Adding Pulse volume  "alsa_output.pci-0000_00_1b.0.analog-stereo" , isCapture=  false , isAppStream=  false = false , devnum= 0
kmix(6033) Mixer_PULSE::updateRecommendedMaster: Selecting master  "alsa_output.pci-0000_00_1b.0.analog-stereo"  for type  0
kmix(6033) Mixer_PULSE::open: Using PulseAudio for mixer:  "Dispositivos de reproducción"
kmix(6033) Mixer::recreateId: Early _id= "PulseAudio::Playback_Devices:1"
kmix(6033) Mixer::openIfValid: Mixer::open() detected master:  "alsa_output.pci-0000_00_1b.0.analog-stereo"
kmix(6033) DBusMixerWrapper::DBusMixerWrapper: Create QDBusConnection for object  "/Mixers/PulseAudio__Playback_Devices_1"
kmix(6033) MixerToolBox::possiblyAddMixer: Added card  "PulseAudio::Playback_Devices:1"
kmix(6033) MixerToolBox::initMixerInternal: Success! Found a mixer with the :  "PulseAudio"  driver
kmix(6033) Mixer_Backend::registerCard: cardBaseName= "Dispositivos de captura" , cardDiscriminator= 1
kmix(6033) Mixer_PULSE::open: Using PulseAudio for mixer:  "Dispositivos de captura"
kmix(6033) Mixer::recreateId: Early _id= "PulseAudio::Capture_Devices:1"
kmix(6033) DBusMixerWrapper::DBusMixerWrapper: Create QDBusConnection for object  "/Mixers/PulseAudio__Capture_Devices_1"
kmix(6033) MixerToolBox::possiblyAddMixer: Added card  "PulseAudio::Capture_Devices:1"
kmix(6033) MixerToolBox::initMixerInternal: Success! Found a mixer with the :  "PulseAudio"  driver
kmix(6033) Mixer_Backend::registerCard: cardBaseName= "Flujos de reproducción" , cardDiscriminator= 1
kmix(6033) Mixer_PULSE::open: Using PulseAudio for mixer:  "Flujos de reproducción"
kmix(6033) Mixer::recreateId: Early _id= "PulseAudio::Playback_Streams:1"
kmix(6033) DBusMixerWrapper::DBusMixerWrapper: Create QDBusConnection for object  "/Mixers/PulseAudio__Playback_Streams_1"
kmix(6033) MixerToolBox::possiblyAddMixer: Added card  "PulseAudio::Playback_Streams:1"
kmix(6033) MixerToolBox::initMixerInternal: Success! Found a mixer with the :  "PulseAudio"  driver
kmix(6033) Mixer_Backend::registerCard: cardBaseName= "Flujos de captura" , cardDiscriminator= 1
kmix(6033) Mixer_PULSE::open: Using PulseAudio for mixer:  "Flujos de captura"
kmix(6033) Mixer::recreateId: Early _id= "PulseAudio::Capture_Streams:1"
kmix(6033) DBusMixerWrapper::DBusMixerWrapper: Create QDBusConnection for object  "/Mixers/PulseAudio__Capture_Streams_1"
kmix(6033) MixerToolBox::possiblyAddMixer: Added card  "PulseAudio::Capture_Streams:1"
kmix(6033) MixerToolBox::initMixerInternal: Success! Found a mixer with the :  "PulseAudio"  driver
kmix(6033) MixerToolBox::initMixerInternal: "Controladores de sonido aceptados: PulseAudio + ALSA + OSS + MPRIS2
Controladores de sonido utilizados: PulseAudio"
Total number of detected Mixers:  4
kmix(6033) KMixWindow::recreateGUI: Using fallback GUI Profile for the mixer  "PulseAudio::Playback_Devices:1"
kmix(6033) GUIProfile::buildReadableProfileName: "Dispositivos de reproducción"
kmix(6033) GUIProfile::addProfile: I have added "PulseAudio.Dispositivos_de_reproducción.1.default" ; Number of profiles is now  1
kmix(6033) KMixWindow::addMixerWidget: Add  "PulseAudio.Dispositivos_de_reproducción.1.default"
kmix(6033) ViewBase::load: KMixToolBox::loadView() grp= "View.PulseAudio.Dispositivos_de_reproducción.1.default"
kmix(6033) KMixWindow::recreateGUI: Using fallback GUI Profile for the mixer  "PulseAudio::Capture_Devices:1"
kmix(6033) GUIProfile::buildReadableProfileName: "Dispositivos de captura"
kmix(6033) GUIProfile::addProfile: I have added "PulseAudio.Dispositivos_de_captura.1.default" ; Number of profiles is now  2
kmix(6033) KMixWindow::addMixerWidget: Add  "PulseAudio.Dispositivos_de_captura.1.default"
kmix(6033) ViewBase::load: KMixToolBox::loadView() grp= "View.PulseAudio.Dispositivos_de_captura.1.default"
kmix(6033) KMixWindow::recreateGUI: Using fallback GUI Profile for the mixer  "PulseAudio::Playback_Streams:1"
kmix(6033) GUIProfile::buildReadableProfileName: "Flujos de reproducción"
kmix(6033) GUIProfile::addProfile: I have added "PulseAudio.Flujos_de_reproducción.1.default" ; Number of profiles is now  3
kmix(6033) KMixWindow::addMixerWidget: Add  "PulseAudio.Flujos_de_reproducción.1.default"
kmix(6033) ViewBase::load: KMixToolBox::loadView() grp= "View.PulseAudio.Flujos_de_reproducción.1.default"
kmix(6033) KMixWindow::recreateGUI: Using fallback GUI Profile for the mixer  "PulseAudio::Capture_Streams:1"
kmix(6033) GUIProfile::buildReadableProfileName: "Flujos de captura"
kmix(6033) GUIProfile::addProfile: I have added "PulseAudio.Flujos_de_captura.1.default" ; Number of profiles is now  4
kmix(6033) KMixWindow::addMixerWidget: Add  "PulseAudio.Flujos_de_captura.1.default"
kmix(6033) ViewBase::load: KMixToolBox::loadView() grp= "View.PulseAudio.Flujos_de_captura.1.default"
Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QString)
Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QString)
kmix(6033) source_cb: Ignoring Monitor Source:  Monitor of Barts HDMI Audio [Radeon HD 6800 Series] Digital Surround 5.1 (HDMI)
kmix(6033) source_cb: Ignoring Monitor Source:  Monitor of Audio Interno Estéreo Analógico
kmix(6033) Mixer_PULSE::addDevice: Adding Pulse volume  "restore:sink-input-by-media-role:event" , isCapture=  false , isAppStream=  true = true , devnum= 2
kmix(6033) Mixer_PULSE::updateRecommendedMaster: Selecting master  "restore:sink-input-by-media-role:event"  for type  2
kmix(6033) dec_outstanding: Reconnected to PulseAudio
kmix(6033) Mixer_PULSE::pulseControlsReconfigured: Reconfigure  "PulseAudio::Playback_Streams:1"
Comment 1 Sean 2014-12-01 20:06:40 UTC
I have the same problem but my kmix doesn't run at all after the QDBusConnection error, so I have no sound at the moment.

Audio:     Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller driver: snd_hda_intel
           Card-2 NVIDIA GF108 High Definition Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k3.16.7.1-1-MANJARO
Comment 2 Christian Esken 2015-01-06 22:29:36 UTC
Git commit 91284ff2561ba9627dfe47d21593f472df9ffa8e by Christian Esken.
Committed on 06/01/2015 at 22:29.
Pushed by esken into branch 'master'.

Add a Lock to avoid duplicate initializiation, which may help with some
startup issues (delays, lockups). Not likely a solutin for all, but
please test. Also some ceanups, less logging and fixing a small memleak.
Related: bug 318986, bug 339272, bug 317926

M  +1    -0    CMakeLists.txt
M  +122  -59   apps/KMixApp.cpp
M  +7    -10   apps/KMixApp.h
M  +2    -7    apps/kmix.cpp
M  +1    -0    apps/main.cpp
M  +1    -1    backends/mixer_mpris2.cpp
M  +4    -4    backends/mixer_pulse.cpp
M  +4    -2    core/GlobalConfig.cpp
M  +13   -0    core/GlobalConfig.h
M  +2    -1    core/mixdevice.cpp
M  +2    -2    core/mixer.cpp
M  +14   -7    gui/kmixprefdlg.cpp
M  +2    -2    gui/viewbase.cpp

http://commits.kde.org/kmix/91284ff2561ba9627dfe47d21593f472df9ffa8e
Comment 3 Jonathan Marten 2021-02-06 17:03:20 UTC
Please confirm if this is still a problem with current KMix and Plasma.
Comment 4 Bug Janitor Service 2021-02-21 04:33:11 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Bug Janitor Service 2021-03-08 04:33:34 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!