Bug 339272 - KMixCtrl crash during user session start breaks plasma
Summary: KMixCtrl crash during user session start breaks plasma
Status: RESOLVED WORKSFORME
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-21 16:14 UTC by tommy
Modified: 2018-11-30 04:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tommy 2014-09-21 16:14:44 UTC
openSUSE 13.1 x86-64, KDE 5.
KMixCtrl crashes itself and plasma when I try to log in. The wallpapers disappear (and plasmoids and panels do not appear), and only movable mouse plasma-style pointer and a window "Send error report" are shown, but it's impossible either to send the report or to save it on hard-disk, so I provide a reprinted log below:

Application: KMixCtrl (kmixctrl), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa0110c28c0 (LWP 645))]

Thread 2 (Thread 0x7f9ffdc28700 (LWP 648)):
#0 0x00007fa0109c47bd in poll () from /lib64/libc.so.6
#1 0x00007fa005eff0e2 in ?? () from /usr/lib64/libxcb.so.1
#2 0x00007fa005f0077f in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3 0x00007f9fff91dea9 in ?? () from /usr/lib64/qt5/plugins/platforms/libqxcb.so
#4 0x00007fa00f9c1e6f in QThreadPrivate::start (arg=0xade030) at thread/qthread_Unix.cpp:345
#5 0x00007fa0109cd58d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fa0110c28c0 (LWP 645)):
[KCrash Handler]
#5 0x00007fa01091b4c9 in raise () from /lib64/libc.so.6
#6 0x00007fa01091c958 in abort () from /lib64/libc.so.6
#7 0x00007fa00f9b1f85 in qt_message_fatal (context=..., message=...) at global/qlogging.cpp:1364
#8 qt_message_output (msgType=<optimized out>, context=..., message=...) at global/qlogging.cpp:1378
#9 0x00007fa0100c0240 in QDebug::~QDebug (this=0x7fff82196d70, __in_chrg=<optimized out>) at /usr/include/qt5/QtCore/QDebug.h:89
#10 0x00007fa01015d235 in KApplicationPrivate::init (this=0xb36790, GUIenabled=GUIenabled@entry=false) at /usr/src/debug/kdelibs4support-5.3.0git/src/kdeui/kapplication.cpp:416
#11 0x00007fa01015e4e3 in KApplication::KApplication (this=0x7fff82196f70, GUIenabled=false) at /usr/src/debug/kdelibs4support-5.3.0git/src/kdeui/kapplication.cpp:310
#12 0x00007fa010cc0d90 in kdemain () from /usr/lib64/libkdeinit5_KMixCtrl.so
#13 0x00007fa010907be5 in __libc_start_main () from /lib64/libc.so.6
#14 0x00000000004007f1 in start ()

Alt F2 and other keyboard shortcuts have no effect, only shortcuts for shutting down/rebooting act well. 

That sometimes happens for the first user account and always for the second.

Reproducible: Sometimes

Steps to Reproduce:
1. Try to login

Actual Results:  
If you're lucky, then you will login sucessfully. Otherwise after watching the login animation you will see black screen, mouse pointer and "Report Error" window.

Expected Results:  
Just a normal login.

Also there's no KMix icon in system tray, and system volume level is unchangable (same via keyboard). KMix5 installed, but maybe I need something else?
Comment 1 Christian Esken 2015-01-06 22:29:36 UTC
Git commit 91284ff2561ba9627dfe47d21593f472df9ffa8e by Christian Esken.
Committed on 06/01/2015 at 22:29.
Pushed by esken into branch 'master'.

Add a Lock to avoid duplicate initializiation, which may help with some
startup issues (delays, lockups). Not likely a solutin for all, but
please test. Also some ceanups, less logging and fixing a small memleak.
Related: bug 318986, bug 339525, bug 317926

M  +1    -0    CMakeLists.txt
M  +122  -59   apps/KMixApp.cpp
M  +7    -10   apps/KMixApp.h
M  +2    -7    apps/kmix.cpp
M  +1    -0    apps/main.cpp
M  +1    -1    backends/mixer_mpris2.cpp
M  +4    -4    backends/mixer_pulse.cpp
M  +4    -2    core/GlobalConfig.cpp
M  +13   -0    core/GlobalConfig.h
M  +2    -1    core/mixdevice.cpp
M  +2    -2    core/mixer.cpp
M  +14   -7    gui/kmixprefdlg.cpp
M  +2    -2    gui/viewbase.cpp

http://commits.kde.org/kmix/91284ff2561ba9627dfe47d21593f472df9ffa8e
Comment 2 Andrew Crouthamel 2018-10-31 04:03:01 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2018-11-15 10:48:59 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2018-11-30 04:01:57 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!