Bug 338555 - CatalystControlCenter.exe stop to run while digiKam installation
Summary: CatalystControlCenter.exe stop to run while digiKam installation
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Bundle-Windows (show other bugs)
Version: 4.2.0
Platform: Microsoft Windows Microsoft Windows
: NOR minor (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-25 19:19 UTC by MBB
Modified: 2020-08-10 10:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.8.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MBB 2014-08-25 19:19:08 UTC
This is a confirmation/ repeat of a part of bug 312422
https://bugs.kde.org/show_bug.cgi?id=312422

OS	Windows 7x64
video	ATI Radeon Mobility HD 5145 [NB: this is a renamed 4x sries, not a 5x]
Driver	8.692.1.0  	22-01-2010
Digikam  4.2.0-win32-2.exe


Crash happens on Digikam install 4.2(.2) , *and* uninstall 3.8, (back during original install too). 
The crash happens after starting the installer, before "Choose a start menu folder". The install self finishes okay, and the program starts normally. 

error: 
Catalyst control Centre: Host application error:
Catalyst control Centre: Host application has stopped working
crash report box offers options:
"Debug or close program:"
CCC.exe no debugger found
No registered JIT debugger was specified

--
It is not really a problem for me, as 
- I haven't really used Digikam yet, .
- I do not use CCC, 
- it only happens during (un)install and 
- it is easy to restart ccc.exe

But I thought I call it in, in case there is a deeper cause that can help solve other problems. 
Also I am curious about why, as I do not see a reason why it should take down the video driver control center. 

PS: I had, at one time, had KDE for Windows installed to get Digikam (2x?), but it did not work as I thougt and I removed it)

PS: Digikam>Help>about> shows KDE platform version 4.10.2 , not 4.2.0
Comment 1 caulier.gilles 2014-11-16 10:02:15 UTC
Please try again with the new digiKam 4.5.0 for windows

http://download.kde.org/stable/digikam/digiKam-installer-4.5.0-win32.exe.mirrorlist

Gilles Caulier
Comment 2 MBB 2014-11-29 23:02:02 UTC
Thank you for taking the time to address my bug. 
My apologies for taking my time to test, but I wanted to clean up my system a bit before re-installing. 
Unfortunately, it does not seem to have solved the problem. 
I aborted the install and tried again a few times after the CCC crash, but it keeps happening. 
(at one time the error changed to " Catalyst Control Center: Monitoring program has stopped working. " in stead of "CCC - Host application has stopped working", but the next time it was back to the old one. 

If you think it would help I could try to run a JIT-debugger  - I don't think Windows has one installed by default. 
(What is that Backtrace that  Laurent Soron was talking about in the linked bug?)

Can I follow the instructions on this site for that? 
https://techbase.kde.org/Projects/KDE_on_Windows/Tools#WinDbg
I can not find it on the MSDN site as I can only find about JIT debugging for Visual Studio (which I do not have), a Tool menu that does not show, and a setting in DotNet framework that is not there. 

I'll probably also try to update the AMD driver at some point, if I do I'll try to reinstall Digikam again. (I've been a little hesitant to update before as things ran fine otherwise, but maybe it's time...)
Comment 3 MBB 2014-12-13 12:23:45 UTC
Okay. I have  uninstalled Digikam with Iobit-Uninstaller, and manually removed all remaining traces from the old KDE from directories and register. 
(I do not remember it crashing CCC this time but I might have missed it)
Re-installed Digikam, still CCC crashed.


Then I uninstalled again (normally, it did crash CCC).
I installed the latest Legacy AMD drivers (2013 x64). (It gave me OpenCL :-) )

Re-installed Digikam, but still it takes out the Catalyst Control Center.
In fact, the menu now claims to be actively searching for conflicting software before crashing CCC - is it supposed to put a log file somewhere?

Perhaps you could ask Laurent Soron (from the cited bug report) if he is experiencing the CCC crash still as well?

Let me know if I can do anything else.
Comment 4 caulier.gilles 2017-12-16 10:17:01 UTC
This file still valid using current 5.8.0 pre release bundle available here :

https://files.kde.org/digikam/

Thanks in advance

Gilles Caulier
Comment 5 caulier.gilles 2018-01-07 16:08:16 UTC
This problem is not reproducible with 5.8.0. I close this file now. Reopen if
necessary.

Gilles Caulier
Comment 6 MBB 2018-02-17 17:40:50 UTC
I can confirm that it is fixed ( for me) with 5.8. 
Been over to win10 (Which did not have CCC), but recently went back to a clean Win7. It still happened with 5.7 but with 5.8 the crash no longer happens/ So something you recently did seems to have fixed it. :-)