Bug 338482 - digikam crash when importing pictures if no album was selected in the main window
Summary: digikam crash when importing pictures if no album was selected in the main wi...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Albums (show other bugs)
Version: 4.0.0
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-22 15:56 UTC by Frederic Grelot
Modified: 2021-04-04 16:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Grelot 2014-08-22 15:56:20 UTC
Application: digikam (4.0.0)
KDE Platform Version: 4.13.3
Qt Version: 4.8.6
Operating System: Linux 3.15.8-200.fc20.x86_64 x86_64
Distribution: "Fedora release 20 (Heisenbug)"

-- Information about the crash:
- What I was doing when the application crashed:
A camera SD card was inserted in the computer slot.
I started DK (at this point, no album is selected, and the main windows shows no picture), clicked on "import", selected pictures and clicked on "Download and delete selected". DK crashed immediately.
The crash is reproducible everytime.
Workaround : after launching DK, select an album (by default, no album is selected), then import the pictures.
I didn't try to delete digikamrc, since I don't want to :-)

The crash can be reproduced everytime.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f503c75bb40 (LWP 17686))]

Thread 6 (Thread 0x7f501110b700 (LWP 17688)):
#0  0x00007f503134dccd in recvmsg () from /lib64/libpthread.so.0
#1  0x00007f502ded0ed9 in udev_monitor_receive_device () from /lib64/libudev.so.1
#2  0x00007f502751444b in linux_udev_event_thread_main () from /lib64/libusb-1.0.so.0
#3  0x00007f5031346f33 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f50305eaded in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f5008bf2700 (LWP 17689)):
#0  0x00007f503134ad20 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f50315d8bd6 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib64/libQtCore.so.4
#2  0x00000000005f09ce in Digikam::ScanController::run (this=0x2936d60) at /usr/src/debug/digikam-4.0.0/core/digikam/database/scancontroller.cpp:725
#3  0x00007f50315d869f in QThreadPrivate::start(void*) () from /lib64/libQtCore.so.4
#4  0x00007f5031346f33 in start_thread () from /lib64/libpthread.so.0
#5  0x00007f50305eaded in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f5003fff700 (LWP 17690)):
#0  0x00007f50305e09dd in poll () from /lib64/libc.so.6
#1  0x00007f502c3f85b4 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#2  0x00007f502c3f86dc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f503171143e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#4  0x00007f50316e138f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#5  0x00007f50316e16dd in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#6  0x00007f50315d5e5f in QThread::exec() () from /lib64/libQtCore.so.4
#7  0x00007f50316c1de3 in QInotifyFileSystemWatcherEngine::run() () from /lib64/libQtCore.so.4
#8  0x00007f50315d869f in QThreadPrivate::start(void*) () from /lib64/libQtCore.so.4
#9  0x00007f5031346f33 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f50305eaded in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f50037fe700 (LWP 17692)):
#0  0x00007f503134ad20 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f50315d8bd6 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib64/libQtCore.so.4
#2  0x00007f50396fac1a in Digikam::ParkingThread::run (this=0x2d50440) at /usr/src/debug/digikam-4.0.0/core/libs/threads/threadmanager.cpp:119
#3  0x00007f50315d869f in QThreadPrivate::start(void*) () from /lib64/libQtCore.so.4
#4  0x00007f5031346f33 in start_thread () from /lib64/libpthread.so.0
#5  0x00007f50305eaded in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f4f57fff700 (LWP 18186)):
#0  0x00007f503134ad20 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f50315d8bd6 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib64/libQtCore.so.4
#2  0x0000000000806314 in Digikam::CameraController::run (this=0x54e86d0) at /usr/src/debug/digikam-4.0.0/core/utilities/importui/backend/cameracontroller.cpp:400
#3  0x00007f50315d869f in QThreadPrivate::start(void*) () from /lib64/libQtCore.so.4
#4  0x00007f5031346f33 in start_thread () from /lib64/libpthread.so.0
#5  0x00007f50305eaded in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f503c75bb40 (LWP 17686)):
[KCrash Handler]
#5  Digikam::Album::globalID (this=0x0) at /usr/src/debug/digikam-4.0.0/core/digikam/album/album.cpp:227
#6  0x00000000007f4003 in Digikam::ImportUI::slotDownload (this=this@entry=0x50c3090, onlySelected=onlySelected@entry=true, deleteAfter=deleteAfter@entry=true, album=album@entry=0x0) at /usr/src/debug/digikam-4.0.0/core/utilities/importui/main/importui.cpp:1475
#7  0x00000000007f50a9 in slotDownloadAndDeleteSelected (this=0x50c3090) at /usr/src/debug/digikam-4.0.0/core/utilities/importui/main/importui.cpp:1400
#8  Digikam::ImportUI::qt_static_metacall (_o=0x50c3090, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/digikam-4.0.0/x86_64-redhat-linux-gnu/core/utilities/importui/importui.moc:202
#9  0x00007f50316f737a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib64/libQtCore.so.4
#10 0x00007f503234a862 in QAction::triggered(bool) () from /lib64/libQtGui.so.4
#11 0x00007f503234c3f7 in QAction::activate(QAction::ActionEvent) () from /lib64/libQtGui.so.4
#12 0x00007f503279567d in QMenuPrivate::activateCausedStack(QList<QPointer<QWidget> > const&, QAction*, QAction::ActionEvent, bool) () from /lib64/libQtGui.so.4
#13 0x00007f5032799f19 in QMenuPrivate::activateAction(QAction*, QAction::ActionEvent, bool) () from /lib64/libQtGui.so.4
#14 0x00007f50331720ab in KMenu::mouseReleaseEvent(QMouseEvent*) () from /lib64/libkdeui.so.5
#15 0x00007f50323a3cc8 in QWidget::event(QEvent*) () from /lib64/libQtGui.so.4
#16 0x00007f503279df6b in QMenu::event(QEvent*) () from /lib64/libQtGui.so.4
#17 0x00007f5032350e5c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQtGui.so.4
#18 0x00007f50323578f1 in QApplication::notify(QObject*, QEvent*) () from /lib64/libQtGui.so.4
#19 0x00007f50330b159a in KApplication::notify(QObject*, QEvent*) () from /lib64/libkdeui.so.5
#20 0x00007f50316e28fd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /lib64/libQtCore.so.4
#21 0x00007f5032357067 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /lib64/libQtGui.so.4
#22 0x00007f50323cc96c in QETWidget::translateMouseEvent(_XEvent const*) () from /lib64/libQtGui.so.4
#23 0x00007f50323cb0ac in QApplication::x11ProcessEvent(_XEvent*) () from /lib64/libQtGui.so.4
#24 0x00007f50323f2ac4 in x11EventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQtGui.so.4
#25 0x00007f502c3f82a6 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#26 0x00007f502c3f8628 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#27 0x00007f502c3f86dc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#28 0x00007f503171143e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#29 0x00007f50323f2c46 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtGui.so.4
#30 0x00007f50316e138f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#31 0x00007f50316e16dd in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#32 0x00007f50316e6da9 in QCoreApplication::exec() () from /lib64/libQtCore.so.4
#33 0x0000000000494bca in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/digikam-4.0.0/core/digikam/main/main.cpp:236

The reporter indicates this bug may be a duplicate of or related to bug 330676.

Possible duplicates by query: bug 335927, bug 335708.

Report to https://bugs.kde.org/
Comment 1 caulier.gilles 2014-08-22 19:00:24 UTC

*** This bug has been marked as a duplicate of bug 330676 ***
Comment 2 caulier.gilles 2021-04-04 16:55:48 UTC
Fixed with #330676