Bug 335708 - Crash on image import
Summary: Crash on image import
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Albums (show other bugs)
Version: 4.0.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-06-02 17:54 UTC by pbhj
Modified: 2019-12-25 15:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pbhj 2014-06-02 17:54:49 UTC
Application: digikam (4.0.0)
KDE Platform Version: 4.13.0
Qt Version: 4.8.6
Operating System: Linux 3.13.0-24-generic x86_64
Distribution: Ubuntu 14.04 LTS

-- Information about the crash:
- What I was doing when the application crashed: importing a selection of images from the camera (including videos), using the "download and delete selection" option.

The crash can be reproduced sometimes.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f08d8088ac0 (LWP 7160))]

Thread 7 (Thread 0x7f08b39ba700 (LWP 7165)):
#0  0x00007f08d11dcfbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f08b8565248 in ?? () from /lib/x86_64-linux-gnu/libusb-1.0.so.0
#2  0x00007f08cd210182 in start_thread (arg=0x7f08b39ba700) at pthread_create.c:312
#3  0x00007f08d11ea30d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 6 (Thread 0x7f08ace09700 (LWP 7166)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f08d1fcb816 in wait (time=18446744073709551615, this=0x1734e60) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x1712b50, mutex=mutex@entry=0x1712b48, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005e3d9e in Digikam::ScanController::run (this=0x1735120) at /build/buildd/digikam-4.0.0/core/digikam/database/scancontroller.cpp:725
#4  0x00007f08d1fcb32f in QThreadPrivate::start (arg=0x1735120) at thread/qthread_unix.cpp:349
#5  0x00007f08cd210182 in start_thread (arg=0x7f08ace09700) at pthread_create.c:312
#6  0x00007f08d11ea30d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 5 (Thread 0x7f08a7fff700 (LWP 7167)):
#0  0x00007f08d11db6bd in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f08ca163c20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f08ca122b14 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f08ca122f7b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f08ca1230ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f08d20fa7be in QEventDispatcherGlib::processEvents (this=0x7f08a00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f08d20cc0af in QEventLoop::processEvents (this=this@entry=0x7f08a7ffeae0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f08d20cc3a5 in QEventLoop::exec (this=this@entry=0x7f08a7ffeae0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f08d1fc8c5f in QThread::exec (this=this@entry=0x164e840) at thread/qthread.cpp:537
#9  0x00007f08d20ad823 in QInotifyFileSystemWatcherEngine::run (this=0x164e840) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f08d1fcb32f in QThreadPrivate::start (arg=0x164e840) at thread/qthread_unix.cpp:349
#11 0x00007f08cd210182 in start_thread (arg=0x7f08a7fff700) at pthread_create.c:312
#12 0x00007f08d11ea30d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 4 (Thread 0x7f08a77fe700 (LWP 7169)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f08d1fcb816 in wait (time=18446744073709551615, this=0x1d01740) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x1de3d00, mutex=mutex@entry=0x1de3cf8, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f08d570e8aa in Digikam::ParkingThread::run (this=0x1de3ce0) at /build/buildd/digikam-4.0.0/core/libs/threads/threadmanager.cpp:119
#4  0x00007f08d1fcb32f in QThreadPrivate::start (arg=0x1de3ce0) at thread/qthread_unix.cpp:349
#5  0x00007f08cd210182 in start_thread (arg=0x7f08a77fe700) at pthread_create.c:312
#6  0x00007f08d11ea30d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f08a6985700 (LWP 7170)):
#0  0x00007f08d11db6bd in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f08ca163c20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f08ca122b14 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f08ca122f7b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f08ca1230ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f08d20fa7be in QEventDispatcherGlib::processEvents (this=0x7f089c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f08d20cc0af in QEventLoop::processEvents (this=this@entry=0x7f08a6984ae0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f08d20cc3a5 in QEventLoop::exec (this=this@entry=0x7f08a6984ae0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f08d1fc8c5f in QThread::exec (this=this@entry=0x292d7c0) at thread/qthread.cpp:537
#9  0x00007f08d20ad823 in QInotifyFileSystemWatcherEngine::run (this=0x292d7c0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f08d1fcb32f in QThreadPrivate::start (arg=0x292d7c0) at thread/qthread_unix.cpp:349
#11 0x00007f08cd210182 in start_thread (arg=0x7f08a6985700) at pthread_create.c:312
#12 0x00007f08d11ea30d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f0844ac9700 (LWP 7317)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f08d1fcb816 in wait (time=18446744073709551615, this=0x6a09240) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x69be888, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000007e585c in Digikam::CameraController::run (this=0x6a09050) at /build/buildd/digikam-4.0.0/core/utilities/importui/backend/cameracontroller.cpp:400
#4  0x00007f08d1fcb32f in QThreadPrivate::start (arg=0x6a09050) at thread/qthread_unix.cpp:349
#5  0x00007f08cd210182 in start_thread (arg=0x7f0844ac9700) at pthread_create.c:312
#6  0x00007f08d11ea30d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f08d8088ac0 (LWP 7160)):
[KCrash Handler]
#6  Digikam::Album::globalID (this=0x0) at /build/buildd/digikam-4.0.0/core/digikam/album/album.cpp:227
#7  0x00000000007d3d43 in Digikam::ImportUI::slotDownload (this=0x526e100, onlySelected=<optimized out>, deleteAfter=<optimized out>, album=0x0) at /build/buildd/digikam-4.0.0/core/utilities/importui/main/importui.cpp:1475
#8  0x00000000007d4cf9 in slotDownloadAndDeleteSelected (this=<optimized out>) at /build/buildd/digikam-4.0.0/core/utilities/importui/main/importui.cpp:1400
#9  Digikam::ImportUI::qt_static_metacall (_o=0x526e100, _c=76337608, _id=0, _a=0x10) at /build/buildd/digikam-4.0.0/obj-x86_64-linux-gnu/core/utilities/importui/importui.moc:202
#10 0x00007f08d20e187a in QMetaObject::activate (sender=sender@entry=0x6a10e40, m=m@entry=0x7f08d3569de0 <QAction::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fff177df5b0) at kernel/qobject.cpp:3539
#11 0x00007f08d2ab9a62 in QAction::triggered (this=this@entry=0x6a10e40, _t1=false) at .moc/release-shared/moc_qaction.cpp:276
#12 0x00007f08d2abb433 in QAction::activate (this=this@entry=0x6a10e40, event=event@entry=QAction::Trigger) at kernel/qaction.cpp:1257
#13 0x00007f08d2ee9489 in QMenuPrivate::activateCausedStack (this=this@entry=0x6a3d030, causedStack=..., action=action@entry=0x6a10e40, action_e=action_e@entry=QAction::Trigger, self=self@entry=true) at widgets/qmenu.cpp:1038
#14 0x00007f08d2eed9b9 in QMenuPrivate::activateAction (this=0x6a3d030, action=0x6a10e40, action_e=action_e@entry=QAction::Trigger, self=self@entry=true) at widgets/qmenu.cpp:1130
#15 0x00007f08d2ef1385 in QMenu::mouseReleaseEvent (this=this@entry=0x6a5fcd0, e=e@entry=0x7fff177dfce0) at widgets/qmenu.cpp:2372
#16 0x00007f08d38814f5 in KMenu::mouseReleaseEvent (this=0x6a5fcd0, e=0x7fff177dfce0) at ../../kdeui/widgets/kmenu.cpp:464
#17 0x00007f08d2b0f50a in QWidget::event (this=this@entry=0x6a5fcd0, event=event@entry=0x7fff177dfce0) at kernel/qwidget.cpp:8376
#18 0x00007f08d2ef17bb in QMenu::event (this=0x6a5fcd0, e=0x7fff177dfce0) at widgets/qmenu.cpp:2481
#19 0x00007f08d2abfe2c in QApplicationPrivate::notify_helper (this=this@entry=0x151f540, receiver=receiver@entry=0x6a5fcd0, e=e@entry=0x7fff177dfce0) at kernel/qapplication.cpp:4567
#20 0x00007f08d2ac65dd in QApplication::notify (this=this@entry=0x7fff177e0920, receiver=receiver@entry=0x6a5fcd0, e=e@entry=0x7fff177dfce0) at kernel/qapplication.cpp:4110
#21 0x00007f08d37cabaa in KApplication::notify (this=0x7fff177e0920, receiver=0x6a5fcd0, event=0x7fff177dfce0) at ../../kdeui/kernel/kapplication.cpp:311
#22 0x00007f08d20cd4dd in QCoreApplication::notifyInternal (this=0x7fff177e0920, receiver=receiver@entry=0x6a5fcd0, event=event@entry=0x7fff177dfce0) at kernel/qcoreapplication.cpp:953
#23 0x00007f08d2ac5d93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0x6a5fcd0, event=event@entry=0x7fff177dfce0, alienWidget=alienWidget@entry=0x0, nativeWidget=nativeWidget@entry=0x6a5fcd0, buttonDown=buttonDown@entry=0x7f08d35a5318 <qt_button_down>, lastMouseReceiver=..., spontaneous=spontaneous@entry=true) at kernel/qapplication.cpp:3178
#25 0x00007f08d2b3acfc in QETWidget::translateMouseEvent (this=this@entry=0x6a5fcd0, event=event@entry=0x7fff177e0030) at kernel/qapplication_x11.cpp:4568
#26 0x00007f08d2b3a269 in QApplication::x11ProcessEvent (this=0x7fff177e0920, event=event@entry=0x7fff177e0030) at kernel/qapplication_x11.cpp:3627
#27 0x00007f08d2b61b02 in x11EventSourceDispatch (s=0x151c400, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#28 0x00007f08ca122e04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f08ca123048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f08ca1230ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f08d20fa7be in QEventDispatcherGlib::processEvents (this=0x1440020, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#32 0x00007f08d2b61bb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f08d20cc0af in QEventLoop::processEvents (this=this@entry=0x7fff177e0400, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f08d20cc3a5 in QEventLoop::exec (this=this@entry=0x7fff177e0400, flags=...) at kernel/qeventloop.cpp:204
#35 0x00007f08d20d1b79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#36 0x00007f08d2abe37c in QApplication::exec () at kernel/qapplication.cpp:3828
#37 0x00000000004948f0 in main (argc=<optimized out>, argv=<optimized out>) at /build/buildd/digikam-4.0.0/core/digikam/main/main.cpp:236

Reported using DrKonqi
Comment 1 pbhj 2014-06-02 18:21:20 UTC
It's possible this was caused by low camera battery.
Comment 2 caulier.gilles 2014-06-02 18:59:25 UTC
Not sure. If it's the case, it's easy reproducible. Power off camera during downloading...

Gilles Caulier
Comment 3 Jekyll Wu 2014-06-03 00:42:48 UTC

*** This bug has been marked as a duplicate of bug 330676 ***
Comment 4 caulier.gilles 2019-12-25 15:45:03 UTC
Not reproducible using digiKam 7.0.0 beta1.