Bug 338249 - Digikam uses all free memory and gets terminated
Summary: Digikam uses all free memory and gets terminated
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Sqlite (show other bugs)
Version: 4.2.0
Platform: Kubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-13 21:05 UTC by Micha
Modified: 2019-12-24 08:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Micha 2014-08-13 21:05:30 UTC
After a long time in which I've been unable to use Digikam due to an unrelated crash in phonon library, I finally managed to get it to install and run today.  I get the splash screen, then the main window.  The main window shows a progress bar (apparently for scanning my albums) which completes in about 26 seconds and I get a "no active process" message.  However, at the same time (i.e. right afer the main window is shown) Digikam starts using all available CPU resources (400%) and locking memory at a very high rate, until it gets to 70-80% of system memory, then I have a few minutes of swapping in which the system is unusable, and finally memory is fully exhausted and the system terminates Digikam.  It does not matter if I close the main window after it starts to use CPU and memory, the digikam process would not disappear and continues to use resources until it gets terminated.  I don't know what is being done behind the scenes (as far as I can tell Digikam doesn't generate a log file) but in the past I've been able to use Digikam (up to 3.4.0 I believe) with the same image collection.  The issue exists in 4.2.0 and I've also tried 4.1.0 and 3.5.0 with the same result.
Comment 1 caulier.gilles 2014-08-13 21:56:20 UTC

*** This bug has been marked as a duplicate of bug 323888 ***
Comment 2 Maik Qualmann 2017-12-17 19:49:38 UTC
Git commit 6a9fd9891a3ff341dc42fe36158cbf0101d513b6 by Maik Qualmann.
Committed on 17/12/2017 at 19:20.
Pushed by mqualmann into branch 'master'.

delete threads from memory when they are finished
Related: bug 375317, bug 375035, bug 321784, bug 325712, bug 328732, bug 330227, bug 331912, bug 344661, bug 345395, bug 350549, bug 381877, bug 329651, bug 329091, bug 387821, bug 381222

M  +2    -1    NEWS
M  +25   -0    libs/database/dbjobs/dbjobsmanager.cpp
M  +35   -0    libs/iojobs/iojobsmanager.cpp

https://commits.kde.org/digikam/6a9fd9891a3ff341dc42fe36158cbf0101d513b6
Comment 3 caulier.gilles 2017-12-17 20:03:43 UTC
Following this commit:

https://commits.kde.org/digikam/6a9fd9891a3ff341dc42fe36158cbf0101d513b6

... the approach to fix this problem is under way and new digiKam 5.8.0 pre-release bundles will be compiled tonight to lets a chance to end-users to give a feedback about this fix before the 5.8.0 official release planed before Christmas 2017.

The bundles will be available in 2 hours at this url:

https://files.kde.org/digikam/

Please do not waste time to test if this file is always valid for next 5.8.0.

Thanks in advance

Gilles Caulier
Comment 4 caulier.gilles 2019-12-24 08:51:33 UTC
Not reproducible with 7.0.0-beta1